Jump to content

[SOLVED] Attributes Not Applying


Recommended Posts

 I have no idea if I'm doing this even near right but when I spawn a chicken next to a zombie I get this error "Can't find attribute minecraft:generic.attack_damage" error.

package me.prouddesk.proudmod.proudmod.common.events;

import me.prouddesk.proudmod.proudmod.ProudMod;
import net.minecraft.entity.Entity;
import net.minecraft.entity.EntityType;
import net.minecraft.entity.ai.attributes.Attributes;
import net.minecraft.entity.ai.goal.*;
import net.minecraft.entity.monster.ZombieEntity;
import net.minecraft.entity.passive.ChickenEntity;
import net.minecraftforge.event.entity.EntityAttributeModificationEvent;
import net.minecraftforge.event.entity.EntityJoinWorldEvent;
import net.minecraftforge.eventbus.api.SubscribeEvent;
import net.minecraftforge.fml.common.Mod;

@Mod.EventBusSubscriber(modid = ProudMod.MODID)
public class PlayerEvents {

    public static void onEntitySpawn(EntityJoinWorldEvent e)
        Entity mob = e.getEntity();
        if(mob instanceof ChickenEntity) {
            ChickenEntity chick = (ChickenEntity) mob;

            chick.goalSelector.addGoal(2, new MeleeAttackGoal(chick, 1.0D, false));
            chick.targetSelector.addGoal(2, new NearestAttackableTargetGoal<>(chick, ZombieEntity.class, true));

    public static void Attributes(EntityAttributeModificationEvent e) {
        e.add(EntityType.CHICKEN, Attributes.ATTACK_DAMAGE, 2.0D);
Edited by ProudDesk
Link to comment
Share on other sites

6 hours ago, DietmarKracht said:

You need to register your Attributes void to the Mod Eventbus.

How would I do that?  I tried to register the whole class by doing 


But that doesn't work.

Link to comment
Share on other sites

  • ProudDesk changed the title to Attributes Not Applying
  • ProudDesk changed the title to [SOLVED] Attributes Not Applying

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I created a server with the Pixelmon mod, it's fine and everything but a person enters and the server closes, I don't know how to explain it very well but I attach the detailed file of the error that happens to me https://mclo.gs/eSemvtq This error had not happened to me until now, so I don't understand very well why this happens, could you help me solve it?
    • When I create the server and log in it lets me play, but a person ends up joining and it sends me an error and the server closes The report says Exception in server tick Loop I put here what the console tells me because I honestly don't know how to explain it: https://mclo.gs/eSemvtq I use Forge mods and this has not happened to me until now 
    • Sorry I wasn't on this site for a few days. But anyways, if you just simply want to install forge to play with mods, you need to click on the installer option, thqat way, forge will be automatically installed to your device at the version you chose. Then you could just open Minecraft launcher to play on that version.
    • I've been putting together a modpack for a few weeks, and it's worked just fine. Until today, I logged onto my survival world and went exploring. As soon as I entered my boat the game froze and crashed. Now when I try to start the world, nothing loads and the game crashes. I tried creating a new world and the same thing happened when I tried to use a boat. Here's the latest crash report from the original world: If anyone knows how to fix the issue, I'd really appreciate the help, thanks.
    • I am using Geckolib to create custom entities, but I want to be able to enable/disable certain parts based on criteria. For example, a saddle layer would only show if the entity `isSaddled()`. I'm just not sure how to access individual model parts using the geo.json files. For now, I have created two separate models and I swap them based on the `object.isSaddled() method`:   @Override public ResourceLocation getModelResource(MyModdedEntity object) { return MODELS[object.isSaddled() ? 1 : 0]; }
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.