Jump to content

[1.6.2] [SOLVED] No LWJGL in java.library.path


Recommended Posts



So, today I wanted to update my mod to 1.6.2. However, places where GL11 is used did not work. I started minecraft and it crashed with this error

Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at org.lwjgl.Sys$1.run(Sys.java:73)
at java.security.AccessController.doPrivileged(Native Method)
at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
at org.lwjgl.Sys.loadLibrary(Sys.java:95)
at org.lwjgl.Sys.<clinit>(Sys.java:112)
at net.minecraft.client.Minecraft.getSystemTime(Minecraft.java:2444)
at net.minecraft.client.main.Main.main(Main.java:37)
at Start.main(Start.java:68)



I don't know what is wrong because LWJGL is in the Java Build path of my Minecraft Project. My Mod has "Minecraft" as a required project too.


Here's the .classpath for my "Msc Houses" project






Minecraft .classpath





Link to comment
Share on other sites

Configure the Java Build Path for your minecraft project.  Source Tab, expand the project, set the "Native library location" to where your natives are (forge/mcp/jars/versions/x/x-natives).


Well, that worked. But, I get this now:



Exception in thread "main" java.lang.NullPointerException
at java.util.logging.Logger.setParent(Unknown Source)
at net.minecraft.logging.LogAgent.setupLogger(LogAgent.java:33)
at net.minecraft.logging.LogAgent.<init>(LogAgent.java:25)
at net.minecraft.client.Minecraft.<init>(Minecraft.java:308)
at net.minecraft.client.main.Main.main(Main.java:77)
at Start.main(Start.java:68)


Link to comment
Share on other sites

I did that. But, it still crashes



Jul 15, 2013 12:05:54 PM net.minecraft.launchwrapper.LogWrapper log
INFO: Using tweak class name net.minecraft.launchwrapper.VanillaTweaker
Jul 15, 2013 12:05:58 PM net.minecraft.launchwrapper.LogWrapper log
SEVERE: Unable to launch
java.lang.NoSuchMethodException: net.minecraft.client.Minecraft.main([Ljava.lang.String;)
at java.lang.Class.getMethod(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:54)
at net.minecraft.launchwrapper.Launch.main(Launch.java:18)


Link to comment
Share on other sites

Edit your run configurations, Arguments tab, Program arguments:

--version 1.6 --tweakClass cpw.mods.fml.common.launcher.FMLTweaker


Also check to be sure your working directory on that tab also resolves to forge\mcp\jars

Link to comment
Share on other sites

  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.