Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

1.16.2 forge gradle wont work


Recommended Posts

this is the gradle idk what went wrong.

 

 

 

 

 

 

 

 

 

 

 

Last login: Sun Jul 11 10:00:41 on ttys000

cd desktop

cd codakid

cd/Users/iMac/.nvm/versions/io.js/v3.3.1/lib/node_modules/npm/bin/npm-cli.js:85

      let notifier = require('update-notifier')({pkg})

      ^^^

 

SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode

    at exports.runInThisContext (vm.js:53:16)

    at Module._compile (module.js:413:25)

    at Object.Module._extensions..js (module.js:448:10)

    at Module.load (module.js:355:32)

    at Function.Module._load (module.js:310:12)

    at Function.Module.runMain (module.js:471:10)

    at startup (node.js:117:18)

    at node.js:951:3

nvm is not compatible with the npm config "prefix" option: currently set to ""

Run `npm config delete prefix` or `nvm use --delete-prefix iojs-v3.3.1 --silent` to unset it.

iMacs-iMac:~ iMac$ cd desktop

iMacs-iMac:desktop iMac$ cd codakid

iMacs-iMac:codakid iMac$ cd "COdakid mod creation 1"

iMacs-iMac:COdakid mod creation 1 iMac$ cd projects

iMacs-iMac:projects iMac$ cd "Emera;d tools and combat"

-bash: cd: Emera;d tools and combat: No such file or directory

iMacs-iMac:projects iMac$ cd "Emerald tools and combat"

^[[AiMacs-iMac:Emerald tools and combat iMac$ cd "Emerald tools and combat"

-bash: cd: Emerald tools and combat: No such file or directory

iMacs-iMac:Emerald tools and combat iMac$ ./gradlew build

This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.

WARNING: You are using an unsupported version of ForgeGradle.

Please consider upgrading to ForgeGradle 4 and helping in the efforts to get old versions working on the modern toolchain.

See https://gist.github.com/TheCurle/fe7ad3ede188cbdd15c235cc75d52d4a for more info on contributing.

#################################################

         ForgeGradle 2.3.2-g62f3756        

  https://github.com/MinecraftForge/ForgeGradle  

#################################################

                 Powered by MCP                  

             http://modcoderpack.com            

     by: Searge, ProfMobius, R4wk, ZeuX          

     Fesh0r, IngisKahn, bspkrs, LexManos         

#################################################

:deobfCompileDummyTask

:getVersionJson

:extractUserdev

Download https://maven.minecraftforge.net/net/minecraftforge/forge/1.16.5-36.1.0/forge-1.16.5-36.1.0.pom

Download https://maven.minecraftforge.net/net/minecraftforge/forge/1.16.5-36.1.0/forge-1.16.5-36.1.0-userdev.jar

:downloadClient

:downloadServer

:splitServerJar

:mergeJars

:applyBinaryPatches FAILED

 

FAILURE: Build failed with an exception.

 

* What went wrong:

A problem was found with the configuration of task ':applyBinaryPatches'.

> File '/Users/iMac/.gradle/caches/minecraft/net/minecraftforge/forge/1.16.5-36.1.0/userdev/devbinpatches.pack.lzma' specified for property 'patches' does not exist.

 

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

 

BUILD FAILED

 

Total time: 43.369 secs

iMacs-iMac:Emerald tools and combat iMac$ 

Link to post
Share on other sites
  • Replies 74
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

it crashed /: 

 

 

 

 

 

 

 

Last login: Sun Jul 11 10:29:09 on ttys000

cd /Users/iMac/.nvm/versions/io.js/v3.3.1/lib/node_modules/npm/bin/npm-cli.js:85

      let notifier = require('update-notifier')({pkg})

      ^^^

 

SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode

    at exports.runInThisContext (vm.js:53:16)

    at Module._compile (module.js:413:25)

    at Object.Module._extensions..js (module.js:448:10)

    at Module.load (module.js:355:32)

    at Function.Module._load (module.js:310:12)

    at Function.Module.runMain (module.js:471:10)

    at startup (node.js:117:18)

    at node.js:951:3

nvm is not compatible with the npm config "prefix" option: currently set to ""

Run `npm config delete prefix` or `nvm use --delete-prefix iojs-v3.3.1 --silent` to unset it.

iMacs-iMac:~ iMac$ cd desktop

iMacs-iMac:desktop iMac$ cd codakid

iMacs-iMac:codakid iMac$ cd "Codakid mod creation 1"

iMacs-iMac:Codakid mod creation 1 iMac$ cd projects

iMacs-iMac:projects iMac$ cd "Emerald tools and combat"

iMacs-iMac:Emerald tools and combat iMac$ ./gradlew build

 

FAILURE: Build failed with an exception.

 

* Where:

Build file '/Users/iMac/Desktop/Codakid/Codakid Mod Creation 1/projects/Emerald Tools And combat/build.gradle' line: 8

 

* What went wrong:

Could not compile build file '/Users/iMac/Desktop/Codakid/Codakid Mod Creation 1/projects/Emerald Tools And combat/build.gradle'.

> startup failed:

  build file '/Users/iMac/Desktop/Codakid/Codakid Mod Creation 1/projects/Emerald Tools And combat/build.gradle': 8: unexpected token: } @ line 8, column 1.

     }

     ^

  

  1 error

 

 

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

 

BUILD FAILED

 

Total time: 3.396 secs

iMacs-iMac:Emerald tools and combat iMac$ 

Link to post
Share on other sites

another crash

 

 

 

 

 

 

 

 

 

 

* What went wrong:

Could not compile build file '/Users/iMac/Desktop/Codakid/Codakid Mod Creation 1/projects/Emerald Tools And combat/build.gradle'.

> startup failed:

  build file '/Users/iMac/Desktop/Codakid/Codakid Mod Creation 1/projects/Emerald Tools And combat/build.gradle': 148: expecting ''', found '\n' @ line 148, column 63.

     e': Emerald Tool's And Combat,

                                   ^

  

  1 error

 

 

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

 

BUILD FAILED

 

Total time: 1.401 secs

iMacs-iMac:Emerald tools and combat iMac$ 

Link to post
Share on other sites

ok jeez

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

FAILURE: Build failed with an exception.

 

* Where:

Build file '/Users/iMac/Desktop/Codakid/Codakid Mod Creation 1/projects/Emerald Tools And combat/build.gradle' line: 12

 

* What went wrong:

A problem occurred evaluating root project 'Emerald Tools And combat'.

> Failed to apply plugin [id 'net.minecraftforge.gradle']

   > Found Gradle version Gradle 2.14. Minimum required is Gradle 4.9.

 

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

 

BUILD FAILED

 

Total time: 2.127 secs

iMacs-iMac:Emerald tools and combat iMac$ 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.