Jump to content

1.16.X Loot Modifiers Only Run in Dev Environment [Solved]


urbanxx001

Recommended Posts

As the title says, everything runs perfectly in dev, but after building the mod and running it, my global loot modifiers don't work. No errors show in the log so I'm not sure what the issue is. I'm certain it's not my custom loot conditions (registered under the minecraft namespace), since I use vanilla conditions as well and those don't work. My global_loot_modifier is located in data/forge/loot_modifiers/(file):

Spoiler
{
  "replace": false,
  "entries": [
    "mod_id:my_modifier1",
    "mod_id:my_modifier2",
    "mod_id:my_modifier3"
  ]
}

And the modifiers are in data/mod_id/loot_modifiers/(file):

Spoiler
{
  "type": "mod_id:my_modifier",
  "conditions": [
    {
      "condition": "minecraft:match_tool_and_entity", //custom condition
      "item": {
        "tag": "mod_id:my_tools"
      },
      "entity": "this"
    }
  ]
}

Any help is appreciated.

Edited by urbanxx001
Link to comment
Share on other sites

56 minutes ago, urbanxx001 said:
"minecraft:match_tool_and_entity", //custom condition

Why does your custom condition live in the vanilla namespace?

  • Like 1

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

1 hour ago, Draco18s said:

Why does your custom condition live in the vanilla namespace?

For some reason I was under the impression it would only work there, but you're right it works under the mod space. I did some more testing and it seems it's a problem with the modifier itself after changing something last minute. I'll mark the thread as finished for now. Thanks for the advice though.

Edit: I'm an idiot the modifier works I completely forgot I added a condition where certain items were required to make the tools function. I'm losing it lol

Edited by urbanxx001
Link to comment
Share on other sites

  • urbanxx001 changed the title to 1.16.X Loot Modifiers Only Run in Dev Environment [Solved]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello, I'm creating a mod that should have a classic config file that I create with: ModLoadingContext.get().registerConfig(ModConfig.Type.COMMON, Config.SPEC); but I want also to have into server config folder more files .yml that I handle from the plugin. How can I create that yaml files?
    • Hi, I've been having a problem with Level 4 enchants on tools and items, it will not let me enchant any weapon or item past level 4, level 3 works on somethings but when I try to enchant it will either not show up in the anvil or when using the /enchant command it will say *item does not support the enchantment. I've tried efficiency 4 on a pickaxe and axe and it will not work.
    • Hello! I am posting since I am at the end of the road in terms of googling this solution and/or pouring through github projects. As the title suggests, I am trying to spawn my custom flower into the overworld into existing biomes, nothing crazy just a flower block spawned into the world. I added an entry into forge/biome_modifier called add_dreamcap_mushroom.json. It is as follows: { "type": "forge:add_features", "biomes": [ , "minecraft:plains", "minecraft:jungle", "minecraft:birch_forest", "minecraft:sparse_jungle", "minecraft:forest" ], "features": "herbalistmod:dreamcap_mushroom_patch", "step": "vegetal_decoration" }   I have a directory worldgen/configured_feature with dreamcap_mushroom_patch.json as follows:   { "type": "minecraft:random_patch", "config": { "feature": { "feature": { "type": "minecraft:simple_block", "config": { "to_place": { "type": "minecraft:simple_state_provider", "state": { "Name": "herbalistmod:dreamcap_mushroom_block" } } } }, "placement": [ { "type": "minecraft:block_predicate_filter", "predicate": { "type": "minecraft:matching_blocks", "blocks": "minecraft:air" } } ] }, "tries": 32, "xz_spread": 7, "y_spread": 3 } }   I have a directory worldgen/placed_feature with dreamcap_mushroom_patch.json as follows: { "feature": "herbalistmod:dreamcap_mushroom_patch", "placement": [ { "type": "minecraft:count", "count": 2 }, { "type": "minecraft:in_square" }, { "type": "minecraft:heightmap", "heightmap": "WORLD_SURFACE_WG" }, { "type": "minecraft:biome" } ] }   As far as I know, these are the only files I need in order to generate blocks, etc into the world, yet despite this I have made tons of worlds searching high and low and my block is nowhere to be found. Am I doing something wrong here or missing something obvious? Thanks in advance!  
    • Please read the FAQ for information on how to properly post logs. When you just post them embedded in your message, they are harder to read, which makes it harder to help. I did notice this though, which means you are missing a mod required by a mod you have installed:
  • Topics

  • Who's Online (See full list)

    • There are no registered users currently online
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.