Jump to content

Problem with items over ID 256


Ginge620

Recommended Posts

I have a problem with certain items appearing flat in hand when using an alternate texture pack.

Here is some pics of what happens.

In the pictures i also show some Minecraft ores to make it clear which texture pack is being used.

 

1st pic - Just shows you what mods i have in the jar file.

http://db.tt/DiHgS5Hi

 

 

2nd pic - shows the config file for the mod item (iron chests mod) with an ID of 2430

http://db.tt/8dvtn4lZ

 

 

3nd pic - Shows what texture pack i have selected (Faithful 32)

http://db.tt/tOvCqyEL

 

 

4rd pic - Shows the name of the item selected and its item ID

http://db.tt/2YRv6Gsi

 

 

5th pic - shows the item (Iron Chest) Placed on the ground and in hand. Note how the item is flat in hand.

http://db.tt/a5JgrAwG

 

 

6th pic - Shows the Default texture pack has been selected

http://db.tt/sRCHAUqK

 

 

7th pic - Shows the name of the selected item and its item ID

http://db.tt/gyV87bYg

 

 

8th pic - Shows the shows the item (Iron Chest) Placed on the ground and in hand. Note how the item is how it should be.

http://db.tt/zeefdjaU

 

 

This is just one example. It also happens to any item that is over ID 256.

Aswell as the Faithful 32x32 texture pack this happens with the Shax 128x128 texture pack.

 

I have also posted this on the Faithful topic on the minecraft forums.

 

Any help would be much appreciated.

Thanks

 

Link to comment
Share on other sites

my jar is almost the same as yours except i dont have mystcraft, so that might be causing the issue

 

anyhow, here are some ideas as to solve it:

 

1) Make sure you have the correct forge version for mystcraft's patch to work

2) Remove mystcraft

3) Update forge

 

i'd try them in order so you can find where the issue is caused

Being noobish since 96, being dumb since birth!

Link to comment
Share on other sites

It still happens when i just have 1 mod installed with forge. I think its a problem with minecraft itself, the extended block id code was incomplete in 1.2.5, minecraft thinks that only the ids bellow 255 are blocks, everything else is rendered as an item, i'm not sure if 1.3 fixed that.

 

 

Link to comment
Share on other sites

all updated forge builds include a fix for the 4096 block id's so that is not the issue

 

try cleaning up your jar completely, then boot with just forge, then install only jar mods one by one (boot mc after each)

 

once that is done, you can start adding mods to your mods folder also one by one

 

(the one by one princible is to see when the bug happens)

 

ps: the nei plugins do not need to be in the jar, you can put the zipfiles in your mods also - or you can put the needed files directly into the NEI zip

Being noobish since 96, being dumb since birth!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.