Jump to content

[1.5.2] GUI coding - Cannot find Symbol mc.renderEngine


Duno666
 Share

Recommended Posts

As I was learning some more modding intricacies today, I tried to write an alternate version of the furnace. I followed closely to the stock MC code, and everything appears to work, except for one line in the GUI class:

 

mc.renderEngine.bindTexture("/gui/furnace.png");

 

Which generates an error message:

 

java: \src\mod\client\gui\inventory\GUIDiamondFurnace.java:39: cannot find symbol
symbol  : variable renderEngine
location: class net.minecraft.client.Minecraft

 

I understand that it is saying it cannot find something, but I look at the client.Minecraft class, and the RenderEngine renderEngine is exactly where it should be. Commenting out the line, things start up and run fine - the GUI background doesn't show properly, of course, but it still works.

 

Lost and confused at this point, any thoughts from the community?

Link to comment
Share on other sites

ffsis. Apparently I was messing with my load order, and Intellij was loading the jar before the source, and (because it's dumb) did not think to look anywhere else for things.

 

So, solved, and it's my own fault.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.