Jump to content

[1.19.2] Spawn a particle at this exact position not visible ?


Recommended Posts

g days 

i need to show a particle at this exact vector 
but the particle donts spaws or its not visible 
soo i made this in a custom item to try figure out was wrong 


	// ########## ########## ########## ##########
	public InteractionResultHolder<ItemStack> use(Level warudo, Player pe, InteractionHand hand) {

		Vec3 vh = util.calcularVectores(pe, 2 , 0.0F );//
		if ( vh != null) //warudo.isClientSide && 
			util.showthis( String.format(" %1$s, %2$s, %3$s",  vh.x, vh.y, vh.z ) , pe);
			warudo.addAlwaysVisibleParticle(ParticleTypes.FLAME, vh.x, vh.y, vh.z , 0.0D, 0.0D, 0.0D);
			warudo.addParticle(ParticleTypes.SMOKE, vh.x, vh.y, vh.z , 0.0D, 0.0D, 0.0D);
			pe.playSound(SoundEvents.FIRE_EXTINGUISH, 1.0F, 1.0F);

		return InteractionResultHolder.pass(pe.getItemInHand(hand));

util.calcularVectores(pe, 2 , 0.0F ); just calculate the position 2 meters in from of player 

if i hold rigth click from time to time i see the flame particle but never see the smoke 
the sound allways works 

soo ineed help whith this how i spawn a particle or its now an entity ?




Link to comment
Share on other sites

Try this:

            warudo.addAlwaysVisibleParticle(ParticleTypes.FLAME, vh.x, vh.y, vh.z + 0.5f , 0.0D, 0.0D, 0.0D);
            warudo.addParticle(ParticleTypes.SMOKE, vh.x + 0.5f, vh.y, vh.z , 0.0D, 0.0D, 0.0D);

Then see if you can figure it out why my code works (and yours does as well). 🙂 


If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

i fond the issue and dont like it 
in mi words i allways turn down render distance the bobbing effect the particles the shadows and pop up the light level is like a tradition to get the best experience from mi video card 

soo particles was not rendering coze i set particles to minimun, turn it to max and now it works  
is weird i could assure than before versions always pops particles from mods wherever the config says 


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • SOLVED! I ended up fixing this after a fresh night of sleep and cloning the forge repo and looking through that. I had to add a BiomeModifier class to my mod, see this file here for assistance: MinecraftForge/src/test/java/net/minecraftforge/debug/world/BiomeModifierTest.java at 1.20.1 · MinecraftForge/MinecraftForge (github.com)
    • Hello, I'm creating a mod that should have a classic config file that I create with: ModLoadingContext.get().registerConfig(ModConfig.Type.COMMON, Config.SPEC); but I want also to have into server config folder more files .yml that I handle from the plugin. How can I create that yaml files?
    • Hi, I've been having a problem with Level 4 enchants on tools and items, it will not let me enchant any weapon or item past level 4, level 3 works on somethings but when I try to enchant it will either not show up in the anvil or when using the /enchant command it will say *item does not support the enchantment. I've tried efficiency 4 on a pickaxe and axe and it will not work.
    • Hello! I am posting since I am at the end of the road in terms of googling this solution and/or pouring through github projects. As the title suggests, I am trying to spawn my custom flower into the overworld into existing biomes, nothing crazy just a flower block spawned into the world. I added an entry into forge/biome_modifier called add_dreamcap_mushroom.json. It is as follows: { "type": "forge:add_features", "biomes": [ , "minecraft:plains", "minecraft:jungle", "minecraft:birch_forest", "minecraft:sparse_jungle", "minecraft:forest" ], "features": "herbalistmod:dreamcap_mushroom_patch", "step": "vegetal_decoration" }   I have a directory worldgen/configured_feature with dreamcap_mushroom_patch.json as follows:   { "type": "minecraft:random_patch", "config": { "feature": { "feature": { "type": "minecraft:simple_block", "config": { "to_place": { "type": "minecraft:simple_state_provider", "state": { "Name": "herbalistmod:dreamcap_mushroom_block" } } } }, "placement": [ { "type": "minecraft:block_predicate_filter", "predicate": { "type": "minecraft:matching_blocks", "blocks": "minecraft:air" } } ] }, "tries": 32, "xz_spread": 7, "y_spread": 3 } }   I have a directory worldgen/placed_feature with dreamcap_mushroom_patch.json as follows: { "feature": "herbalistmod:dreamcap_mushroom_patch", "placement": [ { "type": "minecraft:count", "count": 2 }, { "type": "minecraft:in_square" }, { "type": "minecraft:heightmap", "heightmap": "WORLD_SURFACE_WG" }, { "type": "minecraft:biome" } ] }   As far as I know, these are the only files I need in order to generate blocks, etc into the world, yet despite this I have made tons of worlds searching high and low and my block is nowhere to be found. Am I doing something wrong here or missing something obvious? Thanks in advance!  
  • Topics

  • Who's Online (See full list)

    • There are no registered users currently online
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.