Jump to content

How swtich java version for Miencraft Forge server (SOLVED)

Robert Baca

Recommended Posts

HI, my issue is that i last time do server on 1.18.2 and java 17.

Right now i want back on 1.16.5 server and:

Terminal after start:

C:\Users\Dom\Desktop\MINECRAFT_SERVER\1.16.5 - SERVER RVKK>java -Xmx4096M -Xms4096M -jar forgeserver.jar nogui
2022-11-05 17:34:26,500 main WARN Advanced terminal features are not available in this environment
[17:34:26] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.39, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui]
[17:34:26] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.1.3+8.1.3+main-8.1.x.c94d18ec starting: java version by Oracle Corporation
Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0x7ea37dbf) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0x7ea37dbf
        at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:45)
        at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)
        at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:45)
        at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)
        at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)
        at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)
        at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)
        at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)
        at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:49)
        at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:46)
        at net.minecraftforge.server.ServerMain.main(ServerMain.java:43)

Press any key to continue . . .


CMD show java version:

C:\Users\Dom>java -version
java version "" 2022-08-18 LTS
Java(TM) SE Runtime Environment (build
Java HotSpot(TM) 64-Bit Server VM (build, mixed mode, sharing)

On my PC i have java version:

- jdk1.8.0_202

- jdk-

I change my Path in windows environment variables:

in PATH - C:\Program Files\Java\jdk1.8.0_202\bin

and JAVA_HOME - C:\Program Files\Java\jdk1.8.0_202\bin

But that doesn't help. How i can switch java version ?




Edited by Robert Baca
Link to comment
Share on other sites

  • Robert Baca changed the title to How swtich java version for Miencraft Forge server (SOLVED)


in .bat file starting server before commend:

java -Xmx4096M -Xms4096M -jar forgeserver.jar nogui


needed to switch first java version. I find on StackOverflow and rn file looks like that:


@echo off
echo Setting JAVA_HOME
set JAVA_HOME=C:\Program Files\Java\jdk1.8.0_341
echo setting PATH
set PATH=C:\Program Files\Java\jdk1.8.0_341\bin;%PATH%
echo Display java version
java -version

java -Xmx4096M -Xms4096M -jar forgeserver.jar nogui


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.