Jump to content

Forge-1.12.2.jar Fails to Run


Fierydragon

Recommended Posts

I was trying to make a Modded server for a few of my friends to play on and everything was going well until I first tried to start the server. I was following the Youtube video from The Breakdown "How To Make A RLCraft Server (Play RLCraft w/ Your Friends!" The Issue i ran into is when I try to run the .bat file I get this result:

C:\Users\fired\OneDrive\Desktop\Modded Server>java -Xmx4096M -Xms4096M -jar forge-1.12.2-14.23.5.2859.jar nogui
A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:568)
        at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70)
        at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34)
Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')
        at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
        ... 6 more

C:\Users\fired\OneDrive\Desktop\Modded Server>PAUSE
Press any key to continue . . .

I saw someone had the same issue a few years back and they were told to make sure they are running Java 8 and I've already done that. Not sure what I'm doing wrong here.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.