Jump to content

How to set mod level on commandline


Two
 Share

Recommended Posts

Hi,

I am trying to help a modder to pin down an issue that's happening on my system and I am trying to figure out how to set the log level of forge file logging to debug. My attempts at googling and using the usual log4j settings have failed.

I do not have access to the source code of the mod, so I need to set the log level on the command line.

Edited by Two

My Mods

 

New Dawn - A completely new terrain engine for Minecraft

TwoTility - Blocks and Items for a better Minecraft

TwoGraves - Keeps your items safe on death

Link to comment
Share on other sites

If you are using curseforge, you need to enable the forge debug.log in its settings.

 

Otherwise, it's likely something you are doing when trying to change the log configuration is incorrect and you have broken the logging.

Since you don't say what you have actually done, it's impossible to help further.

Forge's debug logging is enabled by default, when launchers don't elect to turn it off.

Edited by warjort

Boilerplate:

If you don't post your logs/debug.log we can't help you. For curseforge you need to enable the forge debug.log in its minecraft settings. You should also post your crash report if you have one.

If there is no error in the log file and you don't have a crash report then post the launcher_log.txt from the minecraft folder. Again for curseforge this will be in your curseforge/minecraft/Install

Large files should be posted to a file sharing site like https://gist.github.com  You should also read the support forum sticky post.

Link to comment
Share on other sites

I was setting the debug defines on the commandline used to start Minecraft in the Minecraft launcher as ChampionAsh535 suggested, this had zero effect. However enabling debugging in Curseforge did it.

I have no idea what Curse is doing to suppress the commandlines, but if running with the Curseforge Launcher using that specific setting seems to be the only way to activate debug logs. Which is a bit odd, because it should listen to the commandline settings, especially if enforcing something like a log4j config file, but it is not.

Thanks for the help!

Edited by Two

My Mods

 

New Dawn - A completely new terrain engine for Minecraft

TwoTility - Blocks and Items for a better Minecraft

TwoGraves - Keeps your items safe on death

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.