Jump to content

Minecraft 1.20.1 forge troubleshooting


Claytonapt6

Recommended Posts

Hello, I am crashing upon attempting to load Minecraft under the forge launcher. First, I should start with the paste bin. https://pastebin.com/VKwwkEZM.  This was on the curse forge launcher as I could not find the log for the forge file installer. But I had the same issue on both so this should suffice. I have spent the past 5-6 hours on this and have tried many options, so I'll list my troubles so far.

I installed both Java 8 and 17, I then installed Minecraft from Minecraft.net, I already had the launcher apparently, so I didn't actually use that installation method until later (Minecraft dungeons on pc). I ran Minecraft on version 1.20.1 and the snapshot in advance and then closed Minecraft (I have done this all several years ago I should mention). I then attempted to run both the stable and latest release of the forge launcher, and received error code 1 on both, I reinstalled both java and Minecraft 3 times during the course of this and led to nothing. I then went and updated all of my drivers (ROG ZEPHYRUS G14 is the model, requiring ASUS drivers and already has a built-in app for driver updates. All to my knowledge correct versions of java, Minecraft, forge, and drivers alike.

I then tried the curseforge launcher, eventually led to the same result. However, this time given a notepad with the crash log as provided on the Pastebin, only censoring necessary information for privacy concerns. I also tried reinstalling curse forge while I was at it with no luck. I then read the crash logs and came across an error discussed in this article https://howfix.net/games/fix-minecraft-exception_access_violation-0xc0000005-error/#:~:text=Fixing EXCEPTION_ACCESS_VIOLATION (0xc0000005) error 1 Reinstalling Java First,DEP ... 5 Changing the Options File . And this also did nothing to help my cause. and that leads me to now. Any and all suggestions would be appreciated as I truly do not know what else to do.

Link to comment
Share on other sites

Your pastebin link was removed for "being potentially dangerous".

I would try gist.github.com instead.

 

Also I believe the curseforge launcher has useful logs turned off by default, and you may need to change a setting to enable them. Unfortunately, I don't use curseforge so can't explain how to do it, but pretty sure I've seen someone with instructions in their forum signature, or a google search would probably explain how.

Link to comment
Share on other sites

There's instructions on how to enable the debug.log on CurseForge in the FAQ. I suggest trying https://paste.ee or https://paste.gemwire.uk as you're less likely to accidentally end up creating a github repo with a file in it instead of using gist.

Edited by Paint_Ninja
Add link to FAQ
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello. I'm using IntelliJ IDEA and making a mod for Forge 1.20.1 and I'm trying to make a GUI. I found that the Minecraft-related codes are all obfuscated and when setting up the workspace, Gradle did not execute Deobfuscation tasks like createMcpToSrg. Is this normal or a bug? Can anyone help me with this?
    • Hello! I'm trying to get a list of all entries registered in the infusion upgrade registry. Code can be found in github: https://github.com/ChamoisEST/MiningMadness/tree/1.20.1 Registry in common/registries/MMRegistries.java Event that calls the registry is in MiningMadness.java List of registered entries should be called in common/capabilities/infusion/InfusionCapabilityImplementation.java:getActiveInfusions() in the for loop. Is there any way to accomplish that? Thanks in advance!  
    • So, I am trying to create and add tags to my custom damage type, but looks like I made something wrong, since it crashing with error that "cannot register" damage type. Im trying to register it, and in datagen add tags, but it everytime crashing due to not register "grimtales:entropy". Full code there - https://github.com/undertakerJ/Grim-Tales-Forge ModDamageTypes class public class ModDamageTypes { public static final DeferredRegister<DamageType> DAMAGE_TYPES = DeferredRegister.create(Registries.DAMAGE_TYPE, GrimTales.MOD_ID); public static final ResourceKey<DamageType> ENTROPY_KEY = ResourceKey.create(Registries.DAMAGE_TYPE, new ResourceLocation(GrimTales.MOD_ID, "entropy")); public static final RegistryObject<DamageType> ENTROPY = DAMAGE_TYPES.register( "entropy", () -> new DamageType("entropy_effect", DamageScaling.ALWAYS, 1f, DamageEffects.HURT)); // // public static final DamageSource ENTROPY_SOURCE = new DamageSource(Holder.direct(ENTROPY.get())); public static void register(IEventBus eventBus) { DAMAGE_TYPES.register(eventBus); } } Datagen for damageTags public class ModDamageTagsProvider extends DamageTypeTagsProvider { public ModDamageTagsProvider( PackOutput p_270719_, CompletableFuture<HolderLookup.Provider> p_270256_, @Nullable ExistingFileHelper existingFileHelper) { super(p_270719_, p_270256_, GrimTales.MOD_ID, existingFileHelper); } @Override protected void addTags(HolderLookup.Provider pProvider) { this.tag(DamageTypeTags.BYPASSES_INVULNERABILITY).add(ModDamageTypes.ENTROPY_KEY); } } Datagen class it self   @Mod.EventBusSubscriber(modid = GrimTales.MOD_ID, bus = Mod.EventBusSubscriber.Bus.MOD) public class DataGenerators { @SubscribeEvent public static void gatherData(GatherDataEvent event){ DataGenerator generator = event.getGenerator(); PackOutput packOutput = generator.getPackOutput(); ExistingFileHelper helper = event.getExistingFileHelper(); CompletableFuture<HolderLookup.Provider> lookupProvider = event.getLookupProvider(); generator.addProvider(event.includeServer(), new ModDamageTagsProvider(packOutput, lookupProvider, helper)); } } And register class in main class public GrimTales() { IEventBus modEventBus = FMLJavaModLoadingContext.get().getModEventBus(); ModDamageTypes.register(modEventBus); modEventBus.addListener(this::commonSetup); MinecraftForge.EVENT_BUS.register(this); modEventBus.addListener(this::addCreative); }  
    • Looking for a semi-vanilla Minecraft server? Maybe one with keep inventory and land claims? I have one for you! Let me introduce you to Safe Survival! Come on and join us at mc.safesurvival.net. It is bedrock supported too!
    • Hi. I'm trying to play RLCraft with Optifine but my game keeps crashing on startup with Exit Code 1. The modpack was working fine yesterday, not sure what changed to make it not wanna work anymore. I was hoping someone here could help me figure out what's going wrong. If I remove Optifine, nothing changes, I still get the same errors. Thanks in advance. Crash Report (I only included the errors+fatal, I’m not sure if more is needed, please let me know): https://pastebin.ai/66ivknz0f4  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.