Jump to content

Exit Code 1 (Nothing has worked) 1.19.2


Ringo Verne

Recommended Posts

Hey! I apologize if this doesn't make much sense, I'm not the most technologically advanced guy. I've tried almost everything I can find online and nothing has worked, I've just been crashing with a pop-up telling me it's Exit Code 1. 

What I have tried:

- Re-installing 

- Deleting fml.toml

- I've tried checking my display drivers but it says there are no updates (AMD Radeon Graphics)

- I've also tried turning mods on and off with no luck

Here is one of the crash logs (I think that's the correct term, I apologize if it's not. I'm very new to using Forge and things of this manner). 

https://paste.ee/p/D3q6H

 

Any help is greatly appreciated!

Link to comment
Share on other sites

1 hour ago, TileEntity said:

Update your AMD GPU drivers

 I've fully updated the driver, and it's still giving me a Code 1. It won't even let me locate the crash log-- all I have is the option to copy the exit code (1) and then a "close" button. Are there possibly any other problems?

Edit: I believe the forge version is 43.3.0 I'd assume (based on what it says in the Minecraft launcher. I installed it today so I doubt it would be out of date, but maybe there's a problem there?

Edited by Ringo Verne
Link to comment
Share on other sites

1 minute ago, TileEntity said:

Which CPU and GPU are you using?

The processor is a AMD Ryzen 3 7320U with Radeon Graphics  

GPU is an AMD Radeon, and was updated to the most recent version, which it says is 10/16/2023 (I think that's the most recent version as I updated the driver through the official website. There is an exact number listed under "driver version", I'm just not sure if that should be shared or not). 

Link to comment
Share on other sites

You need to fully remove the broken driver before trying to change it, otherwise it'll keep reverting back to the broken one. Likewise it'll claim it's up-to-date when it isn't for the same reason.

Follow the guide for updating drivers in the support FAQ carefully - it should solve your issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I downloaded forge for 1.21 because I wanted to play the new update with a few mods. When I load up the game on the forge installation, the game seems to launch fine, but then freezes and goes into that "not responding" state a few seconds after sitting on the menu. It stays on not responding forever, and I have to close the game myself. The normal vanilla game without forge loads and works perfectly fine, though. The exit code I receive is either 1 or -805306369, depending on how I close the game. When I force close with task manager, I get exit code 1. When I close using the not responding menu (close the program or wait for it to respond), I get exit code -805306369. I tried taking all of the mods out to see if they were the problem, but the same issue still persists even with 0 mods in the mods folder. The pastebin linked is the log from when I launched the game with forge after taking all of the mods out of the mods folder. (Nothing ever shows up in the crash-reports folder, but I do have this from the logs): https://pastebin.com/9bL8awvE I had to delete some of the bottom of the log to be able to upload it onto pastebin, but anything deleted was identical to the lines there at the bottom. Some things I have tried include: Allocating more ram, updating display drivers, updating java version (currently have Java 21, tried switching to java 17 but that did not work either), removing or changing settings on programs that may conflict with minecraft (followed this list https://minecrafthopper.net/help/known-incompatible-software/). None have worked so far. I'm aware of course that this is a beta version of forge, but I just wanted to see if there was something I could do to fix this, or if I will just need to wait for a more stable, non beta version to be released.  
    • sorry if this is an incorrect log or wrong tag ive never used this before and im new to modding latest log: file:///C:/Users/jason/curseforge/minecraft/Instances/Cottage Witch/logs/latest.log
    • Hi its me from my first account. I added creative core but when i start minecraft he gives me an error. Now i can't send you the log but I will later 
    • I want my mod to add two new NBT values to Block Displays and Item Displays (Like left-rotation, scale, transformation, etc.), which I call texture_repetition and texture_shift (both Vector3f variables). Texture_repetition allows the Display to repeat its texture or only show part of it, and the texture_shift value allows you to shift to the part of the texture you want the display to show. I already tried Mixins, and I assume I need to use the renderstate() function and entityData variable, but entityData is protected, which means I can not edit it using Mixins. How would I add these NBT values to the Display class without using the entityData class? (These two data values, if coded correctly, could allow slabs/stairs/walls of any block to be represented using Displays without being limited by the vanilla inventory options)
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.