Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Minecraft Crashes for Unknown Reason??


Recommended Posts

Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

2013-10-31 20:45:41 [iNFO] [sTDOUT] Initializing LWJGL OpenAL

2013-10-31 20:45:41 [iNFO] [sTDOUT]    (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)

2013-10-31 20:45:41 [iNFO] [sTDOUT] #@!@# Game crashed! Crash report saved to: #@!@# *****\crash-2013-10-31_20.45.40-client.txt

AL lib: (EE) alc_cleanup: 1 device not closed

 

 

crash report

 

---- Minecraft Crash Report ----

// Everything's going to plan. No, really, that was supposed to happen.

 

Time: 13-10-31 20:45

Description: Initializing game

 

java.lang.NullPointerException

at net.minecraft.item.ItemStack.<init>(ItemStack.java:77)

at evgenit.betterminecraft.BetterMinecraftMod.<init>(BetterMinecraftMod.java:68)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at cpw.mods.fml.common.ILanguageAdapter$JavaAdapter.getNewInstance(ILanguageAdapter.java:174)

at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:519)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:313)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)

at com.google.common.eventbus.EventBus.post(EventBus.java:267)

at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:194)

at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:174)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:313)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)

at com.google.common.eventbus.EventBus.post(EventBus.java:267)

at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:105)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:509)

at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:183)

at net.minecraft.client.Minecraft.startGame(Minecraft.java:472)

at net.minecraft.client.Minecraft.run(Minecraft.java:807)

at net.minecraft.client.main.Main.main(Main.java:93)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)

at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

 

 

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

 

-- Head --

Stacktrace:

at net.minecraft.item.ItemStack.<init>(ItemStack.java:77)

at evgenit.betterminecraft.BetterMinecraftMod.<init>(BetterMinecraftMod.java:68)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at cpw.mods.fml.common.ILanguageAdapter$JavaAdapter.getNewInstance(ILanguageAdapter.java:174)

at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:519)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:313)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)

at com.google.common.eventbus.EventBus.post(EventBus.java:267)

at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:194)

at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:174)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:313)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)

at com.google.common.eventbus.EventBus.post(EventBus.java:267)

at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:105)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:509)

at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:183)

at net.minecraft.client.Minecraft.startGame(Minecraft.java:472)

 

-- Initialization --

Details:

Stacktrace:

at net.minecraft.client.Minecraft.run(Minecraft.java:807)

at net.minecraft.client.main.Main.main(Main.java:93)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)

at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

 

-- System Details --

Details:

Minecraft Version: 1.6.4

Operating System: Windows 7 (amd64) version 6.1

Java Version: 1.7.0_40, Oracle Corporation

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

Memory: 41031392 bytes (39 MB) / 89755648 bytes (85 MB) up to 259719168 bytes (247 MB)

JVM Flags: 2 total; -Xincgc -XX:MaxHeapSize=256m

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

Suspicious classes: FML and Forge are installed

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML: MCP v8.11 FML v6.4.20.916 Minecraft Forge 9.11.1.916 4 mods loaded, 4 mods active

mcp{8.09} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed

FML{6.4.20.916} [Forge Mod Loader] (bin) Unloaded->Constructed

Forge{9.11.1.916} [Minecraft Forge] (bin) Unloaded->Constructed

bm1914{0.0.1} [betterMinecraft] (bin) Unloaded->Errored

Launched Version: 1.6

LWJGL: 2.9.0

OpenGL: ATI Mobility Radeon HD 5470                          GL version 3.2.9712 Compatibility Profile Context, ATI Technologies Inc.

Is Modded: Definitely; Client brand changed to 'fml,forge'

Type: Client (map_client.txt)

Resource Pack: Default

Current Language: English (US)

Profiler Position: N/A (disabled)

Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

 

 

 

Code that is probably causing it:

 

        ItemStack mouldpStack = new ItemStack(emould_pickaxe_head);

        ItemStack mouldaStack = new ItemStack(emould_axe_head);

        ItemStack mouldhStack = new ItemStack(emould_hoe_head);

        ItemStack mouldsStack = new ItemStack(emould_sword_blade);

        ItemStack mouldlStack = new ItemStack(emould_shovel_head);

 

Itemstack blaBla = new ItemStack((note that i dont have Item because it doesn't recognize it)le_item);

Link to post
Share on other sites

Thanks, that worked, but now I have another problem:

 

this is my code:

 

LanguageRegistry.addName(ironore_item, "Iron ore");

                LanguageRegistry.addName(goldore_item, "Gold ore");

                LanguageRegistry.addName(emould_pickaxe_head, "Empty Pickaxe Mould");

                LanguageRegistry.addName(emould_axe_head, "Empty Axe Mould");

                LanguageRegistry.addName(emould_hoe_head, "Empty Hoe Mould");

                LanguageRegistry.addName(emould_shovel_head, "Empty Shovel Mould");

                LanguageRegistry.addName(emould_sword_blade, "Empty Sword Mould");

                LanguageRegistry.addName(mould_ipickaxe_head, "Iron Pickaxe Mould");

                LanguageRegistry.addName(mould_iaxe_head, "Iron Axe Mould");

                LanguageRegistry.addName(mould_ihoe_head, "Iron Hoe Mould");

                LanguageRegistry.addName(mould_ishovel_head, "Iron Shovel Mould");

                LanguageRegistry.addName(mould_isword_blade, "Iron Sword Mould");

                LanguageRegistry.addName(isword_blade, "Iron Sword Blade");

                LanguageRegistry.addName(ipickaxe_head, "Iron Pickaxe Head");

                LanguageRegistry.addName(iaxe_head, "Iron Axe Head");

                LanguageRegistry.addName(ishovel_head, "Iron Shovel Head");

                LanguageRegistry.addName(ihoe_head, "Iron Hoe Head");

 

 

But ingame every my item takes the name of the last one that is registered(Iron Hoe Head). Am I Missing something??

Link to post
Share on other sites
  • 3 months later...

Thanks, that worked, but now I have another problem:

 

this is my code:

 

LanguageRegistry.addName(ironore_item, "Iron ore");

                LanguageRegistry.addName(goldore_item, "Gold ore");

                LanguageRegistry.addName(emould_pickaxe_head, "Empty Pickaxe Mould");

                LanguageRegistry.addName(emould_axe_head, "Empty Axe Mould");

                LanguageRegistry.addName(emould_hoe_head, "Empty Hoe Mould");

                LanguageRegistry.addName(emould_shovel_head, "Empty Shovel Mould");

                LanguageRegistry.addName(emould_sword_blade, "Empty Sword Mould");

                LanguageRegistry.addName(mould_ipickaxe_head, "Iron Pickaxe Mould");

                LanguageRegistry.addName(mould_iaxe_head, "Iron Axe Mould");

                LanguageRegistry.addName(mould_ihoe_head, "Iron Hoe Mould");

                LanguageRegistry.addName(mould_ishovel_head, "Iron Shovel Mould");

                LanguageRegistry.addName(mould_isword_blade, "Iron Sword Mould");

                LanguageRegistry.addName(isword_blade, "Iron Sword Blade");

                LanguageRegistry.addName(ipickaxe_head, "Iron Pickaxe Head");

                LanguageRegistry.addName(iaxe_head, "Iron Axe Head");

                LanguageRegistry.addName(ishovel_head, "Iron Shovel Head");

                LanguageRegistry.addName(ihoe_head, "Iron Hoe Head");

 

 

But ingame every my item takes the name of the last one that is registered(Iron Hoe Head). Am I Missing something??

 

Don't use the LanguageRegistry.

http://www.minecraftforge.net/forum/index.php/topic,15636.msg79415.html#msg79415

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

Either your graphics card is absolutely freakin outdated or your graphic drivers are not updated. Also: Don't hijack completely unrelated threads.

I will search how to actualize my graphics card, thank you, and sorry for posting in someone phost, i will remove that comment

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.