Jump to content

[SOLVED] [1.6.4] ZipException


saxon564

Recommended Posts

So after several posts here and a lot of time spent modifying the code for each mob to what i wanted, i can finally release it, but i have run into one problem, i have recompiled it and reobfuscated it, i have watched Wuppy's tutorial on 1.6.* how to release your mod, and none of that has worked.

 

Here is the error

 

 

[00:14:19 INFO]: Client> 2013-11-20 00:14:19 [WARNING] [ForgeModLoader] Zip file scala-library-2.10.2.jar failed to read properly, it will be ignored

[00:14:19 INFO]: Client> java.util.zip.ZipException: error in opening zip file

[00:14:19 INFO]: Client> at java.util.zip.ZipFile.open(Native Method)

[00:14:19 INFO]: Client> at java.util.zip.ZipFile.<init>(Unknown Source)

[00:14:19 INFO]: Client> at java.util.zip.ZipFile.<init>(Unknown Source)

[00:14:19 INFO]: Client> at java.util.jar.JarFile.<init>(Unknown Source)

[00:14:19 INFO]: Client> at java.util.jar.JarFile.<init>(Unknown Source)

[00:14:19 INFO]: Client> at cpw.mods.fml.common.discovery.JarDiscoverer.discover(JarDiscoverer.java:41)

[00:14:19 INFO]: Client> at cpw.mods.fml.common.discovery.ContainerType.findMods(ContainerType.java:42)

[00:14:19 INFO]: Client> at cpw.mods.fml.common.discovery.ModCandidate.explore(ModCandidate.java:64)

[00:14:19 INFO]: Client> at cpw.mods.fml.common.discovery.ModDiscoverer.identifyMods(ModDiscoverer.java:127)

[00:14:19 INFO]: Client> at cpw.mods.fml.common.Loader.identifyMods(Loader.java:353)

[00:14:19 INFO]: Client> at cpw.mods.fml.common.Loader.loadMods(Loader.java:485)

[00:14:19 INFO]: Client> at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:181)

[00:14:19 INFO]: Client> at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:471)

[00:14:19 INFO]: Client> at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:806)

[00:14:19 INFO]: Client> at net.minecraft.client.main.Main.main(SourceFile:101)

[00:14:19 INFO]: Client> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

[00:14:19 INFO]: Client> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

[00:14:19 INFO]: Client> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

[00:14:19 INFO]: Client> at java.lang.reflect.Method.invoke(Unknown Source)

[00:14:19 INFO]: Client> at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)

[00:14:19 INFO]: Client> at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

 

 

 

this error gives me no leads as to what i need to do. my mod name file is moChickens1.6.4V1.0.rar all other mods are loading like they should, but this is the only one that isnt loading. file path: mod/1.6.4/moChickens1.6.4V1.0.rar

 

has anyone seen this error before? or does anyone know how to fix this error? any help would be greatly appreciated.

 

if therres anything you need to know that i didnt share, let me know and i will post it as soon as i can.

Link to comment
Share on other sites

.zip files does NOT like mixed case.

Please for the love of god and cows stick to Java conventions they are there for a reason.

 

Now why am I saying this?

Because the most common reason for this error is that you have uppercase letters in one or more of the following:

* modid

* package names

* folder names

 

Please be so kind as to double check that this is not the issue :)

 

As I'm writing this I'm noticing something which may be relevant your file is .rar and not .zip, aren't those file types using different compression types?

If you guys dont get it.. then well ya.. try harder...

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here's a simple example to solve this particular issue: public class ModArmorMaterials { public static final DeferredRegister<ArmorMaterial> ARMORS = DeferredRegister.create(Registries.ARMOR_MATERIAL, MyModName.MOD_ID); public static final RegistryObject<ArmorMaterial> COPPER = registerArmor("copper", Util.make(new EnumMap<>(ArmorItem.Type.class), enumMap -> { enumMap.put(ArmorItem.Type.BOOTS, 1); enumMap.put(ArmorItem.Type.LEGGINGS, 4); enumMap.put(ArmorItem.Type.CHESTPLATE, 5); enumMap.put(ArmorItem.Type.HELMET, 2); enumMap.put(ArmorItem.Type.BODY, 4); }), 12, SoundEvents.ARMOR_EQUIP_IRON, 0.0F, 0.0F, () -> Ingredient.of(Items.COPPER_INGOT)); private static RegistryObject<ArmorMaterial> registerArmor(String pGroup, EnumMap<ArmorItem.Type, Integer> pEnumMap, int pEnchantmentValue, Holder<SoundEvent> pEquipSound, float pToughness, float pKnockbackResistance, Supplier<Ingredient> pRepairIngredient) { List<ArmorMaterial.Layer> pLayerList = List.of(new ArmorMaterial.Layer(new ResourceLocation(pGroup))); return registerArmor(pGroup, pEnumMap, pEnchantmentValue, pEquipSound, pToughness, pKnockbackResistance, pRepairIngredient, pLayerList); } private static RegistryObject<ArmorMaterial> registerArmor( String pGroup, EnumMap<ArmorItem.Type, Integer> pEnumMap, int pEnchantmentValue, Holder<SoundEvent> pEquipSound, float pToughness, float pKnockbackResistance, Supplier<Ingredient> pRepairIngredient, List<ArmorMaterial.Layer> pLayerList) { return ARMORS.register(pGroup, () -> new ArmorMaterial(pEnumMap, pEnchantmentValue, pEquipSound, pRepairIngredient, pLayerList, pToughness, pKnockbackResistance)); } public static void register(IEventBus eventBus) { ARMORS.register(eventBus); } } Essentially, the TierSortingRegistry has been removed and so you now need to set up your own DeferredRegister. Please see the minecraftforge GitHub for more information; I found this solution through their issues (https://github.com/MinecraftForge/MinecraftForge/issues/9961)
    • How did I even leave that in there? I’ll try it in a bit, that very well could be it.
    • Greetings, I met a problem with my Forge server (47.2.0-1.20.1) that I can't join with the following line. (singleplayer world working fine) [net.minecraft.server.network.ServerGamePacketListenerImpl/]: Sharyna lost connection: Internal Exception: io.netty.handler.codec.EncoderException: java.lang.NullPointerException: Cannot invoke "net.minecraft.resources.ResourceLocation.toString()" because "p_130086_" is null   At first it was errored with packet size error, but I fixed that with the Connectivity mod, however, after that this popped up and can't find the source of it. Since the logs are big, I couldn't upload on paste.gg or other site ... so here it is (if the files are deleted, please notice me and I'll upload again. Debug and Latest log
    • Дерево тис
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.