Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED] How to make a block that has multiple layers for textures


TheTrollingTrollguy
 Share

Recommended Posts

Hey guys, it's me again with another crazy idea. How can I make my block have multiple texture layers like the grass block has. What I want to do is to have a base texture on all sides, then have transparent textures on all sides(which in my case will be an arrow) and then the last layer for textures is on that kinda adds some "shadows" on the block, it is transparent too(it will represend the block age, which I have with my tile entity).

So I have 3 layers:

1. base texture

2. arrow or line texture(transparent)

3. "shadows" texture(transparent)

 

So what do I need to do? Add some methods to my block class, or make a renderer for my block? Tell me.  ;)

Link to comment
Share on other sites

You'll probably need custom renderer for that ;) (class that implements ISimpleBlockRenderingHandler). I have similar block in my mod so you can have a look at these files:

 

Custom renderer:

https://github.com/EnkeyMC/morelights/blob/master/renderers/LampRenderer.java

 

Block class:

https://github.com/EnkeyMC/morelights/blob/master/block/BlockOverlayLamp.java

 

Hope it helps ;)

 

EDIT:

I am basically rendering the block in two passes (0 & 1). In each pass is rendered different block (different texture) and the block is taking the base texture from blocks around itself.

If someone helps you, click that thank you button ;)

 

EasyTessellator library: http://www.minecraftforge.net/forum/index.php/topic,14705.0.html

Link to comment
Share on other sites

I did mine a little differently, but same idea.

 

https://github.com/Draco18s/Artifacts/blob/master/draco18s/artifacts/client/RenderArrowTrap.java

 

I didn't bother with passes, I just rendered twice. :P

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

I did mine a little differently, but same idea.

 

https://github.com/Draco18s/Artifacts/blob/master/draco18s/artifacts/client/RenderArrowTrap.java

 

I didn't bother with passes, I just rendered twice. :P

 

And are you rendering transparent textures? Because I think you need to render in two passes if you are rendering transparent texture and solid one on top of each other.

If someone helps you, click that thank you button ;)

 

EasyTessellator library: http://www.minecraftforge.net/forum/index.php/topic,14705.0.html

Link to comment
Share on other sites

And are you rendering transparent textures? Because I think you need to render in two passes if you are rendering transparent texture and solid one on top of each other.

 

Yes, and it works just fine.

 

Edit:

The reason you would need to render in the second pass is if you don't want the block obscuring other blocks ("ambient occlusion").  But a fully solid block with an overlay don't give two shits if stuff behind it isn't rendered when the overlay is rendered.  It can't obscure itself, so the pass number is irrelevant.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

  • 2 weeks later...

Hi

 

The symptom you're seeing is generally caused by the lighting settings.  I'm not sure why you're seeing this because your call to renderStandardBlocks immediately before the renderFaceYpos should have set the lighting up properly already.  Some more info here (but it's pretty complicated and I'm not sure it will help to be honest)

http://greyminecraftcoder.blogspot.com.au/2013/08/lighting.html

 

It looks to me like you don't actually need to render the arrow separately from the asphalt block?  Why not just draw the arrow and block as a single icon?

see here

http://greyminecraftcoder.blogspot.com.au/2013/07/rendering-standard-blocks-cubes.html

Just override getIcon to return the faces you want (with/without arrow, and pointing in correct direction).

 

You'll need a custom renderer for your item like Enkey said.

More information on item rendering here (see the "Items" section)

http://greyminecraftcoder.blogspot.com.au/p/list-of-topics.html

 

-TGG

 

 

Link to comment
Share on other sites

Nah, It looks like I'm just going to do textures that already have arrows on them, because of the lighting. Reasons why I wanted to have them separate is because I'm already using the arrow texture on a block so I wanted just to "stick" it to another block and to have less textures in my mod file after I release the new update. Since I can't really make any progress because of the lighting I'm switching back to my old system. Thanks for the help! :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • i found it guys
    • So i just bought a RLcraft server for me and my friends to play on. I launched it and it is working fine but it tells me that i need to download all the mods i go to mods and press "minecraft forge" and nothing shows up that i can open files. If anyone have a suggestion i would need the help. This is the server hosting i  used 
    • i did it in 1.12.2 not walking for me can anyone help me get it pls???  
    • Got the rotation working. I had to look at LivingEntityRenderer#render and setupRotations a little more closely, and I realized that I needed to change the custom entity's yBodyRot and yBodyRotO.  private static boolean renderingCustomEntity = false; private static CustomEntity customEntity; private static void refreshCustomEntity(LocalPlayer localPlayer, LivingEntity livingEntity) { if (customEntity == null || customEntity.isRemoved()) { customEntity = ModEntities.CUSTOM_ENTITY.get().create(localPlayer.clientLevel); } if (!customEntity.level.dimension().equals(livingEntity.level.dimension())) { customEntity.discard(); } } @SubscribeEvent public static void replaceMobModel(RenderLivingEvent.Pre<LivingEntity, EntityModel<LivingEntity>> event) { LocalPlayer localPlayer = Minecraft.getInstance().player; if (localPlayer != null && event.getEntity() instanceof Mob mob) { if (/* put your own condition here */) { if (!renderingCustomEntity) { try { renderingCustomEntity = true; event.setCanceled(true); refreshCustomEntity(localPlayer, mob); // (truth be told, my custom entity does not have a "head", so these lines aren't needed) // customEntity.setYHeadRot(mob.getYHeadRot()); // customEntity.yHeadRotO = mob.yHeadRotO; customEntity.setYBodyRot(mob.yBodyRot); customEntity.yBodyRotO = mob.yBodyRotO; customEntity.setPose(mob.getPose()); Minecraft.getInstance().getEntityRenderDispatcher().getRenderer(customEntity).render( customEntity, customEntity.yBodyRot, event.getPartialTick(), event.getPoseStack(), event.getMultiBufferSource(), event.getPackedLight() ); } finally { renderingCustomEntity = false; } } } } }   As shown in my code, if the mob whose model is replaced moves to a different dimension, I unload the custom entity with Entity#discard and then reinitialize it on the next tick. I wonder if I also have to unload the custom entity when the mob it is "replacing" dies.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.