Jump to content

Server not starting


Recommended Posts

\Downloads\RAD2-Serverpack-1.11\RAD2-Serverpack-1.11>java -Xmx4G -jar forge-1.16.5-36.2.39.jar nogui
2024-06-07 07:44:01,788 main WARN Advanced terminal features are not available in this environment
[07:44:01] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.2.39, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui]
[07:44:01] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.1.3+8.1.3+main-8.1.x.c94d18ec starting: java version 17.0.1 by Oracle Corporation
Exception in thread "main" java.lang.IllegalAccessError: class cpw.mods.modlauncher.SecureJarHandler (in unnamed module @0xadd0edd) cannot access class sun.security.util.ManifestEntryVerifier (in module java.base) because module java.base does not export sun.security.util to unnamed module @0xadd0edd
        at cpw.mods.modlauncher.SecureJarHandler.lambda$static$1(SecureJarHandler.java:45)
        at cpw.mods.modlauncher.api.LamdbaExceptionUtils.uncheck(LamdbaExceptionUtils.java:95)
        at cpw.mods.modlauncher.SecureJarHandler.<clinit>(SecureJarHandler.java:45)
        at cpw.mods.modlauncher.Launcher.lambda$new$6(Launcher.java:55)
        at java.base/java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1708)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:52)
        at cpw.mods.modlauncher.api.TypesafeMap.computeIfAbsent(TypesafeMap.java:47)
        at cpw.mods.modlauncher.Environment.computePropertyIfAbsent(Environment.java:62)
        at cpw.mods.modlauncher.Launcher.<init>(Launcher.java:55)
        at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)
        at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:49)
        at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:46)
        at net.minecraftforge.server.ServerMain.main(ServerMain.java:43)

C:\Users\coleh\Downloads\RAD2-Serverpack-1.11\RAD2-Serverpack-1.11>pause
Press any key to continue . . .

Link to comment
Share on other sites

I am using java 8 I just downloaded it before trying the server cus I thought that was that issue. Unless I have to do something to make it use java 8 instead, but idk how to do that.

Yeah Im using java 8

Link to comment
Share on other sites

Copy the java 8 to the javaw.exe and replace the word java in your bat with the java 8 path

 

For example:
 

"C:\Program Files\Java\jre1.8.0_311\bin\javaw.exe" -Xmx4G -Xms2048M -jar server.jar 
pause 

Make sure the java 8 path is correct and keep the quotation marks

Link to comment
Share on other sites

C:\Users\coleh\OneDrive\Desktop\RAD2-Serverpack-1.11>"C:\Program Files\Java\jre-1.8\bin\javaw.exe" -Xmx8G -jar forge-1.16.5-36.2.39.jar nogui

C:\Users\coleh\OneDrive\Desktop\RAD2-Serverpack-1.11>pause
Press any key to continue . . .

Link to comment
Share on other sites

Ive had it running for a few min now and its just sitting at 

C:\Users\coleh\OneDrive\Desktop\RAD2-Serverpack-1.11>"C:\Program Files\Java\jre-1.8\bin\javaw.exe" -Xmx8G -jar forge-1.16.5-36.2.39.jar nogui

nothing else

is the "nogui" part making it so I cant see the logs while its loading? can i just delete that?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.