Jump to content

Item decompiler tile entity problem !


Yuri6037

Recommended Posts

Hi there,

I'm trying to make an item decompiler that will decompile by report to a crafting result, but this is extremely buggy, in plus some dropped items are fake, or are not dropped at all, and enougn sometimes it dropes more than nessessary...

 

Here is my TileEntity code (this class is handling the whole dropping and crafting recipe search system) :

package fr.stoneline.tileentity;

import net.minecraft.entity.item.EntityItem;
import net.minecraft.entity.player.EntityPlayer;
import net.minecraft.inventory.IInventory;
import net.minecraft.item.ItemStack;
import net.minecraft.item.crafting.CraftingManager;
import net.minecraft.item.crafting.ShapedRecipes;
import net.minecraft.tileentity.TileEntity;

import java.util.ArrayList;
import java.util.List;

public class TileEntityItemDecompiler extends TileEntity implements IInventory{
    private ItemStack theSlot;

    public TileEntityItemDecompiler(){
        theSlot = null;
    }

    public int getSizeInventory() {
        return 1;
    }

    public ItemStack getStackInSlot(int i) {
        return theSlot;
    }

    public ItemStack decrStackSize(int i, int j) {
        ItemStack var = theSlot;
        if (theSlot == null){
            return null;
        }
        if (theSlot.stackSize <= j){
            theSlot = null;
        } else {
            theSlot.stackSize -= j;
        }
        return var;
    }

    public void updateEntity(){
        if (theSlot != null){
            CraftingManager manager = CraftingManager.getInstance();
            List content = manager.getRecipeList();

            List<ShapedRecipes> var2 = new ArrayList<ShapedRecipes>();
            for (int i = 0 ; i < content.size() ; i++){
                if (content.get(i) instanceof ShapedRecipes){
                    var2.add((ShapedRecipes) content.get(i));
                }
            }

            ShapedRecipes recipe = getKeyFromValue(theSlot, var2);
            if (recipe != null){
                ItemStack[] var = recipe.recipeItems;
                for (ItemStack itemStack : var){
                    System.out.println(itemStack);
                    if (itemStack != null){
                        EntityItem item = new EntityItem(worldObj, xCoord + 0.5, yCoord + 1, zCoord + 0.5, itemStack);
                        worldObj.spawnEntityInWorld(item);
                        decrStackSize(0, recipe.getRecipeOutput().stackSize);
                    }
                }
            }
        }
    }

    private ShapedRecipes getKeyFromValue(ItemStack itemToCheck, List<ShapedRecipes> content){
        for (ShapedRecipes recipe : content){
            ItemStack var = recipe.getRecipeOutput();
            if (itemToCheck.stackSize >= var.stackSize && itemToCheck.itemID == var.itemID && itemToCheck.getItemDamage() == var.getItemDamage()){
                return recipe;
            }
        }
        return null;
    }

    public ItemStack getStackInSlotOnClosing(int i) {
        return theSlot;
    }

    public void setInventorySlotContents(int i, ItemStack itemstack) {
        theSlot = itemstack;
    }

    public String getInvName() {
        return "Item Decompiler";
    }

    public boolean isInvNameLocalized() {
        return false;
    }

    public int getInventoryStackLimit() {
        return 64;
    }

    public boolean isUseableByPlayer(EntityPlayer entityplayer) {
        return worldObj.getBlockTileEntity(xCoord, yCoord, zCoord) == this
                && entityplayer.getDistanceSq(xCoord + 0.5, yCoord + 0.5,
                zCoord + 0.5) < 64;
    }

    public void openChest() {}

    public void closeChest() {}

    public boolean isItemValidForSlot(int i, ItemStack itemstack) {
        return false;
    }
}

About the inventory itself, it's completely working, that's only when it tries to decompile that problems are begening...

 

Can you tell me why entities are so buggy and why sometimes it dropes not the correct items ?

 

Yuri6037

Link to comment
Share on other sites

WTF !? I have solved all the fake itemsbugs ! So YAY !

Now i get a realy strange problem :

The decompiler decompile only if no players are standing next to the block, i explain :

- Jump over the block and stay on ;

- Put some wood planks to decompile and get your logs back

- WTF !? Items are spawning and right after they dispawned !

This bug will reproduce until you restart the game ! So if you stay next to the block you will never get the decompiled items and this bug will rest until you restart game...

 

Do you have an idea ?

Yuri6037

Link to comment
Share on other sites

I've advanced a little on the bug : It seam to be a bug in the Minecraft entity spawn/despawn system...

I have tried to spawn each items after some seconds between the spawns, that not work... But if you place some Hoppers next to the block (for items to enter directly into hopper), all works fine ; there's no longer fake items or direct dispawns. But the bug is only coming if the player is next to the block !

Link to comment
Share on other sites

  • 2 weeks later...

Nobody can help ?

 

Can you confirm me that it's a bug with the game itself ?

 

Do you need more code ? I have the container, block and GUI classes if you want ; I already posted the decompiling core (tile entity)...

 

And if you know, CJB mods for old Minecraft 1.2.5, was adding a block acting like this one that I would like to make...

 

Please help...

Link to comment
Share on other sites

Seriously, no one knows.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Uh !

So it sounds like it's a bug in the Minecraft game itself... Thanks, Jeb, again thanks. Jeb, you succeed to make an ultra laggy game, ultra bugged game and crashing game and in plus you succeed to make a problem in your Entity interface ! Good, very good...

 

@Draco18s

After Notch cancelled the game, when the next version with Jeb comes up (Minecraft 1.3), i began to have almost a problem in all parts of the game... The last error i get is just Java heap space crash ! I just have 8 Gb of RAM, so Minecraft is taking more than 8Gb not possible, it's surely a problem in their side ! In plus every time (from the 1.3) i click on the connect to server button i get crash for 10 seconds and after i get the login screen ! In all cases almost of my problems begans when stupid Mojang put Multiplayer in Siglplayer (or the internal server) without this internal server i get not any bug, but when using it i get all the time a bug or a crash ! I can have a good PC, a PC that runs perfectly almost games, but only this game is not running perfectly !

But What the hell is that internal server ? Why this thing is creating so much problems ? Why they implemented that stupid thing ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Your drivers are in a broken state, follow the guide in the FAQ: https://forums.minecraftforge.net/topic/125488-rules-and-frequently-asked-questions-faq/#:~:text=How do I update my drivers%3F
    • A fatal error has been detected by the Java Runtime Environment: # # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffc3fe22b60, pid=15228, tid=5140 # # JRE version: OpenJDK Runtime Environment Microsoft-8035246 (17.0.8+7) (build 17.0.8+7-LTS) # Java VM: OpenJDK 64-Bit Server VM Microsoft-8035246 (17.0.8+7-LTS, mixed mode, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64) # Problematic frame: # C [atio6axx.dll+0x192b60] # # No core dump will be written. Minidumps are not enabled by default on client versions of Windows # # If you would like to submit a bug report, please visit: # https://aka.ms/minecraftjavacrashes # The crash happened outside the Java Virtual Machine in native code. # See problematic frame for where to report the bug i have no idea why please help
    • Quick-Books is great with regards to coordinating your monetary data. You can decide to live talk with a specialist at Quick-Books to get the answer for your questions. You will actually want to get to the talk going to the landing page and call us +1855-210-1428.
    • Update: I managed to make the item not disappear after crafting, but it doesn't remove any durability. import net.minecraft.enchantment.EnchantmentHelper; import net.minecraft.enchantment.Enchantments; import net.minecraft.enchantment.UnbreakingEnchantment; import net.minecraft.item.Item; import net.minecraft.item.ItemStack; public class NuggetHammer extends Item { private boolean damage; public NuggetHammer(Properties p_i48487_1_) { super(p_i48487_1_); } @Override public int getMaxDamage(ItemStack stack) { return 54 - 1; } public boolean isBarVisible(ItemStack stack) { return false; } @Override public ItemStack getContainerItem(ItemStack stack) { ItemStack copy = stack.copy(); copy.setCount(1); if (!this.damage) return copy; int unbreaking = EnchantmentHelper.getItemEnchantmentLevel(Enchantments.UNBREAKING, stack); for (int i = 0; i < unbreaking; i++) { if (UnbreakingEnchantment.shouldIgnoreDurabilityDrop(stack, unbreaking, random)) return copy; } copy.setDamageValue(stack.getDamageValue() + 1); if (copy.getDamageValue() > stack.getMaxDamage()) return ItemStack.EMPTY; return copy; } }  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.