Jump to content

HELP ME I DONT KNOW WHATS GOING ON!!!!!!


Serger13314

Recommended Posts

So i just now started setting up forge and eclipse it was all going well until i tried to run it and i got this!

 

 

[11:25:55] [main/ERROR]: Unable to launch

java.lang.ClassNotFoundException: cpw.mods.fml.common.launcher.FMLTweaker

at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_45]

at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_45]

at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_45]

at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_45]

at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_45]

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) ~[?:1.7.0_45]

at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_45]

at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:104) ~[launchwrapper-1.9.jar:?]

at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_45]

at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_45]

at java.lang.Class.forName0(Native Method) ~[?:1.7.0_45]

at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_45]

at net.minecraft.launchwrapper.Launch.launch(Launch.java:97) [launchwrapper-1.9.jar:?]

at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]

 

Please help i really do want to start java programing!

 

 

 

oh and also after i loaded my folder to eclipse it gave me these errors

Description Resource Path Location Type

Project 'ForgeMods' is missing required library: 'C:\Users\jlrem_000\Desktop\ForgeMods\unresolved dependency -  forgeBin 1.7.2-10.12.0.1024' ForgeMods Build path Build Path Problem

 

and:

 

Description Resource Path Location Type

The project cannot be built until build path errors are resolved ForgeMods Unknown Java Problem

 

 

Link to comment
Share on other sites

Did you run gradel setupDecompWorkspace and then after it was done run gradel eclipse?

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

[main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!

[10:14:23] [main/ERROR] [FML]: The minecraft jar

 

Ok so i ran in the folder again

 

gradlew setupDecompWorkspace

 

then did

 

gradlew setupDecompWorkspace eclipse

 

it worked! it fixed those two errors but now when i try to run it it just gives me this....

 

file:/C:/Users/jlrem_000/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.0.1024/forgeSrc-1.7.2-10.12.0.1024.jar!/net/minecraft/client/ClientBrandRetriever.class appears to be corrupt! There has been CRITICAL TAMPERING WITH MINECRAFT, it is highly unlikely minecraft will work! STOP NOW, get a clean copy and try again!

[10:14:23] [main/ERROR] [FML]: For your safety, FML will not launch minecraft. You will need to fetch a clean version of the minecraft jar file

[10:14:23] [main/ERROR] [FML]: Technical information: The class net.minecraft.client.ClientBrandRetriever should have been associated with the minecraft jar file, and should have returned us a valid, intact minecraft jar location. This did not work. Either you have modified the minecraft jar file (if so run the forge installer again), or you are using a base editing jar that is changing this class (and likely others too). If you REALLY want to run minecraft in this configuration, add the flag -Dfml.ignoreInvalidMinecraftCertificates=true to the 'JVM settings' in your launcher profile.

 

Link to comment
Share on other sites

Ok so i ran in the folder again

 

gradlew setupDecompWorkspace

 

then did

 

gradlew setupDecompWorkspace eclipse

 

What part of "run gradlew elcipse" did you not understand?

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.