Jump to content

[1.7.2] gradle conflicts with libtomcat7 & eclipse


Recommended Posts

Installing gradle seems to conflict with libtomcat-7.  Should I uninstall eclise, downgrade libtomcat, and just install eclipse again, or is there a better way?


using Ubuntu 13.10


$sudo aptitude install gradle



Reading package lists...

Building dependency tree...

Reading state information...

Reading extended state information...

Initializing package states...

The following NEW packages will be installed:

  bnd{a} checkstyle{a} gradle groovy{a} ivy{a} libaether-java{a}

  libaopalliance-java{a} libasm4-java{a} libasync-http-client-java{a}

  libatinject-jsr330-api-java{a} libbackport-util-concurrent-java{a}

  libbcpg-java{a} libcdi-api-java{a} libclassworlds-java{a}

  libcodenarc-groovy-java{a} libcommons-configuration-java{a}

  libcommons-jexl2-java{a} libcommons-jxpath-java{a}

  libcommons-net2-java{a} libcommons-vfs-java{a} libconstantine-java{a}

  libdom4j-java{a} libdoxia-java{a} libganymed-ssh2-java{a}

  libgeronimo-interceptor-3.0-spec-java{a} libgmetrics-groovy-java{a}

  libgoogle-collections-java{a} libgoogle-gson-java{a}

  libgradle-core-java{a} libgradle-plugins-java{a} libguava-java{a}

  libhttpclient-java{a} libhttpcore-java{a} libitext1-java{a}

  libjackrabbit-java{a} libjaffl-java{a} libjarjar-java{a} libjaxen-java{a}

  libjcifs-java{a} libjcip-annotations-java{a} libjdom1-java{a}

  libjetty-extra{a} libjetty-extra-java{a} libjffi-java{a} libjffi-jni{a}

  libjnr-posix-java{a} libjnr-x86asm-java{a} libjsoup-java{a}

  libjsr305-java{a} libkryo-java{a} liblogback-java{a}

  libmaven-ant-tasks-java{a} libmaven-parent-java{a} libmaven-scm-java{a}

  libmaven2-core-java{a} libminlog-java{a} libmockobjects-java{a}

  libmodello-java{a} libnative-platform-java{a} libnative-platform-jni{a}

  libnekohtml-java{a} libnetbeans-cvsclient-java{a} libnetty-java{a}

  libobjenesis-java{a} libplexus-ant-factory-java{a}

  libplexus-archiver-java{a} libplexus-bsh-factory-java{a}

  libplexus-build-api-java{a} libplexus-cipher-java{a}

  libplexus-classworlds-java{a} libplexus-classworlds2-java{a}

  libplexus-cli-java{a} libplexus-container-default-java{a}

  libplexus-containers-java{a} libplexus-containers1.5-java{a}

  libplexus-i18n-java{a} libplexus-interactivity-api-java{a}

  libplexus-interpolation-java{a} libplexus-io-java{a}

  libplexus-sec-dispatcher-java{a} libplexus-utils-java{a}

  libplexus-utils2-java{a} libpolyglot-maven-java{a} libqdox-java{a}

  libreflectasm-java{a} libsisu-guice-java{a} libsisu-ioc-java{a}

  libtomcat6-java{a} libwagon-java{a} libwagon2-java{a} libxbean-java{a}

  libxom-java{a} libxpp2-java{a} libxpp3-java{a} libxstream-java{a}

  maven{a} testng{a}

0 packages upgraded, 97 newly installed, 0 to remove and 1 not upgraded.

Need to get 56.8 MB of archives. After unpacking 86.8 MB will be used.

The following packages have unmet dependencies:

libtomcat7-java : Conflicts: libtomcat6-java but 6.0.37-1 is to be installed.

The following actions will resolve these dependencies:


    Remove the following packages:

1)    eclipse                   

2)    eclipse-jdt               

3)    eclipse-pde               

4)    eclipse-platform           

5)    eclipse-platform-data     

6)    libtomcat7-java           




Accept this solution? [Y/n/q/?] Abandoning all efforts to resolve these dependencies.




Link to comment
Share on other sites

Gradle wrapper is unmodified, it's directly from the original source.

As for a better way, using the wrapper would be the way to go as it doesn't install all the other libraries just the small package that is Gradle itself. It is your package manager that has the library issue not Forge or Gradle.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.