Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't exclude resources?


kenzierocks
 Share

Recommended Posts

I was moving in some of my .xcf files from GIMP to sit with the assets, and I didn't want them in the end user jar so I tried to exclude the xcfs folder I have under resources. However, regardless of how I do it, it ends up in the jar anyways.

 

Here's the build.gradle:

 

buildscript {

    repositories {

        mavenCentral()

        maven {

            name = "forge"

            url = "http://files.minecraftforge.net/maven"

        }

        maven {

            name = "sonatype"

            url = "https://oss.sonatype.org/content/repositories/snapshots/"

        }

    }

    dependencies {

        classpath 'net.minecraftforge.gradle:ForgeGradle:1.1-SNAPSHOT'

    }

}

 

apply plugin: 'forge'

 

version = "1.7.2-0.0.5a"

group= "com.techshroom.crystalix" // http://maven.apache.org/guides/mini/guide-naming-conventions.html

archivesBaseName = "crystalix"

 

minecraft {

    version = "1.7.2-10.12.0.1047"

    assetDir = "eclipse/assets"

}

sourceSets.main{

    java {

        srcDirs 'src'

    }

    resources {

        srcDirs 'resources'

    }

}

sourceSets.main.resources.exclude 'xcfs/**'

 

processResources {

    // replace stuff in mcmod.info, nothing else

    from(sourceSets.main.resources.srcDirs) {

        include 'mcmod.info'

    // replace $version and $mcversion

        expand 'version':project.version, 'mcversion':project.minecraft.version

    }

 

    // copy everything else, thats not the mcmod.info

    from(sourceSets.main.resources.srcDirs) {

        exclude 'mcmod.info'

    }

}

 

 

Link to comment
Share on other sites

I was moving in some of my .xcf files from GIMP to sit with the assets, and I didn't want them in the end user jar so I tried to exclude the xcfs folder I have under resources. However, regardless of how I do it, it ends up in the jar anyways.

 

gradle does not use your IDE's exclude setting when it builds. If they are in the assets folder they get included in the jar when you gradle build.

Link to comment
Share on other sites

I was moving in some of my .xcf files from GIMP to sit with the assets, and I didn't want them in the end user jar so I tried to exclude the xcfs folder I have under resources. However, regardless of how I do it, it ends up in the jar anyways.

 

gradle does not use your IDE's exclude setting when it builds. If they are in the assets folder they get included in the jar when you gradle build.

 

I know that, if you look at the build.gradle you'll notice I have an exclude right there.

Link to comment
Share on other sites

With build.gradle as:

buildscript {

    repositories {

        mavenCentral()

        maven {

            name = "forge"

            url = "http://files.minecraftforge.net/maven"

        }

        maven {

            name = "sonatype"

            url = "https://oss.sonatype.org/content/repositories/snapshots/"

        }

    }

    dependencies {

        classpath 'net.minecraftforge.gradle:ForgeGradle:1.1-SNAPSHOT'

    }

}

 

apply plugin: 'forge'

 

version = "1.7.2-0.0.5a"

group= "com.techshroom.crystalix" // http://maven.apache.org/guides/mini/guide-naming-conventions.html

archivesBaseName = "crystalix"

 

minecraft {

    version = "1.7.2-10.12.0.1047"

    assetDir = "eclipse/assets"

}

sourceSets.main{

    java {

        srcDirs 'src'

    }

    resources {

        srcDirs 'resources'

    }

}

 

processResources {

    // replace stuff in mcmod.info, nothing else

    from(sourceSets.main.resources.srcDirs) {

        include 'mcmod.info'

    // replace $version and $mcversion

        expand 'version':project.version, 'mcversion':project.minecraft.version

    }

 

    // copy everything else, thats not the mcmod.info

    from(sourceSets.main.resources.srcDirs) {

        exclude 'mcmod.info'

        exclude 'xcfs/**'

    }

}

 

 

 

Same thing.

Link to comment
Share on other sites

  • 10 months later...

Apologies for necro-posting, but since this is the top google result for "forge gradle exclude xcf files from jar", I thought I should put in my solution.

 

You can exclude using sourceSets, like this

 

sourceSets {

    main {

        resources {

            exclude '**/xcf_folder_name/*'

            exclude 'resources/assets/<modname>/path/to/xcf/folder/xcf_folder_name'

        }

    }

}

 

 

So, for my mod (Minechem), I use this:

 

sourceSets {

    main {

        resources {

            exclude '**/xcf/*'

            exclude 'resources/assets/minechem/xcf'

        }

    }

}

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.