Jump to content

[Solved][1.7.2]Need help referring to my sounds.json


Recommended Posts

(This is my first posting here, so let me know if I'm breaking any posting protocol)


I'm using latest/recent forge = 1047


Okay, I am trying a simple experiment to learn the new sound registration using sounds.json and can't quite make it work.


I'm pretty sure I have my assets folders organized properly, since other assets like textures work fine.  I also have properly used the plural "sounds" instead of "sound".  Anyway, I have put my sounds.json file in following folder: path: E:\Forge\eclipse\WildAnimals\src\assets\wildanimals\sounds.  I think this is correct: "WildAnimals" is my Eclipse project name, "wildanimals" is the modid.  I have put the sounds.json file in that folder and also put sub folders (with paths that match sounds.json) for the actual sounds.


Okay, to test this I have basically created a tiger entity that is pretty much an exact copy of a vanilla wolf except with an orange texture, with the idea that I would replace the sounds to sound more like a tiger.  I copied the actual sounds into my mod's sounds assets path described above.


Here is my sounds.json: https://gist.github.com/anonymous/9796472


To test this, in the EntityTiger I have the following method: https://gist.github.com/anonymous/9796757


I'm purposefully trying various references to aid my understanding of how to do it properly.  In other words, I'm trying to see which sounds.json is actually being accessed.


When I run my mod, it generally works (spawns tiger in jungle, the tigers act like wolves except with orange texure) however I get the following console errors:

[16:55:03] [Client thread/WARN]: Unable to play unknown soundEvent: minecraft:mob.tiger.step

[16:55:03] [Client thread/WARN]: Unable to play unknown soundEvent: wildanimals:mob.tiger.step


I do hear a step sound as well, which I assume is the vanilla wolf sound since there is no error related to that.


In other words, I just can't seem to figure out how to get it to reference my sounds.json file.  If I don't put any modid reference, it seems to grab the vanilla sounds.json, proven by fact that the wolf sound works and the tiger one fails (since there is no vanilla tiger).  Even when I explicitly tell it to use my modid asset it fails, but I don't understand this since that json does define mob.tiger.step.


So it all comes down to this, what step am I missing to ensure that Minecraft looks up the sounds based on my json rather than the vanilla one?  Is there some additional step to register the json?  Is there some build-path setting in Eclipse I have wrong? Or maybe I have the json in wrong path despite all my other assets working in same path?  Or what?



Check out my tutorials here: http://jabelarminecraft.blogspot.com/

Link to comment
Share on other sites

AFAIK, the sounds.json goes next to your sounds folder, not into it, in your case like:


instead of


Don't ask for support per PM! They'll get ignored! | If a post helped you, click the "Thank You" button at the top right corner of said post! |

mah twitter

This thread makes me sad because people just post copy-paste-ready code when it's obvious that the OP has little to no programming experience. This is not how learning works.

Link to comment
Share on other sites

Wow you're right.  That is one of those cases where you get blind to an error.  I checked it over so many times and compared with the Minecraft assets folder and my brain just kept seeing the file within the sounds folder rather than beside it.


So yes, the solution to my specific problem was that the sounds.json should be beside the sounds folder, not within it.


The answer to my general question (what is proper way to reference your sounds) is that you do need to put your modid in front of the sound name in order to decode it from your sounds.json otherwise it will pick up the vanilla sound.



Check out my tutorials here: http://jabelarminecraft.blogspot.com/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.