Jump to content

Forge disables all mobs

Recommended Posts


I've recently installed forge 1.7.10 and updated my server to forge 1.7.10. I've had this problem before (on forge 1.7.2) and tried everything to fix it but could not so I just went back to plain old boring vanilla Minecraft :P When i play offline or on the server there are no hostile mobs anywhere!! not during the day or night. At first i thought it was the mods but after an annoying half an hour, I found out it was the forge profile as i had uninstalled all the mods and still... no mobs, Changed the gamemode to peaceful and back again still no mobs, edited my game rules still no mobs, changed my view distance (despite the fact it was already on 20) still no mobs and googled and youtubed yet still no solution or mobs.

Please help if you can :P

Sam (--creeperSteve--)

Link to comment
Share on other sites

[17:33:10] [server thread/INFO]: Starting minecraft server version 1.7.10

[17:33:10] [server console handler/ERROR]: Exception handling console input

java.io.IOException: The handle is invalid

at java.io.FileInputStream.readBytes(Native Method) ~[?:1.8.0_11]

at java.io.FileInputStream.read(Unknown Source) ~[?:1.8.0_11]

at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.8.0_11]

at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.8.0_11]

at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.8.0_11]

at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_11]

at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.8.0_11]

at java.io.InputStreamReader.read(Unknown Source) ~[?:1.8.0_11]

at java.io.BufferedReader.fill(Unknown Source) ~[?:1.8.0_11]

at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_11]

at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_11]

at net.minecraft.server.dedicated.DedicatedServer$2.run(DedicatedServer.java:97) [lv.class:?]

[17:33:12] [server thread/INFO]: Loading properties

[17:33:12] [server thread/INFO]: Default game type: SURVIVAL

[17:33:12] [server thread/INFO]: Generating keypair

[17:33:12] [server thread/INFO]: Starting Minecraft server on *:25565

[17:33:13] [server thread/INFO]: Preparing level "world"

[17:33:14] [server thread/INFO]: Preparing start region for level 0

[17:33:15] [server thread/INFO]: Preparing spawn area: 0%

[17:33:16] [server thread/INFO]: Preparing spawn area: 38%

[17:33:17] [server thread/INFO]: Done (3.555s)! For help, type "help" or "?"

[17:33:24] [server thread/INFO]: Stopping the server

[17:33:24] [server thread/INFO]: Stopping server

[17:33:24] [server thread/INFO]: Saving players

[17:33:24] [server thread/INFO]: Saving worlds

[17:33:24] [server thread/INFO]: Saving chunks for level 'world'/Overworld

[17:33:24] [server thread/INFO]: Saving chunks for level 'world'/Nether

[17:33:24] [server thread/INFO]: Saving chunks for level 'world'/The End




Link to comment
Share on other sites

You're not posting the FML log as diesieben is saying.

Forge does not disable all mobs, obviouly this would not fly and would get immediatly fixed if this did happen.

We need your logs, we need your .minecraft folder, all mods, all saves, etc..

90% of the time it is caused by a mod you installed previously allocating mobs somewhere they should not be and they actually exist, but you just don't 'see' them.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Ok how about i upload the .minecraft folder and post the link? ill even attach my server folder.

I have taken all my mods out of the mods folder as to see if it would help. It didn't, but i have not re installed any mods. should I put them back, load up, even check for mobs to be triple sure and then post a link for download?

once again, Thanks for the help!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.