Jump to content

Running the latest forge on mac osx minecraft 1.3.2


fezz

Recommended Posts

heres the error report please help i havent found a single solution.

 

 

java.lang.NoClassDefFoundError: paulscode/sound/SoundSystem
at ayq.a(SoundManager.java:313)
at apn.a(SourceFile:63)
at apn.d(SourceFile:112)
at apn.m(SourceFile:100)
at net.minecraft.client.Minecraft.l(Minecraft.java:1482)
at net.minecraft.client.Minecraft.J(Minecraft.java:834)
at net.minecraft.client.Minecraft.run(Minecraft.java:764)
at java.lang.Thread.run(Thread.java:680)
Caused by: java.lang.ClassNotFoundException: paulscode.sound.SoundSystem
at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:125)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
... 8 more
Caused by: java.lang.NullPointerException
at org.objectweb.asm.ClassReader.<init>(Unknown Source)
at cpw.mods.fml.common.asm.transformers.SideTransformer.transform(SideTransformer.java:27)
at cpw.mods.fml.relauncher.RelaunchClassLoader.runTransformers(RelaunchClassLoader.java:167)
at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:118)
... 10 more
--- END ERROR REPORT 5b3aff83 ----------


 

Link to comment
Share on other sites

I'm not a pro, nor a mac user but your error log makes me deja vu. I've solved errors like this, like this;

 

Force update, delete meta-inf.

 

Before you put your mod files into jar, make sure that "they're not deleting each others' classes"

You can combine'em  in to a file before putting into jar.

 

(Don't know your level but) when you put mods into the mods file, you don't unzip

 

This is my best.

I'm just saying... If you didn't try it yet, just try it now. Better than nothing.

Link to comment
Share on other sites

I'm also a mac user (running 10.8.1) and I'm getting the exact same problem.  What do you mean make sure that "they're not deleting each others' classes"? I copy forge's class files into my minecraft.jar and replace all of the ones with the same name, is that wrong?

Link to comment
Share on other sites

Unfortunately with Macs, if you copy mod files and subfolders into the "minecraft.jar" folder (that you make while installing on a Mac) and "Replace" old files, if there were any subfolders of the same name already in the "minecraft.jar" folder, then it will remove everything from those subfolders and just replace them with the new files.

 

What this means for you is that, since FML has a "paulscode" subfolder (containing the file "paulscode/sound/codecs/CodecIBXM.class"), everything that was already in "paulscode" goes away - your entire soundsystem.

 

To get around this, you'll need to copy over everything else from that forge universal zip except for the "paulscode" subfolder, and then go down into the "paulscode/sound/codecs" subfolder and copy "CodecIBXM.class" directly into the "paulscode/sound/codecs" subfolder of your "minecraft.jar".  Or else use a mod installer/launcher program like Magic Launcher to avoid touching the "minecraft.jar" at all.

 

(It's a shame, really... if it weren't for that single "CodecIBXM.class" file, there'd be no problems with installing Forge on a Mac in the usual way.)

Link to comment
Share on other sites

Ya well we need that class or else users bitch about audiomod compatibility.

However in the last 10 builds or so i've forced forge to be bundled with all of /paulscode/ to hopefully resolve this situation, its crappy and stupid I know, but... macs.... -.-

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • i have the decocraft mod and i can see all of them. i can click right click and place the items but as soon as i put it down it disappears. im so sad it doesnt work and i dont know how to fix it. i used cursed forge to launch minecraft as well.
    • Me and my friend wanted to make a custom mod pack hosted on aternos. I downloaded the same mods as the server then started the server and my minecraft and I joined the server without issues. Then I sent the mods to my friend compressed in a zip folder (i don’t know if that has anything to do with the issue). He unpacked it put it in his mod folder and started it but couldn't join the server and got this issue:   internal exception: java.lang.runtimeexception: server not initialized yet! call IMDLib.entityHandler (modid)   Also we are using curseforge launcher to manage the mods on client side. But as I said it works on my side but not with my friend, that’s why it doesn’t make sense   Mod list:   xplosives-1.2.0.jar whisperwoods-1.18.2-2.1.0-forge.jar waystones-forge-1.18.2-10.2.2.jar voicechat-forge-1.18.2-2.4.32.jar trashslot-forge-1.18.2-11.0.3.jar towns_and_towers_forge-1.10.0.1+1.18.2.jar torchmaster-18.2.1.jar ToolBelt-1.18.2-1.18.9.jar toms_storage-1.18.2-1.4.4.jar swingthroughgrass-1.18.2-1.9.1.jar strictly_origins_v5.1_1.18.2.jar starlight-1.0.2+forge.546ae87.jar SpartanWeaponry-1.18.2-3.0.4.jar SimpleQuarry-1.18.2-18.2.5.jar simpleplanes-1.18.2-5.2.2.jar secretrooms-1.18.2-1.1.5.jar right-click-harvest-3.2.0+1.18.2-forge.jar REIPluginCompatibilities-forge-8.0.89.jar RoughlyEnough|tems-8.3.681-forge.jar RegionsUnexploredForge-0.4.1_1+1.18.2.jar TerraBlender-forge-1.18.2-1.2.0.126.jar Recall_Potion_v1.0.3-1.18.2.jar Quark-3.2-358.jar PickleTweaks-1.18.2-6.1.2.jar Pehkui-3.7.11+1.18.2-forge.jar Origins-1.18.2-1.4.1.4-unified.jar naturalist-forge-1.1.1-1.18.2.jar mysticaloaktree-1.18.2-1.2.jar selene-1.18.2-1.17.14.jar MysticalAgradditions-1.18.2-5.1.4.jar MysticalAgriculture-1.18.2-5.1.5.jar MultiMine-1.18.7.jar moyai-1.18.2-1.1.4.jar ModernDynamicSurroundings-5.0.0.4.jar lootbeams-1.18.1-release-july1722.jar journeymap-1.18.2-5.9.7-forge.jar ironfurnaces-1.18.2-3.3.3.jar ironchest-1.18.2-13.2.11.jar industrial-foregoing-1.18.2-3.3.1.6-10.jar titanium-1.18.2-3.5.11-45.jar immersive_armors-1.5.6+1.18.2-forge.jar hardcorerevival-forge-1.18.2-8.0.1.jar HammerLib-1.18.2-18.2.16. jar gravestone-1.18.2-1.0.1.jar geckolib-forge-1.18-3.0.57.jar findme-3.0.6-forge.jar faithfulbackrooms3.0.0.7.jar elevatorid-1.18.2-1.8.4.jar EasyMagic-v3.3.0-1.18.2-Forge.jar PuzzlesLib-v3.5.9-1.18.2-Forge.jar easy_villagers-1.18.2-1.0.11.jar easy_mob_farm_1.18.2-7.1.0.jar DynamicTrees-1.18.2-1.0.4.jar dragonseeker-1.1.1-1.18.2.jar iceandfire-2.1.12-1.18.2.jar Cucumber-1.18.2-5.1.5 jar cloth-config-6.5.116-forge.jar citadel-1.11.3-1.18.2.jar chunkloaders-1.2.8a-forge-mc1.18.jar supermartijn642configlib-1.1.8-forge-mc1.18.jar supermartijn642corelib-1.1.17-forge-mc1.18.jar cave_dweller-1.18.2-1.6.4.jar carryon-1.18.2-1.17.1.12.jar caelus-forge-1.18.1-3.0.0.2.jar BotanyTrees-Forge-1.18.2-4.0.13.jar BotanyPots-Forge-1.18.2-8.1.29.jar Bookshelf-Forge-1.18.2-13.3.56.jar balm-3.2.6.jar AutoRegLib-1.7-53.jar ars_nouveau-1.18.2-2.9.0.jar curios-forge-1.18.2-5.0.9.2.jar Patchouli-1.18.2-71.1.jar architectury-4.12.94-forge.jar almostunified-forge-1.18.2-0.3.10.jar [1.18.2] SecurityCraft v1.9.8.jar
    • Thank you for trying, I really appreciate it
    • It worked! Now I can run my modpack without crashes, thanks!
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.