Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Solved] Class file, classpath


glau
 Share

Recommended Posts

I came up with this yesterday. I've got some errors which LexManos underlined it and offered a solution like;

 

Caught exception from YourName_ModName

java.lang.ClassNotFoundException: tutorial.generic.Generic

 

Seems fairly straight forward:

You have a class named YourName_ModName which references tutorial.generic.Generic which is not in the class path.;

So you need to install tutorial.generic.Generic into your class path.

 

So it became a modder issue for me and  i moved here.

 

What i saw is the classpath was already set in eclipse included with "Minecraft/common path" (Isn't it suppose to be so, Isn't it why i set my eclipse workspace there, i don't know.). But it didn't work for me.

 

Because of me not good at java, I wonder if did i miss something, did i misunderstood LexManos?

 

I'm really getting sick of this creeper. I'm getting error messages in my dreams, really.

I woke up suddenly last night and found myself thinking about what should i do about this... Skeleton!

Guys really, help me please.

 

 

 

Link to comment
Share on other sites

-.- Why the hell do you think that having it in the MCP src folder

Would add it to your obfusicated classpath?

You need to stick the damn files into a zip file and shove it into your clients /mods folder, you know, like you do with every other mod...

 

And by the stack traces and what you've said from your toher thread this is not happening in eclipse, this is happening in your obfusicated jar.

So what does eclipse, or mcp have to do with anything?

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Hahaha. Swear me as you like. This thing is so crappy manual. I solved it, thanks to you. What i did wrong was I screwed up the tutorials i learned with every other mod on the market.

 

I was doing everything right but the only thing i did wrong was when i zip the folder, i did it like; Serenity.zip/serenity.class

But it should be like; Serenity.zip/serenity/common/serenity.class ( what i did on eclipse, according to the tutorials. All tutorials are that way but no mod i've ever seen like that. zip/mod_moddy.class i was considering)

 

I was thinking before, what the heck. Why all this folders here, what kind of obfuscating system is that. I know it now, it was completely me. It was retarded. I knew that it was that much retarded at the first time. Thanks again Kirk Lazarus. Here:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.