Jump to content

How do you port a mod from 1.7.10 to 1.6.4?


wildbill

Recommended Posts

I followed the same basic steps as 1.7.10.

 

I downloaded the recommended 1.6.4 src, placed it in a folder under Eclipse, but no gradlew was present, so I read the readme. It said to run the install.bat, but this is what I see:

 

 

C:\eclipse\forge-1_6_4>install

================ Forge ModLoader Setup Start ===================

MCP Detected already, not downloading

Setting up MCP

Patching commands.py

patching file commands.py

Commands patch applied successfully

Copying FML conf

Creating Repackaged data

Creating re-packaged srg

Creating re-packaged exc

Creating re-packaged MCP patches

Downloading 42 libraries

Backing up client

Backing up server

Download of minecraft_server.1.6.4.jar failed hash check, deleting abcf286a14f7aee82e8bf89270433509 ba3145656b1480122bd8

759cecd7b7a1

Something failed verifying minecraft files, see log for details.

Decompile Exception: 1

Press any key to continue . . .

 

C:\eclipse\forge-1_6_4>

 

I tried this several times. This is the output after several tries. I'm doing this on Windows 7. Could not find any log, not sure what that means.

 

Any idea what is wrong?

 

Thanks.

Link to comment
Share on other sites

I don't know why, but Forge 965 uses MCP.  Go get 964, which has Gradle.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.