Jump to content

Administrative Requirement for Gradlew Makestart?


Recommended Posts

Didn't really see this as a bug or issue as I found the solution, just a bit of curiosity.



JDK = build 1.8.0_25-b18

OS = Windows 8.1

Forge src =


So before when I was tinkering with 1.8's FML I had no issues setting up using the good old gradlew SetupDecompWorkspace eclipse, as well as a .bat that opened up the gradle GUI.


But when I went to set up a 1.8 Forge environment it failed to find my compiler during makestart, which I found quite odd. Went to double check my syntax for path and my path for the user variable, they were both clear. Running an echo shows the correct location of the JDK and running java with the version param brought up the correct info. All sanity checks passed, but the blasted makestart still wouldn't run due to it not being able to find my JDK. Scratched my head for a bit, tried a fresh gradlew setup, tried different versions, nada.


Just to do one final check before spending some time digging through the web, I ran command prompt as an administrator, mounted the directory, and ran gradlew makestart. It worked perfectly.


So I was wondering; has Gradle changed so that it requires administrative privileges, or has my environment somehow thrown a spanner in the works for the forge versions?

I think its my java of the variables.

Link to comment
Share on other sites

I haven't touched my JAVA_HOME variable since I set up my JDK and had decompiled the FML1.8 environment successfully.


Also went to check the administrative level and it doesn't have a set JAVA_HOME variable, yet it is required to access the JDK compiler...


width=800 height=450Screenshot%202014-12-18%2010.47.18.png?d [/img]


Must be my setup, but I've got no clue what could have changed for the compiler to only be accessed via administrator.

I think its my java of the variables.

Link to comment
Share on other sites

Actually I just stumbled on part of the answer. Using the "Open command window here" or launching a .bat opens up a different command prompt setup(including window format) as opposed to manually launching command prompt. Seems to not have access to the C:/Program for system variables. No clue why yet but it's something.


Definitely not a forge thing, and just means I'll have to do a manual launch of cmd to avoid this- Sorry about that :P

I think its my java of the variables.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.