Jump to content

Black screen, Linux specific


Recommended Posts

problem seems to be localized to gentoo comps in my house,  what is this error telling me? is there a specific path its trying to find the lwjgl files at? other than natives?


java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException



2012-10-18 23:54:42 [iNFO] [ForgeModLoader] Forge Mod Loader version for Minecraft client:1.3.2, server:1.3.2 loading

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] All core mods are successfully located

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Discovering coremods

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Found library file argo-2.25.jar present and correct in lib dir


2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Found library file guava-12.0.1.jar present and correct in lib dir


2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Found library file asm-all-4.0.jar present and correct in lib dir


2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Running coremod plugins

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Running coremod plugin FMLCorePlugin

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Coremod plugin FMLCorePlugin run successfully

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Running coremod plugin FMLForgePlugin

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Coremod plugin FMLForgePlugin run successfully

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Validating minecraft

2012-10-18 23:54:42 [FINEST] [ForgeModLoader] Minecraft validated, launching...

2012-10-18 23:54:43 [iNFO] [sTDERR] Exception in thread "Thread-3" java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException

2012-10-18 23:54:43 [iNFO] [sTDERR] at java.lang.Class.getDeclaredFields0(Native Method)

2012-10-18 23:54:43 [iNFO] [sTDERR] at java.lang.Class.privateGetDeclaredFields(Class.java:2308)

2012-10-18 23:54:43 [iNFO] [sTDERR] at java.lang.Class.getDeclaredField(Class.java:1897)

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.relauncher.ReflectionHelper.findField(ReflectionHelper.java:78)

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.relauncher.ReflectionHelper.setPrivateValue(ReflectionHelper.java:136)

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.relauncher.FMLRelauncher.setupNewClientHome(FMLRelauncher.java:111)

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.relauncher.FMLRelauncher.relaunchApplet(FMLRelauncher.java:231)

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.relauncher.FMLRelauncher.appletEntry(FMLRelauncher.java:200)

2012-10-18 23:54:43 [iNFO] [sTDERR] at net.minecraft.client.MinecraftApplet.init(MinecraftApplet.java:28)

2012-10-18 23:54:43 [iNFO] [sTDERR] at net.minecraft.Launcher.replace(Launcher.java:143)

2012-10-18 23:54:43 [iNFO] [sTDERR] at net.minecraft.Launcher$1.run(Launcher.java:87)

2012-10-18 23:54:43 [iNFO] [sTDERR] Caused by: java.lang.ClassNotFoundException: org.lwjgl.LWJGLException

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:125)

2012-10-18 23:54:43 [iNFO] [sTDERR] at java.lang.ClassLoader.loadClass(ClassLoader.java:423)

2012-10-18 23:54:43 [iNFO] [sTDERR] at java.lang.ClassLoader.loadClass(ClassLoader.java:356)

2012-10-18 23:54:43 [iNFO] [sTDERR] ... 11 more

2012-10-18 23:54:43 [iNFO] [sTDERR] Caused by: java.lang.NullPointerException

2012-10-18 23:54:43 [iNFO] [sTDERR] at org.objectweb.asm.ClassReader.<init>(Unknown Source)

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.common.asm.transformers.SideTransformer.transform(SideTransformer.java:27)

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.relauncher.RelaunchClassLoader.runTransformers(RelaunchClassLoader.java:167)

2012-10-18 23:54:43 [iNFO] [sTDERR] at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:118)

2012-10-18 23:54:43 [iNFO] [sTDERR] ... 13 more



Link to comment
Share on other sites

Eh? LWJGL is supposed to be downloaded by the launcher, but for some reason it's not found.

Follow this: http://www.minecraftwiki.net/wiki/Tutorials/Update_LWJGL

Read the EAQ before posting! OR ELSE!


This isn't building better software, its trying to grab a place in the commit list of a highly visible github project.




Don't PM me, I don't check this account unless I have to.

Link to comment
Share on other sites

updated my librarys to lwjgl 2.8.4 and now i get this in the minecraft window.. at least its a little better



java.lang.NoClassDefFoundError: org/lwjgl/util/glu/GLU

at ays.b(GuiMainMenu.java:275)

at ays.c(GuiMainMenu.java:391)

at ays.a(GuiMainMenu.java:425)

at auw.b(EntityRenderer.java:917)

at net.minecraft.client.Minecraft.J(Minecraft.java:882)

at net.minecraft.client.Minecraft.run(Minecraft.java:775)

at java.lang.Thread.run(Thread.java:722)

Caused by: java.lang.ClassNotFoundException: org.lwjgl.util.glu.GLU

at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:125)

at java.lang.ClassLoader.loadClass(ClassLoader.java:423)

at java.lang.ClassLoader.loadClass(ClassLoader.java:356)

... 7 more

Caused by: java.lang.NullPointerException

--- END ERROR REPORT 1a89df9a ----------





Link to comment
Share on other sites

For other people having this isue: You need to make all the native (the ones in ~/.minecraft/bin/native) libraries 64 bit (on 64 bit linux) or 32 bit (vice versa).

If that doesn't work, try reinstalling/updating/downgrading Java.

And if it still doesn't work, throw your monitor out the window.

Link to comment
Share on other sites

  • 3 weeks later...


I'm using Minecraft official launcher. it's making symlinks to lwjgl by it's own. I can play clean MC, but if I patch it with fml, get the same error like at the topic. I've tried to download lwjgl by myself — it still doesn't work.

I've tried sun's, oracle's and icedtea's JDK but still not working

Link to comment
Share on other sites

Eh? LWJGL is supposed to be downloaded by the launcher, but for some reason it's not found.

Follow this: http://www.minecraftwiki.net/wiki/Tutorials/Update_LWJGL


Minecraft is *not* supposed to download LWJGL or any .jar files on Gentoo. It just uses the system libraries insted of using its own.


Apparently that makes Forge just stand there dumbfounded not sure how to react. It seems to depend on all jars being shipped along with the game instead of being system-wide libraries.


/usr/games/bin/minecraft on Gentoo -- works perfectly with Vanilla, but Forge cannot compute

Link to comment
Share on other sites

1) dont bump old ass threads

2) Forge doesn't care where the jars as, it doesn't touch anything related to lwjgl So if you're hacking things around, you're gunna have to figure it out.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.