Jump to content

[1.4.2] Techcraft


Recommended Posts


By rex41043

Want to keep up to date on the mod's development progress? then you can go here to my development blog: http://blackholegaming.com


Dev team:



rex41043 Lead coder & founder

ilikepie1987 Co-lead coder

candycool1234 lead texture artist








BUILD: alpha (MC:1.4.2)

Minecraft Forge Version: 6.0.1

Download: http://adf.ly/ECjxP



+Added Safey Tape

+Added Secured Iron

+Added Secured Light

+Added new step sounds to some blocks

*Tweaked Purtonium ore so it can not be blowen up and is harder to mine

*Fixed a server bug, the mod will now run on servers



BUILD: alpha pre release (MC:1.4.2)

Minecraft Forge Version: 6.0.1

Download: http://adf.ly/E6ZE5



*Updated to minecraft 1.4.2

*Renamed the mod to Techcraft

+Added Research Codex

+Added Vile of Antidote



BUILD: alpha (MC:1.3.2)

Minecraft Forge Version: 4.2.5

Download: http://adf.ly/Da2rZ



*Re-coloured the name for the shards to be blue

+Added Viles

+Added Radioactive isotope

*tweaked the spawn rate of the ores as follows:

Triminium Ore will now spawn at Y 45 or below in vanes of 8

Diminium Ore will now spawn at Y 30 or below in vanes of 5

Dextonium Ore will now spawn at Y 25 or below in vanes of 4

and Purtonium Ore will now spawn at Y 25 or below in vanes of 2

+Added crafting recipes for the following blocks/items:

Empty Vile, Triminium Block, Diminium Block, Dextonium Block and Purtonium Block

*The Triminium, Diminium, Dextonium and Purtonium ingots can now be stacked up two 32



BUILD: alpha (MC:1.3.2)

Minecraft Forge Version: 4.2.5

Download: http://adf.ly/DYHPs



*re-named the mod to sciencecraft

*re-named all items to not have ‘meteor’ in the name Eg: form Triminium meteor ore too Triminium ore

+added new textures to the item sprite sheet(not yet used)

*did some back end tweaks to the code



BUILD: alpha (MC:1.3.2)

Minecraft Forge Version: 4.2.5

Download: http://adf.ly/925873/meteorcraft-build-0003-alpha-mc13



*re-named Blue meteor ore too Triminium meteor ore

*re-named Blue meteor shard too Triminium meteor shard

*re-named Blue meteor ingot too Triminium meteor ingot

*re-named Green meteor too Diminium meteor ore

*re-named Green meteor shard too Diminium meteor shard

*re-named Green meteor ingot too Diminium meteor ingot

*re-made most textures (thank you candycool1234)

+added Dextonium ore, shard, ingot and block

+added Purtonium ore, shard, ingot and block

+added smelting for all shard types

+added config file

+added ore generation for all meteor types









You can make Triminium, Diminium Dextonium and Purtonium ingots into the corresponding block.

Here is a way to store and compress the ingots in this mod and it dos not look half bad like this too :D



You can turn the blocks back into ingots as well (yes.. you do get nine back).



This is how you craft the Research Codex is will be used a tone in crafting.



Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I've been having trouble launching forge 1.19.4, i watched YouTube videos but i still don't have a solution.
    • This is my code: private void addCreative(Register<Block> event) { if (event.getTab() == CreativeModeTabs.BUILDING_BLOCKS) event.register(EXAMPLE_BLOCK); } Cannot resolve symbol 'Register'   How do I fix? I have tried the import import net.minecraftforge.registries.Register; but it doesn't work.   I also have these problems on that same code: Cannot resolve method 'getTab()' Cannot resolve method 'register(RegistryObject<Block>)'
    • my arrow wont move at all it would stay mid air and show no collision   my Entity class: package net.jeezedboi.epicraft.entity.custom; import net.jeezedboi.epicraft.init.ModItems; import net.minecraft.entity.EntityType; import net.minecraft.entity.LivingEntity; import net.minecraft.entity.projectile.AbstractArrowEntity; import net.minecraft.item.ItemStack; import net.minecraft.network.IPacket; import net.minecraft.util.math.EntityRayTraceResult; import net.minecraft.world.Explosion; import net.minecraft.world.World; import net.minecraftforge.fml.network.NetworkHooks; public class ExplosiveArrowEntity extends AbstractArrowEntity { // default constructor, required to register the entity public ExplosiveArrowEntity(EntityType<ExplosiveArrowEntity> entityType, World world) { super(entityType, world); } public ExplosiveArrowEntity(EntityType<ExplosiveArrowEntity> entityType, double x, double y, double z, World world) { super(entityType, x, y, z, world); } // the constructor used by the ArrowItem public ExplosiveArrowEntity(EntityType<ExplosiveArrowEntity> entityType, LivingEntity shooter, World world) { super(entityType, shooter, world); } // the item stack to give the player when they walk over your arrow stuck in the ground @Override protected ItemStack getArrowStack() { return new ItemStack(ModItems.EXPLOSIVE_ARROW.get()); } @Override protected void onEntityHit(EntityRayTraceResult result) { super.onEntityHit(result); // this, x, y, z, explosionStrength, setsFires, breakMode (NONE, BREAK, DESTROY) this.world.createExplosion(this, this.getPosX(), this.getPosY(), this.getPosZ(), 4.0f, true, Explosion.Mode.BREAK); } // called each tick while in the ground @Override public void tick() { if (this.timeInGround > 60){ this.world.createExplosion(this, this.getPosX(), this.getPosY(), this.getPosZ(), 4.0f, true, Explosion.Mode.BREAK); this.remove(); } } // syncs to the client @Override public IPacket<?> createSpawnPacket() { return NetworkHooks.getEntitySpawningPacket(this); } } my item class :   package net.jeezedboi.epicraft.item.custom; import net.jeezedboi.epicraft.entity.custom.ExplosiveArrowEntity; import net.jeezedboi.epicraft.init.ModEntityTypes; import net.minecraft.entity.LivingEntity; import net.minecraft.entity.projectile.AbstractArrowEntity; import net.minecraft.item.ArrowItem; import net.minecraft.item.ItemStack; import net.minecraft.world.World; public class ExplosiveArrowItem extends ArrowItem { public ExplosiveArrowItem(Properties props) { super(props); } @Override public AbstractArrowEntity createArrow(World world, ItemStack ammoStack, LivingEntity shooter) { ExplosiveArrowEntity explosiveArrowEntity = new ExplosiveArrowEntity(ModEntityTypes.EXPLOSIVE_ARROW.get(), shooter, world); return explosiveArrowEntity; } } other stuffs: public static final RegistryObject<Item> EXPLOSIVE_ARROW = ITEMS.register("explosive_arrow", () -> new ExplosiveArrowItem(new Item.Properties().group(ModItemGroup.Epic_Items))); public static final RegistryObject<EntityType<ExplosiveArrowEntity>> EXPLOSIVE_ARROW = ENTITY_TYPES.register("explosive_arrow", () -> EntityType.Builder.create((EntityType.IFactory<ExplosiveArrowEntity>) ExplosiveArrowEntity::new, EntityClassification.MISC) .size(0.5F, 0.5F).build("explosive_arrow")); mappings channel: 'snapshot', version: '20210309-1.16.5'
    • may i ask what it was that fixed it, I'm having the same problem and its frustrating because I'm making an origin.
    • I need to accesses byPath field of net.minecraft.client.renderer.texture.TextureManager. As I found out I need to use accesstransformer.cfg file and make the field public via it. In this file field names look like f_<numbers>. And I was unable to figure out, how to get those. It seems like it is connected to something called mappings (thing left after Minecraft decompile process). How can I get such a name for a class field?
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.