Jump to content

[1.7.10] Problem connecting to server made for custom modpack


Recommended Posts

I created a modpack for a friend and I in MultiMC using forge version as the latest was incompatible with one of the mods. Everything worked fairly well until I tried making a server for it. When attempting to connect it shows the login screen as normal, but when we would join the game it shows a screen with the error Internal Exception: java.lang.IllegalStateException: Registry entry for ItemBlock net.minecraft.item.ItemBlock@c269425, id 48, is missing or uses the non-matching id -1. ID 48 is Mossy Cobblestone.


Again, it runs smoothly on singleplayer. First I tried removing all the unnecessary client mods from the server, but that just made it crash. Then I put them back and it stopped crashing, and I updated the server to the correct version of forge as I had accidentally downloaded the installer for a much earlier version.


It is worth mentioning that I used the recommended versions of ChickenBone's mods and thus had to use a earlier version of Waila. I've included the version numbers accordingly.

[spoiler=the mods]Auto Paths(does not show up in the multimc mod list)



Blood Magic



Chisel 2


Example Mod by Example Dude(? I didn't put it there. Possibly part of a api mod.)


Flat Signs

Forbidden Magic


Magic Bees


Mystcraft + Looking Glass

Nei Addons/Integration(both forestry plugins)


Omnis Core

Project Red(Core + Compatibility, Exploration, Illumination, Transmission)

Steves Factory Manager

Tainted Magic


Thaumic Horizons

Thaumic Pipes

Thaumic Tinker

TiC Tooltips

Tinkers Construct



Waila 1.5.7a



The server log can be found at https://gist.github.com/anonymous/935b6c2193c0c22e39bc


Edit: Ack! I forgot the title!

Link to comment
Share on other sites as the latest was incompatible with one of the mods.


Also the issue is you removed/updated a mod that was claiming the mossy cobble stone id and screwed it up, most likely NEI or something like that.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites


Idk. I think it was Tinkers or something, but it kept doing funny stuff and crashing the game.

Or perhaps I have terrible memory and I did it just because. I think it was the first one though.


Also the issue is you removed/updated a mod that was claiming the mossy cobble stone id and screwed it up, most likely NEI or something like that.

I made the server after already putting the mods together though. What I did was I just copied the mods folder from the instance, so I don't know where removing a mod would come in.


[Edit]: Wait a Minute, I remember that mossy cobble was missing a texture, but I must have been tired and dismissed it. I'll fix it tomorrow and lock the thread if there's no more problems.

Link to comment
Share on other sites

I have the same problem with ID 98 :(

I have all your mods except AutoPath, Fastcraft, Tainted magic, Thaumic horizons and Tubes.


But I had no problem with any texture ... And the world of the server was used with other versions of my mods (I updated ~20 mods before the problem).

Link to comment
Share on other sites

Alright, I made a new instance with fresh copies of the mods from my downloads folder, removing lookingglass as it caused mystcraft to crash during profiling. I started a singleplayer world and it crashed, so i updated forge to and it no longer crashes. Mossy Cobble does not appear in the creative menu and looking up the recipe for a chisel2 varient shows fire in the first slot, however fire does not work in a chisel.

The recipe for Tinker's Construct's ball of moss shoes that it still has a id of -1. Additionally, looking up Moss Stone in Nei, both mossy cobblestone and moss stone bricks show up twice  under their normal ids, but cannot be used for anything other than being placed.





Attempting to join the server now shows the error "Mod rejections [FMLMod:ForgeMicroblock{}, FMLMod:ForgeMultipart{}, FMLMod:LookingGlass{}, FMLMod:McMultipart{}]", but I'm guessing that means that I have to update the server to the same forge version, right?


[Edit:]It turns out that the problem was simply that the newest version of Chisel 2 is kinda broken. After removing it Mossy Cobblestone returned to normal.

[Edit2:]Wait, the game crashed because of Chicken Chunks and now it's broken again after removing it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.