Jump to content

1.4.4 MCP Setup - Installing Forge fails


Recommended Posts

Hi All,


I'm trying to install forge for my MCP on 1.4.4(it is updated, right?), I want to update my mod.


On 1.4.2 everything worked just fine, but now, when running install.SH (I'm on a Mac) I get this error:




================ Forge ModLoader Setup Start ===================
Setting up MCP
> Restoring commands.py backup
patching file commands.py
Commands patch applied successfully
Copying FML conf
Fixing MCP Workspace
== MCP 7.21 (data: 7.21, client: 1.4.4, server: 1.4.4) ==
The cleanup script will delete all folders created by MCP, including the
src folder which may contain changes you made to the code, along with any
saved worlds from the client or server.
If you really want to clean up, enter "Yes" Yes
> Cleaning temp
> Cleaning src
> Cleaning bin
> Cleaning reobf
> Cleaning lib
> Cleaning jars
> Cleaning logs
File Exists: lwjgl.jar
File Exists: lwjgl_util.jar
File Exists: jinput.jar
File Exists: windows_natives.jar
Traceback (most recent call last):
  File "install.py", line 40, in <module>
  File "install.py", line 19, in main
  File "/Users/Maxi/Documents/Privat/Projekte/Java/MC/MoreBlockz MOD 144/forge/fml/fml.py", line 309, in setup_fml
    pre_decompile(mcp_dir, fml_dir)
  File "/Users/Maxi/Documents/Privat/Projekte/Java/MC/MoreBlockz MOD 144/forge/fml/fml.py", line 139, in pre_decompile
    download_minecraft(mcp_dir, fml_dir)
  File "/Users/Maxi/Documents/Privat/Projekte/Java/MC/MoreBlockz MOD 144/forge/fml/fml.py", line 106, in download_minecraft
    failed = not download_native(default['base_url'], os.path.join(bin_folder, 'natives'), native) or failed
  File "/Users/Maxi/Documents/Privat/Projekte/Java/MC/MoreBlockz MOD 144/forge/fml/fml.py", line 71, in download_native
    with ZipFile(target) as zip:
AttributeError: ZipFile instance has no attribute '__exit__'




As of now, I'm using the latest version of forge ( and I also completely reinstalled MCP a couple of times, tried redownloading forge and so on.


I'm getting a fresh minecraft.jar by creating a clean instance in MultiMC, and the server.jar is also fresh from minecraft.net.



I know there are plenty of similar bug reports, I tried looking through all of them before posting, but none of the error-logs seem to have similar errors.



Help is much appreciated  :)




Link to comment
Share on other sites

Python 3.x is completely different to 2.x, you want the latest version of Python 2.

Protip: try and find answers yourself before asking on the forum.

It's pretty likely that there is an answer.


Was I helpful? Give me a thank you!



width=635 height=903http://bit.ly/HZ03zy[/img]



Tired of waiting for mods to port to bukkit?

use BukkitForge! (now with a working version of WorldEdit!)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.