Jump to content

[Resolved] Problem with id when forge 1.8 to 1.8.9


Flashback083

Recommended Posts

Hello ! I try to upgrade my server, mod and plugin in 1.8 to 1.8.9.

The server start without problem but when im log in... the id of block / item are different ! so i look for level.dat and i see a big difference for FML registeri, and the id isnt same :confused:

 

Where i make mistake ? i forgot something ?

Thanks for all >w<

 

PS : the still appears even if i test the map in solo mod

PS 2 : the bug is not present in 1.8.8 but i cant do 1.8 -> 1.8.8 -> 1.8.9

Thanks !

Flash <3

Link to comment
Share on other sites

Why would you care about IDs? Aren't they supposed to be hidden in the guts of the game? If you're mods use IDs, then they're going to be fragile, and they won't play nice with other mods.

 

Besides IDs changing, did you have any actual symptoms that affected game play?

The debugger is a powerful and necessary tool in any IDE, so learn how to use it. You'll be able to tell us more and get better help here if you investigate your runtime problems in the debugger before posting.

Link to comment
Share on other sites

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.