Jump to content

[1.7.10]Dedicated server error


Enginecrafter

Recommended Posts

Hi there. Recently I tried to run my mod on server(using forge pre-built server run config). It worked fine until I tried to access any GUI. For example Gui of my machine compressor.

 

Here is my crash report.

http://pastebin.com/hWbGUNSV

 

If you need my code for solving, simply wirte reply and I will post them.

I will accept any help.

Sorry, if you find mistaches in my posts.

I am not EN.

And when I post anything on Modder support, it means, I can't help myself and I need your help. And when you decide to delete my topic, just PM me with the reason, please.

Link to comment
Share on other sites

Ok I will have a look at it tomorrow and wirte a reply. Anyway thanks for helping for now.

Sorry, if you find mistaches in my posts.

I am not EN.

And when I post anything on Modder support, it means, I can't help myself and I need your help. And when you decide to delete my topic, just PM me with the reason, please.

Link to comment
Share on other sites

f you need my code for solving, simply wirte reply and I will post them.

I will accept any help.

 

I so not need your code because I am psychic. Your widget is missing a thingamajig and it's vomiting all over the processor.

 

(Hint: always post code, especially the class mentioned in the crash, ScreenCompressor)

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Sorry Draco I didn't have much time to copy all the code. I am so sorry.

 

Well, some of us don't have time to read your mind. It's a lot of work.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Fixed, the mistake was I referred to variable(GUI_ID) that was stored inside each GUI class. I moved them to GUI Handler. Anyway thank you for help. And special thanks to Choonster for giving me clue to fix it :)

Sorry, if you find mistaches in my posts.

I am not EN.

And when I post anything on Modder support, it means, I can't help myself and I need your help. And when you decide to delete my topic, just PM me with the reason, please.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.