Jump to content

[1.9.4] Custom Hopper with same model and texture as vanilla hopper?


GamrCorps

Recommended Posts

I currently have a custom hopper which uses the exact same code as the vanilla hopper (accomplished by having BlockAdvancedHopper extend BlockHopper and TileEntityAdvancedHopper extend TileEntityHopper), but it is going gain additional functionality down the road. How do I make it  so the custom hopper uses the same models and textures as the vanilla hopper? I have not been able to find anything on the subject, which is why I'm asking here. I'm using version 1.9.4 Forge. The block works just fine, the problem is just the model and texture.

Link to comment
Share on other sites

The hopper uses the same baked model system as regular blocks, you can change your block's model and textures from its blockstates file.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Try providing the location of hopper model through ModelLoader.setCustomModelResourceLocation(...),

and bind hopper state mapper using

ModelLoader.setCustomStateMapper((Your Block), (new StateMap.Builder()).ignore(new IProperty[] {BlockHopper.ENABLED}).build());

(Gotten from BlockModelShapes#registerAllBlocks)

 

This will ensure that the model will be identical to the vanilla hopper model in any case.

 

If you want to make your model modifiable in resourcepacks, you should copy the model, textures, and blockstates file for the hopper.

 

EDIT: first parameter of setCustomStateMapper should be your block, sorry for the previous mistake.

I. Stellarium for Minecraft: Configurable Universe for Minecraft! (WIP)

II. Stellar Sky, Better Star Rendering&Sky Utility mod, had separated from Stellarium.

Link to comment
Share on other sites

Try providing the location of hopper model through ModelLoader.setCustomModelResourceLocation(...),

and bind hopper state mapper using

ModelLoader.setCustomStateMapper((Your Block), (new StateMap.Builder()).ignore(new IProperty[] {BlockHopper.ENABLED}).build());

(Gotten from BlockModelShapes#registerAllBlocks)

 

This will ensure that the model will be identical to the vanilla hopper model in any case.

 

If you want to make your model modifiable in resourcepacks, you should copy the model, textures, and blockstates file for the hopper.

 

EDIT: first parameter of setCustomStateMapper should be your block, sorry for the previous mistake.

 

How would I go about implementing ModelLoader#setCustomResourceLocation?

 

I tried

        ModelLoader.setCustomModelResourceLocation(Item.getItemFromBlock(MyMod.instance.hopper), 0, new ModelResourceLocation("block/hopper"));

but it threw a NullPointerException.

Link to comment
Share on other sites

Ok, I have sorted out most of the problems, I just need to figure out how to correctly reference and assign the model names. Here is the current code:

   ModelLoader.setCustomModelResourceLocation(TestMod.instance.hopperItemBlock, 0, new ModelResourceLocation("models/block/hopper_down"));
        ModelLoader.setCustomModelResourceLocation(TestMod.instance.hopperItemBlock, 0, new ModelResourceLocation("models/block/hopper_side"));
        ModelLoader.setCustomStateMapper(TestMod.instance.hopper, (new StateMap.Builder()).ignore(new IProperty[]{BlockHopper.ENABLED}).build());
    

Link to comment
Share on other sites

How do I make it  so the custom hopper uses the same models and textures as the vanilla hopper?

I've tried both extending the class and copying the code but neither change the model or texture of the block.

 

This amuses me.  I read this as "I want to use the same textures, but when I tried that, it used the same textures (achieving the effect I want): Something is wrong."

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I had a similar issue to what you do above. Given this is an old post, you've probably sorted this now In my case, I had Java (JDK) 22 installed. After uninstalling that and installing 17.0.11 (having both installed gives the same error), then running the startserver.bat worked for me. I managed to get to the EULA section and then start my server correctly- I hope it helps anyone else who may have this issue!
    • Make a test with another Launcher like MultiMC, AT Launcher or Technic Launcher
    • I opened up Minecraft today for the first time in a month and whenever I try and play forge I get an error 1 message. I restarted my computer, tried reinstalling both Minecraft and Forge and have updated all of my drivers. Nothing seems to work so I'm stumped. I have absolutely no mods installed ATM so I have no idea what could be causing the problem. I hope yall are able to help.   DebugLog:   [19May2024 20:33:51.600] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, dmoy18, --version, 1.20.1-forge-47.2.0, --gameDir, C:\Users\dmoyf\AppData\Roaming\.minecraft, --assetsDir, C:\Users\dmoyf\AppData\Roaming\.minecraft\assets, --assetIndex, 5, --uuid, c083972cd92d4dd2894beb25b82ebe82, --accessToken, ????????, --clientId, MDljMzIwMjYtOTJiNS00YWUxLTk1M2EtN2ExMGExZWM0MDAw, --xuid, 2535417310772497, --userType, msa, --versionType, release, --quickPlayPath, C:\Users\dmoyf\AppData\Roaming\.minecraft\quickPlay\java\1716168829421.json, --launchTarget, forgeclient, --fml.forgeVersion, 47.2.0, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412] [19May2024 20:33:51.604] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 17.0.8 by Microsoft; OS Windows 11 arch amd64 version 10.0 [19May2024 20:33:51.634] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [fmlclientdev,forgeclient,minecraft,forgegametestserverdev,fmlserveruserdev,fmlclient,fmldatauserdev,forgeserverdev,forgeserveruserdev,forgeclientdev,forgeclientuserdev,forgeserver,forgedatadev,fmlserver,fmlclientuserdev,fmlserverdev,forgedatauserdev,testharness,forgegametestserveruserdev] [19May2024 20:33:51.653] [main/DEBUG] [cpw.mods.modlauncher.NameMappingServiceHandler/MODLAUNCHER]: Found naming services : [srgtomcp] [19May2024 20:33:51.668] [main/DEBUG] [cpw.mods.modlauncher.LaunchPluginHandler/MODLAUNCHER]: Found launch plugins: [mixin,eventbus,slf4jfixer,object_holder_definalize,runtime_enum_extender,capability_token_subclass,accesstransformer,runtimedistcleaner] [19May2024 20:33:51.681] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Discovering transformation services [19May2024 20:33:51.688] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path GAMEDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path MODSDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft\mods [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path CONFIGDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft\config [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path FMLCONFIG is C:\Users\dmoyf\AppData\Roaming\.minecraft\config\fml.toml
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.