Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.10.2]Custom WorldType has incredibly small biomes


Matryoshika
 Share

Recommended Posts

Hello!

 

I have a Custom WorldType, called CAVES (Underworld in localization), which uses a crude Nether ChunkProvider & BiomeProvider, that have been converted to make use of Overworld blocks & biomes instead.

Everything works fine, bar one thing.

 

Let's say I stand in a Taiga biome. I take 1 step forward, and I'm in an ocean biome. Another step, and I'm inside a river biome.

Some biomes are just 1x1 block big, others can be up to 30 wide, but barely 10 long. If I fly more than 20 blocks, I almost always encounter 10 different biomes shoved unto eachother.

 

I have gone over my code countless times now for over two days, and I cannot find anything that relates to the size of the biomes.

I tried changing the width variable in the biomesForGeneration inside my ChunkProviderCaves#prepareHeights, which was the only variable that seemed related to the size of a biome. A change from 10 to 99 did nothing, sadly.

 

I just want these damned biomes to be of "proper" size, not a minimalist's dream. Anyone here able to make heads or tails of this issue?

 

My GitHub with the related sourcecode: https://github.com/Matryoshika/Underworld/tree/master/src/main/java/se/Matryoshika/Underworld/WorldGen

 

Issue fixed: my chunkProvider had 2 calls to the biomesForGeneration, and wasn't using multiples of 16, causing the biomes to bleed into eachother

Also previously known as eAndPi.

"Pi, is there a station coming up where we can board your train of thought?" -Kronnn

Published Mods: Underworld

Handy links: Vic_'s Forge events Own WIP Tutorials.

Link to comment
Share on other sites

Have you done anything with GenLayer increasing biome sizes? (GenLayerZoom)

 

example: https://github.com/Alex-the-666/archipelago/blob/master/src/main/java/com/github/alexthe666/archipelago/world/GenLayerArchipelago.java

 

No, I have not done anything with GenLayer, bar a single call in my BiomeProviderCaves constructor, which only calls the Genlayer#initializeAllBiomeGenerators().

 

I just made my own GenLayerCaves, which mirrored your code, and with multiples tries, with variables becoming quite ridiculously large, for testing, but no actual difference at all, even if I throw in a GenLayerZoom#magnify call in there as well.

Also previously known as eAndPi.

"Pi, is there a station coming up where we can board your train of thought?" -Kronnn

Published Mods: Underworld

Handy links: Vic_'s Forge events Own WIP Tutorials.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.