Jump to content

Forge tells me that its version is incompatible although I updated it.


ViAik

Recommended Posts

I have a rather weird problem here. I'll start at the beginning.

The version is 1.7.10, reason for that is mods. Another detail is that I used universal version of forge, there are reasons for that and I cannot use an installer in any way.

The version I used was the recommended version downloaded from files.minecraftforge.net, which is 10.13.4.1558. It worked fine with all of my 42 mods. Then I decided to add another mod (RTG if that matters). When I did that, it started telling me at Minecraft startup that

Forge : minimum version required is 10.13.4.1558

 

aul36ey.png

 

That's weird, isn't it? I already had that version installed. So I decided that the problem is in the mod, and deleted it. After some time (without adding any more mods) I've added another mod (Ex Futurum if you need that). And guess what? It started doing the same thing. Minimum version required is 10.13.4.1558. I deleted the mod, and tried adding another random mod, and after testing about 5 different mods they worked fine. The problem was only with these two. I don't know if there are any other mods with that problem.

What I also tried to do is installing the newest version of Forge instead, which is 10.13.4.1614. Absolutely no differences occured. And yes, I did re-install both Minecraft and Forge from scratch in both cases.

I could live without those two mods, but I really want them, and it seems that I won't be able to do anything about this problem without your support, which would be exceptionally highly appreciated.

P.S. Sorry for my English if there's anything wrong with it, I'm not native English-speaking.

Thanks, ViAik

Link to comment
Share on other sites

- There is no valid reason not to use the installer.

- There is no valid reason to be on 1.7.10.

- There is no valid reason why you have not posted the FML log like instructed in the rules.

 

-I have a server that uses a non-traditional file structure. I need minecraft.jar with FML by itself, without other Minecraft files.

-I have 42 mods. 90% of them are not released for 1.8, or 1.9, or 1.10.

-There is no log file, I looked for it. If there was one - I would put it here. There's no reason for me to not follow the rules.

Link to comment
Share on other sites

-I have a server that uses a non-traditional file structure. I need minecraft.jar with FML by itself, without other Minecraft files.
Ehm, what?

This is not supported by forge in any way. Any issue you have with this setup is up to you to fix.

-I have 42 mods. 90% of them are not released for 1.8, or 1.9, or 1.10.
That is not a reason.

1.7.10 is no longer supported by forge. This is like you calling up Microsoft asking them about fixing your Windows 98 installation because this special program you have is not updated. They will laugh at you.

-There is no log file, I looked for it. If there was one - I would put it here. There's no reason for me to not follow the rules.

If you have any kind of forge installed, there will be logs/fml-server-latest.log.

- I did not make this setup. The problem is with Forge, not with my server, because I have the same problem on regular Minecraft.

- If I move to 1.10, I will have to delete almost all of my mods. If I wanted to play on vanilla - I wouldn't use Forge. There is a reason why I'm using mods. And your comparison doesn't make any sense. A ton of people use 1.7.10 for mods. Because a ton of very popular mods are not updated to 1.8, or are in progress.

- Do you think I'm blind? There is no log. There is even no log folder. If you want screenshots of my folders - I can upload them.

 

If you don't know how to help me, please don't reply, with all the respect. I posted here because I need help, not because I want people rudely telling me to delete all of my mods and play on 1.10. I am not as dumb as you think I am.

Link to comment
Share on other sites

Use the installer, and post logs.

1) There is no reason NOT to use the installer if your server designed in fucked up then fix the server.

2) There is ALWAYS a log, SOMETHING ALWAYS happens when you try running the server.

But again, as stated we do not support 1.7.10.

If you want support update your shit.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.