Jump to content

Forge for 1.10.2 abnormally slow with less than 3gb memory allocated


Recommended Posts

Been trying to run several 1.10.2 packs (Unstable, All The Mods) and after that done some troubleshooting myself.


The problem is that Forge startup becomes incredibly slow when starting Model Loader. As in loading the 25k-something objects around 10 per around 2 seconds.


The results of my troubleshooting ranged from no changes to java freezing/crashing or OS freezing/crashing.


I have no issues on the same setup using Forge for 1.10 packs. I have 4gb memory, but it is not possible to allocate 3gb to a single program as the OS will become unusably slow.


A friend with a better computer also tried to run same modpacks with less than 3gb memory and met the exact same results.


I tried:

  • forge-1.10-
  • forge-1.10-
  • forge-1.10-
  • forge-1.10-
  • Disabling background programs
  • Updating java
  • Giving java higher/lower priority
  • Allocating less memory and trying to wait it out
  • Disabling forge updating
  • Disabling splashscreens
  • Disabling AV


Is there a way to revert the new Forge to earlier settings to make it usable again or are there plans to optimize it?

Link to comment
Share on other sites

It's not necessarily a forge issue, i don't know off hand how many mods are in that pack, but id venture to guess 50-100+ and around that point 4gb of overall system memory just really doesn't cut it. More mods inherently means more RAM usage, if you want better performance try disabling some mods that you don't use. And if you can't do that, unless you have a 32bit computer, just upgrade your ram and add another 4 gigs.

Link to comment
Share on other sites

I understand that, but I have had no issues with even larger modpacks on 1.7.10 Forge or 1.10 Forge with 2gb allocated.


The problem occurs only on 1.10.2 Forge with less than 3gb memory allocated. Even with reduced mods Forge startup takes an abnormal amount of time.

Link to comment
Share on other sites

Nothing in FOrge changed that would cause anything like this from 1.10.0 to 1.10.2 Thats all vanilla changes.

The mods on the other hand could have a lot thats changed inside them.

My Forge load times are about 15 seconds so it's not reproduceable on my end.

You are gunna need to give more details.

And/Or try tracking it down to a SPECIFIC build yourself.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites


Intel Core 2 Duo @ 1.86ghz

Radeon HD 5450

4gb ddr2 (2gb allocated for client)

java 8 update 101

forge-1.10- with FTB 1.10.2 modpack Unstable 4.2.4



i5-3570k @ 3.4ghz

GTX 660Ti

16gb ddr3 (2gb allocated for client)

java 8 update 101

forge-1.10- with FTB 1.10.2 modpack Unstable 4.2.4


This exact same thing happened on both PCs. Pictures are made around 60 seconds apart from eachother. You can see it stopped responding at the 4th picture this time.


Different forge versions and different modpacks make no difference.


1.10 had no issues.


I have managed to get in-game twice, but both times the load time was abysmal and my OS became slow and unusable from lack of RAM. But the game performance itself did not seem any different from 1.10.


There are no issues with a small amount of mods. We tried adding only around 20 mods, and Forge loaded mostly at the same speed as before. But it's kind of stupid to be limited to 20 mods when during a previous version there were no issues with 150.


So the issue appears only during Forge startup, while being allocated around 2gb memory. The issue seems to occur around the same time as shown on the pictures, regardless of the amount of mods. So I'm guessing Forge is trying to load some data all at once and it causes it to usually just die down from lack of memory.


You said it loaded up for you in 15 seconds, did you try running a large modpack? I'm honestly clueless as to what may be wrong other than Forge so any ideas are appreciated. Upgrading isn't a possibility and the idea of being unable to use newer Forge versions sucks too.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.