Jump to content

Minecraft Crashes on World Load


damien530

Recommended Posts

Hey, I have been making a modpack recently, and upon trying to enter a world minecraft crashes with a report that I have never seen before, if you have any idea how to fix this please help >.<

P.S. I have done some looking around, and have not come up with any useful fixes.

 

 

---- Minecraft Crash Report ----

// I'm sorry, Dave.

 

Time: 8/10/16 1:17 AM

Description: Exception in server tick loop

 

java.lang.ArrayIndexOutOfBoundsException: 23

at hardcorequesting.network.DataReader.readVersion(DataReader.java:127)

at hardcorequesting.network.FileHelper.loadData(FileHelper.java:107)

at hardcorequesting.QuestingData.load(QuestingData.java:438)

at hardcorequesting.WorldEventListener.onLoad(WorldEventListener.java:23)

at cpw.mods.fml.common.eventhandler.ASMEventHandler_890_WorldEventListener_onLoad_Load.invoke(.dynamic)

at cpw.mods.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:54)

at cpw.mods.fml.common.eventhandler.EventBus.post(EventBus.java:140)

at net.minecraft.server.integrated.IntegratedServer.func_71247_a(IntegratedServer.java:73)

at net.minecraft.server.integrated.IntegratedServer.func_71197_b(IntegratedServer.java:92)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:387)

at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)

 

 

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

 

-- System Details --

Details:

Minecraft Version: 1.7.10

Operating System: Windows 10 (amd64) version 10.0

Java Version: 1.8.0_25, Oracle Corporation

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

Memory: 527157352 bytes (502 MB) / 2882535424 bytes (2749 MB) up to 4056416256 bytes (3868 MB)

JVM Flags: 4 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx4352m -Xms256m -XX:PermSize=256m

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1614 195 mods loaded, 195 mods active

States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored

UCHIJAA mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)

UCHIJAA FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1614-1.7.10.jar)

UCHIJAA Forge{10.13.4.1614} [Minecraft Forge] (forge-1.7.10-10.13.4.1614-1.7.10.jar)

UCHIJAA appliedenergistics2-core{rv2-stable-10} [AppliedEnergistics2 Core] (minecraft.jar)

UCHIJAA CartFixes{0.1.0} [steve's Cart Fixes] (minecraft.jar)

UCHIJAA CodeChickenCore{1.0.7.47} [CodeChicken Core] (minecraft.jar)

UCHIJAA NotEnoughItems{1.0.5.118} [Not Enough Items] (NotEnoughItems-1.7.10-1.0.5.118-universal.jar)

UCHIJAA OpenComputers|Core{1.6.0.7-rc.1} [OpenComputers (Core)] (minecraft.jar)

UCHIJAA OpenEye{0.6} [OpenEye] (OpenEye-0.6-1.7.10.jar)

UCHIJAA MobiusCore{1.3.1-MAPLESS_1.7.10} [MobiusCore] (minecraft.jar)

UCHIJAA ThaumicTinkerer-preloader{0.1} [Thaumic Tinkerer Core] (minecraft.jar)

UCHIJAA OpenModsCore{0.9.1} [OpenModsCore] (minecraft.jar)

UCHIJAA <CoFH ASM>{000} [CoFH ASM] (minecraft.jar)

UCHIJAA BinniePatcher{1.8.2} [binnie Patcher] (minecraft.jar)

UCHIJAA FastCraft{1.23} [FastCraft] (fastcraft-1.23.jar)

UCHIJAA debug{1.0} [debug] (denseores-1.6.2.jar)

UCHIJAA bspkrsCore{6.15} [bspkrsCore] ([1.7.10]bspkrsCore-universal-6.15.jar)

UCHIJAA ArmorStatusHUD{1.27} [ArmorStatusHUD] ([1.7.10]ArmorStatusHUD-client-1.27.jar)

UCHIJAA StartingInventory{1.7.10.r03} [startingInventory] ([1.7.10]StartingInventory-universal-1.7.10.r03.jar)

UCHIJAA StatusEffectHUD{1.26} [statusEffectHUD] ([1.7.10]StatusEffectHUD-client-1.26.jar)

UCHIJAA appliedenergistics2{rv2-stable-10} [Applied Energistics 2] (appliedenergistics2-rv2-stable-10.jar)

UCHIJAA bdlib{1.9.4.109} [bD Lib] (bdlib-1.9.4.109-mc1.7.10.jar)

UCHIJAA ae2stuff{0.5.1.61} [AE2 Stuff] (ae2stuff-0.5.1.61-mc1.7.10.jar)

UCHIJAA AgriCraft{1.7.10-1.5.0} [AgriCraft] (AgriCraft-1.7.10-1.5.0.jar)

UCHIJAA CoFHCore{1.7.10R3.1.3} [CoFH Core] (CoFHCore-[1.7.10]3.1.3-327.jar)

UCHIJAA asielib{0.4.5} [asielib] (AsieLib-1.7.10-0.4.5.jar)

UCHIJAA Baubles{1.0.1.10} [baubles] (Baubles-1.7.10-1.0.1.10.jar)

UCHIJAA aura{unspecified} [Aura Cascade] (AuraCascade-557.jar)

UCHIJAA AWWayofTime{v1.3.3} [blood Magic: Alchemical Wizardry] (BloodMagic-1.7.10-1.3.3-17.jar)

UCHIJAA Thaumcraft{4.2.3.5} [Thaumcraft] (Thaumcraft-1.7.10-4.2.3.5.jar)

UCHIJAA Botania{r1.8-249} [botania] (Botania r1.8-249.jar)

UCHIJAA Avaritia{1.11} [Avaritia] (Avaritia-1.11.jar)

UCHIJAA Backpack{2.0.1} [backpack] (backpack-2.0.1-1.7.x.jar)

UCHIJAA Mantle{1.7.10-0.3.2.jenkins191} [Mantle] (Mantle-1.7.10-0.3.2b.jar)

UCHIJAA Natura{2.2.0} [Natura] (natura-1.7.10-2.2.1a2.jar)

UCHIJAA Forestry{4.2.15.63} [Forestry for Minecraft] (forestry_1.7.10-4.2.15.63.jar)

UCHIJAA beebetteratbees{0.2} [beeBetterAtBees] (BeeBetterAtBees-0.3.jar)

UCHIJAA HardcoreQuesting{4.4.4} [Hardcore Questing Mode] (HQM-FerretBusiness-Custom (4.4.4).jar)

UCHIJAA BeeSpecific{1.0.0} [bee Specific] (BeeSpecific-1.7.10-1.0.0.jar)

UCHIJAA betterquesting{1.0.141} [better Questing] (BetterQuesting-1.0.141.jar)

UCHIJAA BiblioCraft{1.11.5} [biblioCraft] (BiblioCraft[v1.11.5][MC1.7.10].jar)

UCHIJAA ThermalFoundation{1.7.10R1.2.5} [Thermal Foundation] (ThermalFoundation-[1.7.10]1.2.5-115.jar)

UCHIJAA ThermalExpansion{1.7.10R4.1.3} [Thermal Expansion] (ThermalExpansion-[1.7.10]4.1.3-246.jar)

UCHIJAA BigReactors{0.4.3A} [big Reactors] (BigReactors-0.4.3A.jar)

UCHIJAA BinnieCore{2.0-pre14} [binnie Core] (binnie-mods-2.0-pre14.jar)

UCHIJAA Botany{2.0-pre14} [botany] (binnie-mods-2.0-pre14.jar)

UCHIJAA ExtraBees{2.0-pre14} [Extra Bees] (binnie-mods-2.0-pre14.jar)

UCHIJAA ExtraTrees{2.0-pre14} [Extra Trees] (binnie-mods-2.0-pre14.jar)

UCHIJAA Genetics{2.0-pre14} [Genetics] (binnie-mods-2.0-pre14.jar)

UCHIJAA BrandonsCore{1.0.0.12} [brandon's Core] (BrandonsCore-1.0.0.12.jar)

UCHIJAA BuildCraft|Core{7.1.16} [buildCraft] (buildcraft-7.1.16.jar)

UCHIJAA BuildCraft|Builders{7.1.16} [bC Builders] (buildcraft-7.1.16.jar)

UCHIJAA BuildCraft|Transport{7.1.16} [bC Transport] (buildcraft-7.1.16.jar)

UCHIJAA BuildCraft|Energy{7.1.16} [bC Energy] (buildcraft-7.1.16.jar)

UCHIJAA BuildCraft|Silicon{7.1.16} [bC Silicon] (buildcraft-7.1.16.jar)

UCHIJAA BuildCraft|Robotics{7.1.16} [bC Robotics] (buildcraft-7.1.16.jar)

UCHIJAA BuildCraft|Factory{7.1.16} [bC Factory] (buildcraft-7.1.16.jar)

UCHIJAA BuildCraft|Compat{7.1.3} [buildCraft Compat] (buildcraft-compat-7.1.3.jar)

UCHIJAA TwilightForest{2.3.7} [The Twilight Forest] (twilightforest-1.7.10-2.3.7.jar)

UCHIJAA ForgeMultipart{1.2.0.345} [Forge Multipart] (ForgeMultipart-1.7.10-1.2.0.345-universal.jar)

UCHIJAA chisel{2.9.5.11} [Chisel] (Chisel-2.9.5.11.jar)

UCHIJAA CarpentersBlocks{3.3.8} [Carpenter's Blocks] (Carpenter's Blocks v3.3.8 - MC 1.7.10.jar)

UCHIJAA catwalks{2.0.4} [Catwalks Mod] (catwalks-2.0.4.jar)

UCHIJAA catwalkmod{x.x.x} [Legacy Catwalk Compat] (catwalks-2.0.4.jar)

UCHIJAA ComputerCraft{1.75} [ComputerCraft] (ComputerCraft1.75.jar)

UCHIJAA EnderStorage{1.4.7.37} [EnderStorage] (EnderStorage-1.7.10-1.4.7.37-universal.jar)

UCHIJAA MrTJPCoreMod{1.1.0.33} [MrTJPCore] (MrTJPCore-1.1.0.33-universal.jar)

UCHIJAA ProjRed|Core{4.7.0pre12.95} [ProjectRed Core] (ProjectRed-1.7.10-4.7.0pre12.95-Base.jar)

UCHIJAA ProjRed|Transmission{4.7.0pre12.95} [ProjectRed Transmission] (ProjectRed-1.7.10-4.7.0pre12.95-Integration.jar)

UCHIJAA OpenComputers{1.6.0.7-rc.1} [OpenComputers] (OpenComputers-MC1.7.10-1.6.0.7-rc.1-universal.jar)

UCHIJAA Waila{1.5.10} [Waila] (Waila-1.5.10_1.7.10.jar)

UCHIJAA CompactMachines{1.7.10-1.21} [Compact Machines] (compactmachines-1.7.10-1.21.jar)

UCHIJAA compactstorage{v2.0.0a} [CompactStorage] (compactstorage-1.7.10-release-2.1.0-lts.21-universal.jar)

UCHIJAA ComputerCraftEdu{1.74} [ComputerCraftEdu] (ComputerCraftEdu1.74.jar)

UCHIJAA endercore{1.7.10-0.2.0.36_beta} [EnderCore] (EnderCore-1.7.10-0.2.0.36_beta.jar)

 

 

Link to comment
Share on other sites

java.lang.ArrayIndexOutOfBoundsException: 23

  at hardcorequesting.network.DataReader.readVersion(DataReader.java:127)

  at hardcorequesting.network.FileHelper.loadData(FileHelper.java:107)

  at hardcorequesting.QuestingData.load(QuestingData.java:438)

  at hardcorequesting.WorldEventListener.onLoad(WorldEventListener.java:23)

 

HQM's data is corrupt. Delete its data from your save and restore it from a backup (if you have one).

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Another Minecraft Launcher https://multimc.org/#Download or https://atlauncher.com/downloads
    • Remove these mods and combine OptiFine HD U I6 with Forge 47.2.18 Start with Optifine - without any other mods - if this works, add the mods one by one or in groups until you find the mod, conflicting with Optifine
    • Ok yeah I think this might be where the problem starts. For starters, I think you can get rid of your RecipeType impl and make it a static constant instead. I'm not 100% sure this will fix it but it's posssible. RuneInscribingRecipe public class RuneInscribingRecipe implements Recipe<SimpleContainer> { public static final RecipeType<RuneInscribingRecipe> RECIPE_TYPE = new RecipeType<>(){}; // .... @Override public RecipeType<?> getType() { return RECIPE_TYPE; } // .... } RuneInscriberMenu private Optional<RecipeHolder<RuneInscribingRecipe>> getCurrentRecipe() { SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); List<RecipeHolder<RuneInscribingRecipe>> list = this.blockEntity.getLevel().getRecipeManager().getRecipesFor(RuneInscribingRecipe.RECIPE_TYPE, inventory, this.blockEntity.getLevel()); if (list.isEmpty()) { return Optional.empty(); } return Optional.of(list.get(0)); }   Also, this here is a little suspicious where you're getting the `this.inventory.getStackInSlot` calls. I'd try and make sure those are what you expect they are with either a Debug line in IDE or print statement SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); System.out.printf("CHECKING BASE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); System.out.printf("CHECKING TEMPLATE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); ^ See what the result of those print statements are, make sure they're right
    • Upon testing again after adding them, the game still doesn't crash however the resource packs are still unfortunately broken.
    • Hi! Can someone please point me to the correct FAQ or place? I'm not able do DuckDuckGo myself out of this one. As you can hopefully see, chunks are not rendered. I run a forge server, fresh install on a linux VM. Curseforge on the Win11 client with Embeddium, Oculus and Unbound shader. No mods. Forge 47.2.23 on server & client.  No errors, no crashes, no apparent CPU or RAM issues with the VM. This screenshot was captured while creative, but the same happens when flying in survival. Waiting (floating) for a few minutes sooner or (often) later, lets the missing chunks appear. Usually takes 5-10 minutes.  When on a local game, the chunks appear slowly, but they do appear without pause.   This must be something simple, obvious, but I can't find the correct "search words" to find my way out. "Chunks not loading / rendering" didn't help. Browsing several forums neither. 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.