Jump to content

[Solved] [1.10.2] Entity Spawn Egg spawns Pig Only Once Built


Recommended Posts

Not sure what to post but I would have thought that if it works in Eclipse but not after building it is another problem though.


Registering in preinit with these two lines:


EntityRegistry.registerModEntity(EntityCustom.class, "entity_Custom", Ref.entityID++, Customs.instance, 80, 1, true, 0x79553A, 0x6FAE44);
	EntityRegistry.addSpawn(EntityCustom.class, 5, 1, 2, EnumCreatureType.CREATURE, Biomes.BIRCH_FOREST, Biomes.BIRCH_FOREST_HILLS, Biomes.FOREST, Biomes.FOREST_HILLS, Biomes.ROOFED_FOREST, Biomes.PLAINS, Biomes.TAIGA, Biomes.SWAMPLAND, Biomes.SAVANNA);


It isn't a rendering issue as the mob literally acts like a pig. I know there was a bug at one point with the spawn eggs but I just updated to the latest version of Forge to make sure so I am clueless at the moment.


Not sure what code I can supply that would be of use as I can't seem to figure out the source of the issue.


Link to comment
Share on other sites

Well sometimes eclipse doesn't care about something that forge cares about when outside the dev environment. Try moving the registration code to your init method.


I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

Still no luck, I am going to try changing the entity ID and also a 1.9 version and report back.


Edit: No luck again. I tried an older version of the mod as well which works fine so I have clearly broken something somewhere. I will just try and piece together what I have done.


Is there anyway to the console in the normal game at all?

Link to comment
Share on other sites

Still absolutely no clue as to why I can use my spawn egg fine in the Eclipse/IDE environment but now when it is built and installed normally. I can't even debug it because I can't see a console when in normal Minecraft, nor does it crash or provide any logs. Any way that I can actually go about finding the problem?

Link to comment
Share on other sites

Well I am utterly confused by the solution/problem. Basically in one of my classes I was somehow importing


import scala.actors.threadpool.Arrays;


instead of


import java.util.Arrays;


Then for some reason this didn't bother Eclipse or affect how anything worked but then caused the error in normal Minecraft.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.