Jump to content

[1.10.2] Models Won't Register After Building.


Recommended Posts

I've spent countless hours the past few days solving two trivial issues, and another has come my way. When I run minecraft in Eclipse, everything is perfect. Textures, models, recipes, etc... However, if I run minecraft forge using the minecraft launcher with my built .jar file in the "mods" folder, it seems that block models, item models, blockstates, and textures aren't registering.


I'm sick of going at it alone, so hopefully someone here can help me out. Thank you ahead of time.

Link to comment
Share on other sites

  • First of all, what the f*** are all those block class files? Surely you are not serious about this...
  • Your registry names all start with an uppercase letter. This is fine, but then you cannot base your model locations on your registry names, because files must be all lowercase (will be enforced by Mojang in 1.11).
  • You should be using

    in preInit instead of the



Link to comment
Share on other sites

How do I change the registry name?
I really do not know how to answer this question. Have you not written your own code? What the heck?


sorry for being a moron, I'm just working on my first official mod after screwing around trying to figure out the coding.
Can I read this as "I do not know Java"? Because if so you are in the wrong forum.
Link to comment
Share on other sites

I do know java to a minor extent. I program robots in my engineering class, which pushed me back into trying minecraft modding again. I don't have a full understanding of how FORGE coding works, but I do know basic Java. As for the registry name change, I'm looking at my resources class.. I'm trying to understand to the fullest extent possible, but mostly everything I can find on the internet is based either towards beginner or MCCreator (which I don't think is any fun if coding is done for you), or towards people who have been modding for years.


Also, PLEASE tell me that there is a way that I can compress all of those damn block classes. I hate creating a new set of blocks, because it takes over an hour to create 10 basic blocks.

Link to comment
Share on other sites

private String unlocalizedName;

private String registryName;


ModBlocks(String unlocalizedName, String registryName)


this.unlocalizedName = unlocalizedName;

this.registryName = registryName;



I found this.. so basically the registryName is being pulled from my ModBlocks?


(within my Reference class... was never called resources... I assume this is what we were talking about, my bad)

Link to comment
Share on other sites

Okay, so after pondering for a while at school I had this idea to find my registry name by doing this simple line:




It is indeed capitalized... it reads: cb:Sand2


How do I change this? The only thing I have capitalized is the class name as far as "sand2" goes (or any of my blocks for that matter).

Link to comment
Share on other sites

HOLY CRAP I'M RETARDED. I thought the second string in all of my reference declarations was the class name, but it's the registry name! Sorry, the problem it wasn't due to not understanding it at all... It was due to falsely understanding it. Will see if it works.


edit: it does. thank you for helping me, although you could have been a hell of a lot nicer and more patient.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.