Jump to content

Trouble with Forge or Mod?


Pinku

Recommended Posts

I don't really know where to turn to at this point. The friend who wanted me to join his Pixelmon server is of no help when it comes to troubleshooting.

He had me download 1.8.9-forge1.8.9-11.15.1.1722 in order to play Pixelmon-1.8.9-4.3.0-beta9-universal.

I read that I should never use a "universal" for forge, which I'm assuming I do not have, but my Pixelmon is a "universal". Not sure if that's why I'm having issues.

Anyway, said issues being that when I load my world with forge/pixelmon, my game freezes EVERY TWO SECONDS. Not even joking. I barely move my mouse an inch and it freezes. Takes a couple seconds to unfreeze, go to move my mouse and again, freezing. To the point that my game does "Not Responding" each time as well.

Here's the log:

 

2016-10-30 09:31:02,864 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream

2016-10-30 09:31:02,872 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream

[09:31:02] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker

[09:31:03] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker

[09:31:03] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker

[09:31:03] [main/INFO] [FML]: Forge Mod Loader version 11.15.1.1722 for Minecraft 1.8.9 loading

[09:31:03] [main/INFO] [FML]: Java is Java HotSpot 64-Bit Server VM, version 1.8.0_25, running on Windows 10:amd64:10.0, installed at C:\Program Files (x86)\Minecraft\runtime\jre-x64\1.8.0_25

[09:31:04] [main/WARN] [FML]: The coremod chylex.javacheck.Java8CheckerCoremod does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[09:31:04] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker

[09:31:04] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker

[09:31:04] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker

[09:31:04] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker

[09:31:04] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper

[09:31:08] [main/INFO] [FML]: Found valid fingerprint for Minecraft. Certificate fingerprint cd99959656f753dc28d863b46769f7f8fbaefcfc

[09:31:08] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing

[09:31:08] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper

[09:31:08] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper

[09:31:08] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker

[09:31:10] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker

[09:31:10] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker

[09:31:10] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}

2016-10-30 09:31:11,033 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream

2016-10-30 09:31:11,070 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream

2016-10-30 09:31:11,075 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream

[09:31:11] [main/INFO] [sTDOUT]: [net.minecraft.client.main.Main:main:57]: Completely ignored arguments: [--nativeLauncherVersion, 307]

[09:31:11] [Client thread/INFO]: Setting user: Pinku

[09:31:19] [Client thread/INFO]: LWJGL Version: 2.9.4

[09:31:20] [Client thread/WARN] [FML]: =============================================================

[09:31:20] [Client thread/WARN] [FML]: MOD HAS DIRECT REFERENCE System.exit() THIS IS NOT ALLOWED REROUTING TO FML!

[09:31:20] [Client thread/WARN] [FML]: Offendor: com/sun/jna/Native.main([Ljava/lang/String;)V

[09:31:20] [Client thread/WARN] [FML]: Use FMLCommonHandler.exitJava instead

[09:31:20] [Client thread/WARN] [FML]: =============================================================

[09:31:21] [Client thread/INFO] [sTDOUT]: [net.minecraftforge.fml.client.SplashProgress:start:246]: ---- Minecraft Crash Report ----

 

WARNING: coremods are present:

  Java8CheckerCoremod (Pixelmon-1.8.9-4.3.0-beta9-universal.jar)

Contact their authors BEFORE contacting forge

 

// This is a token for 1 free hug. Redeem at your nearest Mojangsta: [~~HUG~~]

 

Time: 10/30/16 9:31 AM

Description: Loading screen debug info

 

This is just a prompt for computer specs to be printed. THIS IS NOT A ERROR

 

 

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

 

-- System Details --

Details:

Minecraft Version: 1.8.9

Operating System: Windows 10 (amd64) version 10.0

Java Version: 1.8.0_25, Oracle Corporation

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

Memory: 130435640 bytes (124 MB) / 265138176 bytes (252 MB) up to 1060372480 bytes (1011 MB)

JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML:

Loaded coremods (and transformers):

Java8CheckerCoremod (Pixelmon-1.8.9-4.3.0-beta9-universal.jar)

 

GL info: ' Vendor: 'Intel' Version: '4.4.0 - Build 20.19.15.4352' Renderer: 'Intel® HD Graphics'

[09:31:21] [Client thread/INFO] [FML]: MinecraftForge v11.15.1.1722 Initialized

[09:31:21] [Client thread/INFO] [FML]: Replaced 204 ore recipies

[09:31:22] [Client thread/INFO] [FML]: Found 0 mods from the command line. Injecting into mod discoverer

[09:31:22] [Client thread/INFO] [FML]: Searching C:\Users\Babzilla\AppData\Roaming\.minecraft\mods for mods

[09:31:31] [Client thread/INFO] [FML]: Forge Mod Loader has identified 4 mods to load

[09:31:32] [Client thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, pixelmon] at CLIENT

[09:31:32] [Client thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, pixelmon] at SERVER

[09:31:37] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Pixelmon

[09:31:37] [Client thread/INFO] [FML]: Processing ObjectHolder annotations

[09:31:37] [Client thread/INFO] [FML]: Found 384 ObjectHolder annotations

[09:31:37] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations

[09:31:37] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations

[09:31:37] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0

[09:31:37] [Forge Version Check/INFO] [ForgeVersionCheck]: [Forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotions_slim.json

[09:31:38] [Forge Version Check/INFO] [ForgeVersionCheck]: [Forge] Found status: UP_TO_DATE Target: null

[09:31:52] [Client thread/INFO] [Pixelmon]: Loading TM/HMs.

[09:31:52] [Client thread/INFO] [Pixelmon]: Extracting database.

[09:31:53] [Client thread/INFO] [Pixelmon]: Loading database driver.

[09:31:53] [Client thread/INFO] [Pixelmon]: Establishing connection.

[09:32:03] [Client thread/INFO] [FML]: Applying holder lookups

[09:32:03] [Client thread/INFO] [FML]: Holder lookups applied

[09:32:03] [Client thread/INFO] [FML]: Injecting itemstacks

[09:32:03] [Client thread/INFO] [FML]: Itemstack injection complete

[09:32:03] [sound Library Loader/INFO]: Starting up SoundSystem...

[09:32:04] [Thread-10/INFO]: Initializing LWJGL OpenAL

[09:32:04] [Thread-10/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)

[09:32:04] [Thread-10/INFO]: OpenAL initialized.

[09:32:04] [sound Library Loader/INFO]: Sound engine started

[09:32:18] [Client thread/INFO] [FML]: Max texture size: 8192

[09:32:18] [Client thread/INFO]: Created: 16x16 textures-atlas

[09:32:28] [Client thread/INFO] [Pixelmon]: Registering shop items.

[09:32:28] [Client thread/INFO] [Pixelmon]: Registering NPCs.

[09:32:29] [Client thread/INFO] [Pixelmon]: Registering structures.

[09:32:31] [Client thread/INFO] [Pixelmon]: Registering drops.

[09:32:31] [Client thread/INFO] [Pixelmon]: Registering entity spawns.

[09:32:39] [Client thread/INFO] [FML]: Injecting itemstacks

[09:32:39] [Client thread/INFO] [FML]: Itemstack injection complete

[09:32:41] [Client thread/INFO] [FML]: Forge Mod Loader has successfully loaded 4 mods

[09:32:41] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Pixelmon

[09:32:41] [Client thread/INFO]: SoundSystem shutting down...

[09:32:41] [Client thread/WARN]: Author: Paul Lamb, www.paulscode.com

[09:32:41] [sound Library Loader/INFO]: Starting up SoundSystem...

[09:32:42] [Thread-12/INFO]: Initializing LWJGL OpenAL

[09:32:42] [Thread-12/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)

[09:32:42] [Thread-12/INFO]: OpenAL initialized.

[09:32:42] [sound Library Loader/INFO]: Sound engine started

[09:32:46] [Client thread/INFO] [FML]: Max texture size: 8192

[09:32:51] [Client thread/INFO]: Created: 2048x1024 textures-atlas

[09:33:13] [server thread/INFO]: Starting integrated minecraft server version 1.8.9

[09:33:13] [server thread/INFO]: Generating keypair

[09:33:13] [server thread/INFO] [FML]: Injecting existing block and item data into this server instance

[09:33:13] [server thread/INFO] [FML]: Applying holder lookups

[09:33:13] [server thread/INFO] [FML]: Holder lookups applied

[09:33:14] [server thread/INFO] [FML]: Loading dimension 0 (Pixelmon) (net.minecraft.server.integrated.IntegratedServer@7d6962fb)

[09:33:14] [server thread/INFO] [FML]: Loading dimension 1 (Pixelmon) (net.minecraft.server.integrated.IntegratedServer@7d6962fb)

[09:33:14] [server thread/INFO] [FML]: Loading dimension -1 (Pixelmon) (net.minecraft.server.integrated.IntegratedServer@7d6962fb)

[09:33:14] [server thread/INFO]: Preparing start region for level 0

[09:33:15] [server thread/INFO]: Preparing spawn area: 20%

[09:33:22] [server thread/INFO]: Preparing spawn area: 25%

[09:33:23] [server thread/INFO]: Preparing spawn area: 63%

[09:33:24] [server thread/INFO]: Preparing spawn area: 97%

[09:33:26] [server thread/INFO]: Changing view distance to 8, from 10

[09:33:27] [Netty Local Client IO #0/INFO] [FML]: Server protocol version 2

[09:33:27] [Netty Server IO #1/INFO] [FML]: Client protocol version 2

[09:33:27] [Netty Server IO #1/INFO] [FML]: Client attempting to join with 4 mods : [email protected],[email protected],[email protected],[email protected]

[09:33:27] [server thread/INFO] [FML]: [server thread] Server side modded connection established

[09:33:27] [Netty Local Client IO #0/INFO] [FML]: [Netty Local Client IO #0] Client side modded connection established

[09:33:27] [server thread/INFO]: Pinku[local:E:3ac70174] logged in with entity id 21 at (-14.014399996259485, 67.0, -31.046670297268626)

[09:33:27] [server thread/INFO]: Pinku joined the game

[09:33:33] [server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 5852ms behind, skipping 117 tick(s)

[09:34:03] [server thread/INFO]: Saving and pausing game...

[09:34:04] [server thread/INFO]: Saving chunks for level 'Pixelmon'/Overworld

[09:34:04] [server thread/INFO]: Saving chunks for level 'Pixelmon'/Nether

[09:34:04] [server thread/INFO]: Saving chunks for level 'Pixelmon'/The End

[09:34:13] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Pixelmon

[09:34:14] [Client thread/INFO]: SoundSystem shutting down...

[09:34:14] [Client thread/WARN]: Author: Paul Lamb, www.paulscode.com

[09:34:14] [sound Library Loader/INFO]: Starting up SoundSystem...

[09:34:14] [Thread-15/INFO]: Initializing LWJGL OpenAL

[09:34:14] [Thread-15/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)

[09:34:14] [Thread-15/INFO]: OpenAL initialized.

[09:34:15] [sound Library Loader/INFO]: Sound engine started

[09:34:18] [Client thread/INFO] [FML]: Max texture size: 8192

[09:34:23] [Client thread/INFO]: Created: 2048x1024 textures-atlas

[09:34:31] [server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 7673ms behind, skipping 153 tick(s)

 

 

Link to comment
Share on other sites

I read that I should never use a "universal" for forge

Where the f*ck did you read that? You should just use the windows installer for your version. And the server should update to 1.10.2, Pixelmon is already out for 1.10.2.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

I apologize for that, I have seen a lot of people confused by the client-server architecture Minecraft is using, and I was suspecting you were another one of those who thinks he/she has to use a client-only version of Forge.

 

Before Minecraft 1.3, client and server were separated, and modders would have to make 2 versions of the mod: client and server. Now, there's an integrated server involved allowing modders to make 1 universal mod jar for client and server. So in the case of mods, you should be using the universal jar, unless it's a client/server-only mod. In the case of Forge, use the installer.

 

As for your problem, I have no idea what is causing that. 1GB of RAM should be enough for 1 mod installed. Try removing Pixelmon from your mods list, and try to make a world without. If it stops freezing, it is a problem with Pixelmon and you should report it to their author.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

You're kidding me. Pixelmon is the only mod I have and I am on a brand new laptop. It's barely even 2 months old, and now I need to add RAM just to play Pixelmon?

That's a slap in the face. I mean, it's not your fault at all, and I'm not mad at you for telling me this. It's just like, a huge WTF in my mind xD

The Technic Launcher told me I need 2GB of RAM too so my friend was like "try it this way". Pff.

 

Thanks for the help guys, I will figure out how to do it from here ^^

 

Link to comment
Share on other sites

1GB is not enough for Pixelmon.

And this what he describes is cpu/gc lag. So more ram might help.

The game works perfectly when playing without the forge profile. It is Pixelmon itself.. I'm being told I need 2GB of RAM, and I find it hard to believe that my NEW laptop can't handle it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I have a problem, I am trying to put two different effects to two different armors but when I run it only the emerald armor effect works. This is the code public class ModArmorItem extends ArmorItem{ private static final Map<ArmorMaterial, MobEffectInstance> MATERIAL_TO_EFFECT_MAP = (new ImmutableMap.Builder<ArmorMaterial, MobEffectInstance>()) .put(ModArmorMaterials.EMERALD, new MobEffectInstance(MobEffects.HERO_OF_THE_VILLAGE,200, 1,false,false, true)) .put(ModArmorMaterials.OBSIDIAN, new MobEffectInstance(MobEffects.FIRE_RESISTANCE,200, 1,false,false, true)).build(); public ModArmorItem(ArmorMaterial pMaterial, Type pType, Properties pProperties) { super(pMaterial, pType, pProperties); } @Override public void onArmorTick(ItemStack stack, Level world, Player player){ if (!world.isClientSide()) { if (hasFullSuitOfArmorOn(player)) { evaluateArmorEffects(player); } } } private void evaluateArmorEffects(Player player) { for (Map.Entry<ArmorMaterial,MobEffectInstance> entry : MATERIAL_TO_EFFECT_MAP.entrySet()){ ArmorMaterial mapArmorMaterial = entry.getKey(); MobEffectInstance mapStatusEffect = entry.getValue(); if (hasCorrectArmorOn(mapArmorMaterial, player)) { addStatusEffectForMaterial(player, mapArmorMaterial, mapStatusEffect); } } } private void addStatusEffectForMaterial(Player player, ArmorMaterial mapArmorMaterial, MobEffectInstance mapStatusEffect) { boolean hasPlayerEffect = player.hasEffect(mapStatusEffect.getEffect()); if (hasCorrectArmorOn(mapArmorMaterial, player) && !hasPlayerEffect) { player.addEffect(new MobEffectInstance(mapStatusEffect)); } } private boolean hasCorrectArmorOn(ArmorMaterial material, Player player) { for (ItemStack armorStack : player.getInventory().armor){ if (!(armorStack.getItem() instanceof ArmorItem)) { return false; } } ArmorItem helmet = ((ArmorItem)player.getInventory().getArmor(3).getItem()); ArmorItem breastplace = ((ArmorItem)player.getInventory().getArmor(2).getItem()); ArmorItem leggins = ((ArmorItem)player.getInventory().getArmor(1).getItem()); ArmorItem boots = ((ArmorItem)player.getInventory().getArmor(0).getItem()); return helmet.getMaterial() == material && breastplace.getMaterial() == material && leggins.getMaterial() == material && boots.getMaterial() == material; } private boolean hasFullSuitOfArmorOn(Player player){ ItemStack helmet = player.getInventory().getArmor(3); ItemStack breastplace = player.getInventory().getArmor(2); ItemStack leggins = player.getInventory().getArmor(1); ItemStack boots = player.getInventory().getArmor(0); return !helmet.isEmpty() && !breastplace.isEmpty() && !leggins.isEmpty() && !boots.isEmpty(); } } Also when I place two effects on the same armor, the game crashes. Here is the crash file. The code is the same, only this part is different   private static final Map<ArmorMaterial, MobEffectInstance> MATERIAL_TO_EFFECT_MAP = (new ImmutableMap.Builder<ArmorMaterial, MobEffectInstance>()) .put(ModArmorMaterials.EMERALD, new MobEffectInstance(MobEffects.HERO_OF_THE_VILLAGE,200, 1,false,false, true)) .put(ModArmorMaterials.EMERALD, new MobEffectInstance(MobEffects.FIRE_RESISTANCE,200, 1,false,false, true)).build(); I hope you guys can help me. Thanks.
    • I removed all related embeddium and oculus mods, i just tested it by disconnecting and the error happened again. heres the report https://pastebin.com/1kcR5wAt   EDIT: i tried removing xaeros and also smoothboot thinking there may be an issue there, nothing, heres that report too. https://pastebin.com/zQS7i9rM
    • Hi, I need suggestions. I am a beginner in Minecraft Modding. I would like to apply custom effects to some armors, something like: more chance to drop seeds, change zombie awareness, drop more pieces of wood when chopping logs, and things like that. How would you recommend me to do it, is there any library that has something similar and which ones would you recommend me?.
    • "downloading minecraft server failed, invalid Checksum. try again, or manually place server.jar to skip download"    
    • You have to create an Entity class called PlayerPart and use multiple of them to make the different parts of the player. See EnderDragonPart.java source code. The green hitboxes of the dragon are all EnderDragonParts
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.