Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Minecraft Server prompt does not show after Forge is fused


Sonic7167
 Share

Recommended Posts

So I downloaded multiple versions of forge, and most were I believed to be the most recent versions, and when I placed my forgedownload's content to my minecraft_Server.jar via 7 zip I get: "coremods" "ForgeModLoader-server0.log" "ForgeModLoader-server-0.log.lck" and "lib" which only contains either "argo-2.25.jar" and "asm-all-4.0.jar".  I get No Server cmd prompt, and the java process just stays on, with nothing happening.

 

I'm not sure if I need to update something or what the problem is, i'd like some

 

Edit :

 

Forge works for my client but not my server.

 

I noticed the "mods" folder is missing under server and isn't being created.

 

Is it possibly my Java? Does forge have prerequisites?

 

2012-12-28 05:44:21 [iNFO] [ForgeModLoader] Forge Mod Loader version 4.6.17.515 for Minecraft 1.4.6 loading
2012-12-28 05:44:21 [iNFO] [ForgeModLoader] Downloading file http://files.minecraftforge.net/fmllibs/argo-2.25.jar
2012-12-28 05:44:22 [iNFO] [ForgeModLoader] Download complete
2012-12-28 05:44:22 [iNFO] [ForgeModLoader] Downloading file http://files.minecraftforge.net/fmllibs/guava-12.0.1.jar
2012-12-28 05:44:27 [iNFO] [ForgeModLoader] Download complete
2012-12-28 05:44:27 [iNFO] [ForgeModLoader] Downloading file http://files.minecraftforge.net/fmllibs/asm-all-4.0.jar
2012-12-28 05:44:28 [iNFO] [ForgeModLoader] Download complete
2012-12-28 05:44:28 [iNFO] [ForgeModLoader] Downloading file http://files.minecraftforge.net/fmllibs/bcprov-jdk15on-147.jar
2012-12-28 05:44:34 [iNFO] [ForgeModLoader] Download complete
2012-12-28 05:44:34 [iNFO] [sTDERR] Exception in thread "main" java.lang.RuntimeException: java.lang.NoClassDefFoundError: com/google/common/io/LineProcessor
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.FMLRelauncher.setupHome(FMLRelauncher.java:175)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.FMLRelauncher.relaunchServer(FMLRelauncher.java:133)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.FMLRelauncher.handleServerRelaunch(FMLRelauncher.java:33)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:1375)
2012-12-28 05:44:34 [iNFO] [sTDERR] Caused by: java.lang.NoClassDefFoundError: com/google/common/io/LineProcessor
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.lang.Class.getDeclaredConstructors0(Native Method)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.lang.Class.getConstructor0(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.lang.Class.newInstance0(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.lang.Class.newInstance(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.RelaunchClassLoader.registerTransformer(RelaunchClassLoader.java:75)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.RelaunchLibraryManager.handleLaunch(RelaunchLibraryManager.java:238)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.FMLRelauncher.setupHome(FMLRelauncher.java:155)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	... 3 more
2012-12-28 05:44:34 [iNFO] [sTDERR] Caused by: java.lang.ClassNotFoundException: com.google.common.io.LineProcessor
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.net.URLClassLoader$1.run(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.net.URLClassLoader$1.run(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.security.AccessController.doPrivileged(Native Method)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.net.URLClassLoader.findClass(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:108)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.lang.ClassLoader.loadClass(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	at java.lang.ClassLoader.loadClass(Unknown Source)
2012-12-28 05:44:34 [iNFO] [sTDERR] 	... 11 more

Link to comment
Share on other sites

You don't merge the contents of the forge zip with the server jar anymore.

You RUN THE FORGE ZIP AS A JAR.

Read the EAQ before posting! OR ELSE!

 

This isn't building better software, its trying to grab a place in the commit list of a highly visible github project.

 

www.forgeessentials.com

 

Don't PM me, I don't check this account unless I have to.

Link to comment
Share on other sites

Copy the files in .minecraft/lib to the server's lib folder.

Protip: try and find answers yourself before asking on the forum.

It's pretty likely that there is an answer.

 

Was I helpful? Give me a thank you!

 

 

width=635 height=903http://bit.ly/HZ03zy[/img]

 

 

Tired of waiting for mods to port to bukkit?

use BukkitForge! (now with a working version of WorldEdit!)

Link to comment
Share on other sites

Okay now the server prompt loaded, I'm assuming that happened because I put in the new lib "guava-12.0.1.jar" along with "argo-2.25.jar" and "asm-all-4.0.jar".

 

Now I have acquired a crash report, after it loaded up.

 

---- Minecraft Crash Report ----
// This is a token for 1 free hug. Redeem at your nearest Mojangsta: [~~HUG~~]

Time: 12/28/12 3:07 PM
Description: Exception in server tick loop

java.lang.NoClassDefFoundError: org/bouncycastle/jce/provider/BouncyCastleProvider
at ho.c(DedicatedServer.java:112)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:458)
at fy.run(SourceFile:849)
Caused by: java.lang.ClassNotFoundException: org.bouncycastle.jce.provider.BouncyCastleProvider
at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:179)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 3 more
Caused by: java.lang.NullPointerException
at org.objectweb.asm.ClassReader.<init>(Unknown Source)
at net.minecraftforge.transformers.EventTransformer.transform(EventTransformer.java:29)
at cpw.mods.fml.relauncher.RelaunchClassLoader.runTransformers(RelaunchClassLoader.java:222)
at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:171)
... 5 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
Minecraft Version: 1.4.6
Operating System: Windows 7 (x86) version 6.1
Java Version: 1.7.0_10, Oracle Corporation
Java VM Version: Java HotSpot(TM) Client VM (mixed mode, sharing), Oracle Corporation
Memory: 14790216 bytes (14 MB) / 31125504 bytes (29 MB) up to 259522560 bytes (247 MB)
JVM Flags: 0 total; 
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Suspicious classes: FML and Forge are installed
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP v7.25 FML v4.6.17.515 Minecraft Forge 6.5.0.489 3 mods loaded, 3 mods active
mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized
FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized
Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized
Profiler Position: N/A (disabled)
Is Modded: Definitely; Server brand changed to 'fml'
Type: Dedicated Server (map_server.txt)

 

 

WAIT DON'T say anything yet,

My server and client arn't on the same computer so I am transfering files

Link to comment
Share on other sites

Sweet! the server is running! But no one can join.

 

Could it possibly be that forge for client and server needs to be the exact same?

 

The port is open my server is good.  But when I try to join it says I join then I disconnect twice.

 

 

[iNFO] Starting minecraft server version 1.4.6
[WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
[iNFO] Loading properties
[iNFO] Default game type: SURVIVAL
[iNFO] Generating keypair
[iNFO] Starting Minecraft server on *:25565
[iNFO] Preparing level "world"
[iNFO] Preparing start region for level 0
[iNFO] Preparing spawn area: 58%
[iNFO] Done (2.400s)! For help, type "help" or "?"
[iNFO] User Sonic7167 connecting with mods []
[iNFO] Sonic7167[/**************] logged in with entity id 1495 at (-234.5, 65.62000000476837, 211.5)
[iNFO] Sonic7167 lost connection: disconnect.endOfStream
[iNFO] Sonic7167 lost connection: disconnect.endOfStream
[iNFO] User Sonic7167 connecting with mods []
[iNFO] Sonic7167[/**************] logged in with entity id 1496 at (-234.5, 65.62000000476837, 211.5)
[iNFO] Sonic7167 lost connection: disconnect.endOfStream
[iNFO] Sonic7167 lost connection: disconnect.endOfStream

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.