Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Better Ores Update Discussion


DE3000
 Share

Recommended Posts

So I have been away from modding for a while and recently gotten back (I'm not asking for tutorials :P).

 

I have started to update my Better Ores Mod and was hoping I could get a few opinions on what was my original plans back in the days of beta.

 

Back in beta and even through till now many mods add new ores/gem ores or some other type of mineable resource. The original plan was to have mods register that they require a new metal/gem with the API and the API would generate everything you might need i.e ore block, ingot, ingot storage block.

 

The API would also and some customisation options, like dynamically changing the colour of the ore \ ingot in-game. I thought this would be nice for texture pack creators as they would generate the base image and give a colour of the different ores in the config file instead of creating ten different ore block textures with just slight colour variations.

 

Around that time the Forge Ore dictionary was in development and I suggested adding the features I was thinking about it was rejected as forge was just for compatibility and not adding content.

 

With the mods now I have seen that dusts of ores/gems are being used al ot as well as nuggets of the different metals.

 

I plan on adding some new auto generated content to the API as a result for this.

 

Ideally this is the way it would work.

@PreInit ....
{
   ....
   ....
   BetterOre copper = BetterOreAPI->register(BOType.Metal,"copper");
   BetterOre ruby = BetterOreAPI->register(BOType.Gem,"ruby");
   ....
}

 

This code would register copper ore blocks, copper ingots, copper nuggets, copper dust. Ore generation parameters will be defined to default parameters and can be changed by calling some mutation functions in the BetterOre class.

Similarly ruby ore, ruby gems, ruby chips (I am going to add this as the nugget equivalent  for gems :P) and ruby dust.

 

For alloy metals which would not have ore blocks, generation can be turned off. If there are conflicts between mods turning ore generation of the "same" metal/gem off and on then we need a way to handle this, I have not come to a conclusion about this yet.

 

For both of theres new types and entry under the mod configuration GUI (I use GuiAPI) there will be options for colour of the types an maybe some other configuration.

 

This whole wall of text might seem haphazard and probably is but I have been debating on what to do with my API (even if nobody uses it :P). I would love to hear some sort of feedback.

 

Please check the link to the BetterOres mod to see some screens of what I am talking about. I'll link new screens once I have them.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • when i tried joining a world my mc crashed exit code -805306369
    • Hello There! In the 73rd episode of Bed Wars we get into a lobby with a guy who had a cool name and for some reason Ben is very impressed with the name and thus the title!  
    • I have been trying to install forge, but I can't even get the installer to run. I'm really not sure what the issue is, first let me make sure I am even using the installer right, I downloaded the forge installer matching my minecraft version (1.19.2), if I double click the .jar from the download then I see a flash of a black window that immediately disappears. If I use a command prompt, I receive the following output: C:\Users\austi> java -jar forge-1.19.2-43.0.19-installer.jar Error: Unable to access jarfile forge-1.19.2-43.0.19-installer.jar   I feel like this is more likely a java issue than a forge issue but I was hoping that people here might be able to help. I've tried a couple versions of java, at first I was using 8 I believe because all of the install guides for forge were a bit older so they linked to the java website rather than oracle. I tried version 18 from the oracle site and received the same result from command prompt. It is also entirely possible that I am doing something else wrong that is blatantly obvious to everyone else.
    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.