Jump to content

[1.10.2] [SOLVED] Different ways to cancel fall damage?


Differentiation

Recommended Posts

Hey,

So currently, to cancel only the single player's fall damage I'm using EntityPlayer::fallDistance = 0; to cancel player fall damage...

However, whenever the player hits the ground, that "poof" sound is played (the sound meant to imitate the breaking of bones.)

I was wondering, is there a way to cancel player fall damage without that sound?

 

Please list the ways below if you have any.

Thanks! :)

Edited by Differentiation
Link to comment
Share on other sites

LivingFallEvent

  • Like 1

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

....if you cancel the event....

  • Like 1

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

The event fires for all players, yes. Use some if-then magic to figure out which player needs to have it cancelled.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

51 minutes ago, Draco18s said:

The event fires for all players, yes. Use some if-then magic to figure out which player needs to have it cancelled.

It doesn't really work out :/

If you do, lets say, this:

If the player is wearing Leafy Boots, the events seems to cancel for every player.

	@SubscribeEvent
    public void cancelPlayerFallDamage(LivingFallEvent event)
    {
		if (event.getEntity() instanceof Entityplayer
		{
        	EntityPlayer player = (EntityPlayer) event.getEntity();
 
        	if (player.getItemStackFromSlot(EntityEquipmentSlot.FEET).getItem() == DinocraftItems.LeafyBoots)
        	{
            	event.setCanceled(true); //Sets canceled for ALL players if only one player is wearing the item. See my point?
        	}
	    }
    }

 

Edited by Differentiation
Link to comment
Share on other sites

You have "Entityplayer" there, it should be "EntityPlayer"

You're also missing a ) at the end of that same line.

I put this code into a mod of my own, changed the reference to use vanilla's Leather Boots instead, booted up a server and two clients, equipped one with leather boots, left the other without. Used a command to teleport both players 100 blocks into the air.

2017-10-10_22.44.04.png

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

9 minutes ago, Draco18s said:

You have "Entityplayer" there, it should be "EntityPlayer"

You're also missing a ) at the end of that same line.

I put this code into a mod of my own, changed the reference to use vanilla's Leather Boots instead, booted up a server and two clients, equipped one with leather boots, left the other without. Used a command to teleport both players 100 blocks into the air.

2017-10-10_22.44.04.png

The typos are because I quickly wrote that code on the top of my head.

 

I'm going to try to test it myself and see if it works or not, I mean maybe it's because I tested on an actual server with two different accounts or something, I will have to see when I can get back to my code tomorrow.

 

Thanks for all the help though! :)

Link to comment
Share on other sites

48 minutes ago, diesieben07 said:

How was I "threatening"? I just told you that what you stated so matter-of-fact-ly is not correct.

Sorry, wrong word... I just tested it and it turns out you are correct, it only cancels for one player as long as they meet the "if" expectations.

Thanks for all the help guys! :)

Edited by Differentiation
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • !warudo.isClientSide() still not a gui not an error just a simple message [06:44:39] [Render thread/WARN] [minecraft/MenuScreens]: Failed to create screen for menu type: mercmod:gem_polishing_menu Not a hint of what the problem is  this silent simple error dont tell much about the problem the code i made don't show errors highlighted   in mi old code 1.19.4 i launch the menu part from client side  but now i recheck the video and kapenjoe does it server side         
    • Hey, for getting your model to show up in Forge, double-check the way you've set up your model registration. Sometimes, it's just a tiny mix-up with where you've put your model file or maybe missing the right event to hook it up. Also, peek at your @Mod.EventBusSubscriber setup; it's gotta be listening in the right place. And don't forget to place your model file in the exact right spot with the correct naming. If in doubt, the Forge docs or forum threads can be super helpful.
    • Since flying mobs like bees and flies aren't affected, the problem likely lies with how ground mob AI interacts with the server environment. Checking the server logs, as you've done, is a good step. You might want to look for errors related to mob AI or pathfinding. Consider removing or updating mods one at a time to isolate the issue. Additionally, ensure your server's performance isn't being overly taxed by the modpack, as this can sometimes lead to unusual behavior with entity AI.
    • I'm having the same issue rn. Hostile mobs wont move until attacked but peaceful land mobs wont move at all. If it swims or flies its unaffected until it touches blocks.
    • Im trying to register model for my item but it doesn't works. First I Created a class where i declared all my items.   public class ModItems { public static final List<Item> ITEMS = new ArrayList<Item>(); public static final Item MY_ITEM = new MyItemClass(); } Then I created the MyItemClass where i describe my item. public class MyItemClass extends Item { public MyItemClass() { this.setRegistryName("my_item"); this.setUnlocalizedName("my_item"); this.setCreativeTab(CreativeTabs.COMBAT); ModItems.ITEMS.add(this); } } And The i created a class where i was trying register the model and where i registered my item @Mod.EventBusSubscriber public class EventsHandler { @SubscribeEvent public void registerItems(RegistryEvent.Register<Item> event) { event.getRegistry().register(new MyItemClass()); } @SubscribeEvent @SideOnly(Side.CLIENT) public static void onRegistryModel(ModelRegistryEvent event) { registryModel(new MyItemClass()); } @SideOnly(Side.CLIENT) private static void registryModel(Item item) { final ResourceLocation regName = item.getRegistryName(); final ModelResourceLocation mr1 = new ModelResourceLocation(regName, "inventory"); ModelBakery.registerItemVariants(item, mr1); ModelLoader.setCustomModelResourceLocation(item, 0, mr1); } } The registerItems method just registers my items. Then im catching ModelRegistryEvent to register my model. And in the last private method im registering models. In The game iitem still has purple-black cube instead of texture. I dont forgot to create the models\item folder and my_item.json file im sorry if this text has a grammatical errors. My english is very low  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.