Jump to content

Server refuses to start (1.12.2 - 14.23.3.2656+)


Recommended Posts

It appears to run but then nothing, checking with Task Manager shows the Java binary starting and exiting almost instantly, so am reporting it as a bug.

 

Server version 1.12.2 - 14.23.3.2655 or lower starts fine with the exact same startup batch file:

Spoiler

@echo off
setlocal enableDelayedExpansion
set max=0
for /f "tokens=1* delims=-.0" %%A in ('dir /b /a-d forge-*-universal.jar') do if %%B gtr !max! set max=%%B
rem echo higest version: forge-%max%
set JAVA_HOME=C:\Program Files\Java\jre1.8.0_152
set PATH=C:\Program Files\Java\jre1.8.0_152\bin;%PATH%
start /abovenormal javaw -jar forge-%max% /NOCONSOLE

It checks for the highest installed version of Forge's server .jar then runs it with Java 1.8.0_152

(It has worked since I've used a Forge server, I started with MC 1.8, and have both Java 8 and 9 64 bit installed)

 

Logs and Debug Logs:

https://pastebin.com/wyCrKRNE - latest.log - 2668

https://pastebin.com/6uFTkEqJ - debug.log - 2668

 

Working Server Logs and Debug Logs: (For comparison purposes)

https://pastebin.com/uiRCD09f -;latest.log - 2655

https://pastebin.com/8VG9L06X - debug.log - 2655

 

The interesting part (for me) is that from 2656 the logs say it has a problem with Maven and also canonicalizing the libraries path, (2668 excerpt in spoiler)

(It looks like it may be a / vs \ directory issue between the Java..jar and Windows to me)

Spoiler

[00:04:08] [main/ERROR] [FML]: Apache Maven library folder was not in the format expected: C:\Users\Coolio\AppData\Roaming\.minecraft\server\libraries\org\apache\maven\maven-artifact\3.5.3\maven-artifact-3.5.3.jar. Using default libraries directory.
[00:04:08] [main/INFO] [FML]: Unable to canonicalize path C:/Users/Coolio/AppData/Roaming/.minecraft/server/libraries relative to C:\Users\Coolio\AppData\Roaming\.minecraft\server\.
java.io.IOException: The filename, directory name, or volume label syntax is incorrect

I hope this will help resolve this issue and help me get the latest server version running soon™

 

Oh and just to confirm the Java game client version is working fine (Including versions 2655 through 2668)

Link to comment
Share on other sites

Only mod_list.json I have in C:\Users\Coolio\AppData\Roaming\.minecraft\server\mods is: 

{
    "repositoryRoot": "C:/Users/Coolio/AppData/Roaming/.minecraft/server/libraries",
    "modRef": [
        "net.minecraftforge:MercuriusUpdater:1.12.2"
    ]
}

I don't have a /mods/1.12/2/ that I can find...

The server has been working since MC 1.8 and having the forge installer install both client, then server files...

As for this issue it's fine up until i try upgrading to the 2656 or higher universal .jar (I Have now tried both the installer and the standalone downloads) then the server refuses to start, every other version from forge going right back to the 1.8 versions has worked fine.

 

It has me baffled atm.

Link to comment
Share on other sites


    "repositoryRoot": "C:/Users/Coolio/AppData/Roaming/.minecraft/server/libraries",

 

Thats your issue that's not a valid repository root. They have always been relative to the MC directory unless you specify "absolute:" before it

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

That was the default mod_list.json that came with forge, it was setup by your own installer based on the directory chosen to install the server

 

Yes single player uses the Program Files/minecraft server directory ( C:\Program Files (x86)\Minecraft\server )

 

But if you are specifying a server location for the installer shouldn't it make that change correctly itself?

As stated the versions up to 2655 work, even if the fault existed then, they work by using the install directories /libraries

 

The later versions FAIL with a near useless verbose output, I come here for help and get told the automatically generated mod_list.json needs editing

with a change I have no clue how to implement just because I was playing 1.8 locally and had a 1.8 separate server for myself and friends to use which

happened to be in a different directory to avoid destroying each world. with the other.

 

Sorry but I have Aspergers and this issue is somewhat distressing.

 

IMHO as 2655 works and the later versions fail, yes there may be a config error but it looks like the failsafe they had has been changed to a failhard

and the server installer part of the Windows Installer package should make this location correction automatically, thereby reducing the likely hood of

this issue occurring.

 

I will manually attempt to correct the/your mod_list.json file and see if that fixes the issue.

-----

Just made a json edit:

{
    "absolute:" "repositoryRoot": "C:/Users/Coolio/AppData/Roaming/.minecraft/server/libraries",
    "modRef": [
        "net.minecraftforge:MercuriusUpdater:1.12.2"
    ]
}

2655 starts up...

And

2668 starts up... (Yay, but still shows an error.)

 

Even http://www.minecraftforge.net/forum/topic/42881-solved-how-to-specify-absolute-path-in-mod_listjson/  isn't helping.

 

Renaming the mod_list.json stops it triggering most of the errors, the server still shows a maven issue but it starts.

Spoiler

[03:06:39] [main/ERROR] [FML]: Apache Maven library folder was not in the format expected: C:\Users\Coolio\AppData\Roaming\.minecraft\server\libraries\org\apache\maven\maven-artifact\3.5.3\maven-artifact-3.5.3.jar. Using default libraries directory.

How do I force it to re-install the Apache Maven library folder correctly, I'm so confused...

Edited by Coolio_Wolfus
Additional
Link to comment
Share on other sites

Interesting you are correct that the installer is creating an incorrect json, I wonder when that happened and why it hasn't broken things before now.

However, you can just delete the modlist and you'll be fine.

I can add hardening for things like this. But doesn't really matter as the modern versions no longer include Mercurius.

 

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Could I suggest that the server installer option as well as installing the universal.jar also removes (if it exists) the server locations /mods/mod_list.json
This would prevent this issue for most windows player, but you have helped me fix the server refusing to start anyway so case solved :D

 

I'll leave the pastebin logs up so you can compare them and compare Forge universal 2655 with 2656 as that change is the one that borked my server

And please remember the current  Recommended Version (as of this post) is currently 2655, once that changes you may start seeing more reports of

this now (mostly) solved* issue.

 

* The only other issue is the Apache Maven one, but I'm not sure how that can be fixed...

Link to comment
Share on other sites

The current recommended version is before the library re-write so that doesn't matter.

And no the installer will not go around deleting your modlists. That would just be stupid.

I've added hardening for broken modlists. That solves this issue, beyond that, you can just delete your json and you'll be fine.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Understood, sorry (I blame my Aspergers)

 

Anyway do feel free to include the batch file with a desktop shortcut for those wanting it, it will as mentioned automatically search through the directory for the forge universal jar's and then run the highest numbered one found aka the latest installed, making installing a forge server update better than a client one, MC still insists the player updates their forge client version in the launch properties, prior to running the new version.

 

(I'm sure you can adapt the batch file to use the highest available 1.8 java version a user has installed too)

startserver.bat

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • The version of what? I just imported the MDK into Eclipse. I haven't made any edits to the Java code in it or even any other files. I haven't even gotten to changing the modid from "examplemod" yet.
    • Captain WebGenesis is a Cyber skilled hacker with special abilities and skills that enact penetration to help victims of Crypto Fraudulent activities who are faced with cyber challenges get back their lost funds. Simply file your complaint through the website (https://captainwebgenesis. com) and have all your crypto recovered back.
    • The crash log keeps saying something about the tick rate. Can someone please help me fix?   ---- Minecraft Crash Report ---- // Everything's going to plan. No, really, that was supposed to happen. Time: 2024-06-21 16:24:55 Description: Exception in server tick loop java.lang.NullPointerException: Cannot invoke "com.cobblemon.mod.common.api.conditional.RegistryLikeCondition.fits(Object, net.minecraft.core.Registry)" because "condition" is null at com.cobblemon.mod.common.api.spawning.condition.SpawningCondition.fits(SpawningCondition.java:85) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.condition.AreaTypeSpawningCondition.fits(AreaTypeSpawningCondition.java:30) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.condition.GroundedTypeSpawningCondition.fits(GroundedTypeSpawningCondition.java:28) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.condition.GroundedTypeSpawningCondition.fits(GroundedTypeSpawningCondition.java:24) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.condition.SpawningCondition.isSatisfiedBy(SpawningCondition.java:68) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.detail.SpawnDetail.isSatisfiedBy(SpawnDetail.java:78) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.spawner.Spawner$DefaultImpls.getMatchingSpawns(Spawner.java:42) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.spawner.TickingSpawner.getMatchingSpawns(TickingSpawner.java:31) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.selection.FlatContextWeightedSelector.getSelectionData(FlatContextWeightedSelector.java:79) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.selection.FlatContextWeightedSelector.select(FlatContextWeightedSelector.java:106) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.spawner.AreaSpawner.run(AreaSpawner.java:94) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.spawner.TickingSpawner.tick(TickingSpawner.java:71) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.spawning.SpawnerManager.onServerTick(SpawnerManager.java:58) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.events.ServerTickHandler.onTick(ServerTickHandler.java:20) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.Cobblemon$initialize$7.invoke(Cobblemon.java:368) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.Cobblemon$initialize$7.invoke(Cobblemon.java:368) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.reactive.ObservableSubscription.handle(ObservableSubscription.java:16) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.common.api.reactive.SimpleObservable.emit(SimpleObservable.java:39) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.forge.event.ForgePlatformEventHandler.onTick(ForgePlatformEventHandler.kt:172) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading} at com.cobblemon.mod.forge.event.__ForgePlatformEventHandler_onTick_ServerTickEvent.invoke(.dynamic) ~[Cobblemon-forge-1.5.2+1.20.1.jar%23121!/:?] {re:classloading,pl:eventbus:B} at net.minecraftforge.eventbus.ASMEventHandler.invoke(ASMEventHandler.java:73) ~[eventbus-6.0.5.jar%2352!/:?] {} at net.minecraftforge.eventbus.EventBus.post(EventBus.java:315) ~[eventbus-6.0.5.jar%2352!/:?] {} at net.minecraftforge.eventbus.EventBus.post(EventBus.java:296) ~[eventbus-6.0.5.jar%2352!/:?] {} at net.minecraftforge.event.ForgeEventFactory.onPostServerTick(ForgeEventFactory.java:950) ~[forge-1.20.1-47.2.17-universal.jar%23138!/:?] {re:classloading} at net.minecraft.server.MinecraftServer.m_5705_(MinecraftServer.java:835) ~[server-1.20.1-20230612.114412-srg.jar%23133!/:?] {re:computing_frames,pl:accesstransformer:B,re:classloading,pl:accesstransformer:B,re:mixin,pl:accesstransformer:B} at net.minecraft.server.MinecraftServer.m_130011_(MinecraftServer.java:661) ~[server-1.20.1-20230612.114412-srg.jar%23133!/:?] {re:computing_frames,pl:accesstransformer:B,re:classloading,pl:accesstransformer:B,re:mixin,pl:accesstransformer:B} at net.minecraft.server.MinecraftServer.m_206580_(MinecraftServer.java:251) ~[server-1.20.1-20230612.114412-srg.jar%23133!/:?] {re:computing_frames,pl:accesstransformer:B,re:classloading,pl:accesstransformer:B,re:mixin,pl:accesstransformer:B} at java.lang.Thread.run(Thread.java:840) ~[?:?] {re:mixin}
    • okay i've managed to fix it. looks like i made the stupidest error known to man. i hadn't installed forge to the client, which i assumed only affected the launcher which wouldn't affect me because i used a third party one. evidently not. the more you know
    • tried a fresh install of above and beyond with java 8 installed. got a popup that says "Error: Unable to access jarfile forge-1.16.5-36.2.8.jar". every good programmer knows getting a different error means you've made progress!
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.