Jump to content

paulscode.sound.SoundSystem.CommandQueue client hangup (LWJGL3 in 1.12.2 please)


ZXQWAS
 Share

Recommended Posts

Sometimes (every 30 - 300 minutes), my Minecraft forge client just stops responding. The server part (I'm playing single player over LAN) still runs, I see that in ongoing debug logs, as well as in thread activity in JVisualVM. I do not see any errors in any logs, the client simply hangs, there is no crash, and this happens at "random".  I have thread dumps of two such occasions though, which seemingly show the same problem: "Thread-11" is blocking "Client thread" @ paulscode.sound.SoundSystem.CommandQueue(SoundSystem.java:2359). This Paul guy says Minecraft uses his lib: http://paulscode.com/forum/index.php?topic=34.0 .

 

Dumps:

https://pastebin.com/f22JNd1V

https://pastebin.com/Sbq5cur3

 

Some analysis here: http://fastthread.io/my-thread-report.jsp?p=c2hhcmVkLzIwMTgvMDYvMjUvLS1mZi50eHQtLTEtNDgtNDQ7Oy0tZGQudHh0LS0xLTQ4LTQ0

 

I tried killing this "Thread-11" via sysinternals process explorer (converted nid from hex to dec, but that thread was at the top of "process' properties / threads" per CPU usage anyway), this caused a BSOD (I missed two times before that though :)).

 

What could this be, is this a sound driver error, a sound lib incompatibility, something completely unrelated? Should I provide some other info?

Edited by ZXQWAS
Link to comment
Share on other sites

Could you let it run until the watchdog kills it and post your debug.log as well as the stall report the watchdog generates?

This is my Forum Signature, I am currently attempting to transform it into a small guide for fixing easier issues using spoiler blocks to keep things tidy.

 

As the most common issue I feel I should put this outside the main bulk:

The only official source for Forge is https://files.minecraftforge.net, and the only site I trust for getting mods is CurseForge.

If you use any site other than these, please take a look at the StopModReposts project and install their browser extension, I would also advise running a virus scan.

 

For players asking for assistance with Forge please expand the spoiler below and read the appropriate section(s) in its/their entirety.

Spoiler

Logs (Most issues require logs to diagnose):

Spoiler

Please post logs using one of the following sites (Thank you Lumber Wizard for the list):

https://gist.github.com/100MB Requires member (Free)

https://pastebin.com/: 512KB as guest, 10MB as Pro ($$$)

https://hastebin.com/: 400KB

Do NOT use sites like Mediafire, Dropbox, OneDrive, Google Drive, or a site that has a countdown before offering downloads.

 

What to provide:

...for Crashes and Runtime issues:

Minecraft 1.14.4 and newer:

Post debug.log

Older versions:

Please update...

 

...for Installer Issues:

Post your installer log, found in the same place you ran the installer

This log will be called either installer.log or named the same as the installer but with .log on the end

Note for Windows users:

Windows hides file extensions by default so the installer may appear without the .jar extension then when the .log is added the log will appear with the .jar extension

 

Where to get it:

Mojang Launcher: When using the Mojang launcher debug.log is found in .minecraft\logs.

 

Curse/Overwolf: If you are using the Curse Launcher, their configurations break Forge's log settings, fortunately there is an easier workaround than I originally thought, this works even with Curse's installation of the Minecraft launcher as long as it is not launched THROUGH Twitch:

Spoiler
  1. Make sure you have the correct version of Forge installed (some packs are heavily dependent on one specific build of Forge)
  2. Make a launcher profile targeting this version of Forge.
  3. Set the launcher profile's GameDir property to the pack's instance folder (not the instances folder, the folder that has the pack's name on it).
  4. Now launch the pack through that profile and follow the "Mojang Launcher" instructions above.

Video:

Spoiler

 

 

 

or alternately, 

 

Fallback ("No logs are generated"):

If you don't see logs generated in the usual place, provide the launcher_log.txt from .minecraft

 

Server Not Starting:

Spoiler

If your server does not start or a command window appears and immediately goes away, run the jar manually and provide the output.

 

Reporting Illegal/Inappropriate Adfocus Ads:

Spoiler

Get a screenshot of the URL bar or copy/paste the whole URL into a thread on the General Discussion board with a description of the Ad.

Lex will need the Ad ID contained in that URL to report it to Adfocus' support team.

 

Posting your mod as a GitHub Repo:

Spoiler

When you have an issue with your mod the most helpful thing you can do when asking for help is to provide your code to those helping you. The most convenient way to do this is via GitHub or another source control hub.

When setting up a GitHub Repo it might seem easy to just upload everything, however this method has the potential for mistakes that could lead to trouble later on, it is recommended to use a Git client or to get comfortable with the Git command line. The following instructions will use the Git Command Line and as such they assume you already have it installed and that you have created a repository.

 

  1. Open a command prompt (CMD, Powershell, Terminal, etc).
  2. Navigate to the folder you extracted Forge’s MDK to (the one that had all the licenses in).
  3. Run the following commands:
    1. git init
    2. git remote add origin [Your Repository's URL]
      • In the case of GitHub it should look like: https://GitHub.com/[Your Username]/[Repo Name].git
    3. git fetch
    4. git checkout --track origin/master
    5. git stage *
    6. git commit -m "[Your commit message]"
    7. git push
  4. Navigate to GitHub and you should now see most of the files.
    • note that it is intentional that some are not synced with GitHub and this is done with the (hidden) .gitignore file that Forge’s MDK has provided (hence the strictness on which folder git init is run from)
  5. Now you can share your GitHub link with those who you are asking for help.

[Workaround line, please ignore]

 

Link to comment
Share on other sites

I've let it run for maybe half an hour. What happened was that the process was suspended by windows10, almost immediately, so I had to unfreeze it first to be able to attach to it (with consequent skipped ticks message for the time of the freeze). Nothing else. When I kill the process, nothing  special happens.  When I let it run, it's just normal stuff like "Traveling merchant was slain by Slasher".

Link to comment
Share on other sites

I've replaced all jars in libraries\com\paulscode with corresponding ones from http://www.paulscode.com/forum/index.php?topic=4.0 (renaming to names present in minecraft), as they're all different sizes and seems like some are different dates as well. It's been doing well for the weekend, until right at the end it hung the same way. This may seem to happen only when I have render distance 16, never when 8, and I think probably only at nights. Might be because some bugged mob spawns, can't figure out how to find it out.

 

I've seen some more stacks @ process explorer today and would like to try LWJGL 3. Is there a 1.12.2 forge branch/build with LWJGL3? This here ( http://forum.lwjgl.org/index.php?topic=5610.0 ) implies that this is apparently not hard to do.

Link to comment
Share on other sites

I've decided to actually upload my debug.log, maybe someone else will see more in it than me. Maybe I'll also get more responses here too. :) There is no such thing as a watchdog killing the process, as well as no stall report either. I'd really like to have this solved. I'm a network engineer, not a developer, it would be hard for me to try to change the LWJGL version myself (could be an initiative to finally learn Eclipse, eh). I've seen couple of people did this already:  https://www.youtube.com/watch?v=WB_cN3NdHEw, https://www.youtube.com/watch?v=uijUFzF-R7c.

 

 

Debug log: https://gist.github.com/ZXQWAS/54873f48648826072759062d4344757e

 

 

I'm using legacy FTB launcher: http://ftb.cursecdn.com/FTB2/launcher/FTB_Launcher.exeThe hang happened at around 2:30 ~ 3:00 AM, I was afk, the backup that happened around that time interval is irrelevant.

 

This was never present in previous cases (I used grep on the unpacked logs folder):

[01:35:14] [Thread-11/ERROR] [net.minecraft.client.audio.SoundManager]: Error in class 'SourceLWJGL OpenAL'
[01:35:14] [Thread-11/ERROR] [net.minecraft.client.audio.SoundManager]: Channel null in method 'stop'

 

This was present multiple times, however in most cases I was able to play for many hours after this event:

[02:07:24] [main/WARN] [net.minecraft.client.audio.SoundManager]: Unable to play empty soundEvent: minecraft:entity.small_slime.squish
[02:07:24] [main/WARN] [net.minecraft.client.audio.SoundManager]: Unable to play empty soundEvent: minecraft:entity.small_slime.jump

 

I can't recognize anything else of relevance. I've killed the right thread from the first try this time, however this didn't help. I've disabled my Realtek High Definition Audio from device manager, however this didn't help too. I'm not running out of memory, I have a Xeon W-2125 with 32G of ECC RAM, with Xmx 10G. The motherboard's audio chip seems to be new and rare though, Realtek ALC S1220A. Is there a way to monitor this Thread-11 in a way to find out how it got stuck in this state? Is this forum even the right place for this report?

Link to comment
Share on other sites

Do you have this issue with a regular forge instance without any mods as this might help narrow down where things are going wrong?

I noticed it stalls right after it loads the resources for "youatemymother" and before it finishes loading "zeiyocraft" either could be the possible problem.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.