Jump to content

Keeping minecraft.mappings up to date with new versions of Forge Mdk


Recommended Posts

The recommended 1.12.2 - and even the current latest version 1.12.2 - has a minecraft.mappings set to snapshot_20171003 in the build.gradle file ... which is pretty old and from what I understand (correct me if I'm wrong :D) might not match the actual Minecraft version 1.12.2 the Forge version is targeting.


I ran across this when I started out writing my mod on and locally it was all fine and working since the decomp workspace provides the Minecraft source according to the mapping but when I built the jar and tried to run it on the Minecraft launcher for that Forge version I ran into the following exception:


Caused by: java.lang.NoSuchMethodError: com.modalstudio.mctribes.item.ItemBlueprint.setUnlocalizedName(Ljava/lang/String;)Lnet/minecraft/item/Item;


snapshot_20171003 was hip for Minecraft 1.12.0 source but 1.12.2 has removed that method in favor of setTranslationKey. Moving to stable_39 solved the case for me but it took me a while to figure out why upgrading to the latest Forge version didn't affect the issue at all - because I assumed that mappings are something you're keeping up to date and I wouldn't have to worry about :D So if at all possible I'd like to suggest modifying your build process to keep that minecraft.mappings up to date.

Link to comment
Share on other sites

1 hour ago, loordgek said:

how did you build your mod ?


Tried ./gradlew clean build on the following docker images: openjdk:8-jdk-slim, java:8 and atlassian/default-image:latest (java-8-openjdk-amd64), and the same on my local machine (jdk1.8.0_162). Cleared the workspace between switching the different Forge versions and reran setup steps described in the README. NoSuchMethodError persisted in launcher until I moved the mappings to stable_39.

Link to comment
Share on other sites

You can update the MDK's mapping version yourself. The one Forge uses is just the default that Forge was built with.

We usually don't update it on Forge's end because it's a useless change that really doesn't effect end users.

At the end of the day, mods get reobfed to SRG names. Which are stable and unique. If you're getting the NoSuchMethodException, then you're not building your mod correctly.

The mappings are PURELY for dev time.


So... No... Update it yourself.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.