Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.14.3 -> 1.14.4] Loot Tables stopped working


Recommended Posts

Somehow in updating from 1.14.3 to 1.14.4 my loot tables stopped working.

 

I know that I had them properly tested back on this branch and they were working (all blocks):

https://github.com/Draco18s/ReasonableRealism/tree/1.14.3/src/main/java/com/draco18s

 

But today they don't work on this branch:

https://github.com/Draco18s/ReasonableRealism/tree/1.14.4/src/main/java/com/draco18s

 

I didn't even touch loot tables. All I can figure is that the registration for them changed in some way that I can't identify (e.g. they are no longer automatically loaded).

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites
1 hour ago, Afroman said:

I tried one of your loot_table. Works fine on my project...

Weird.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

I keep poking at this to try and figure out what's going on.

 

If I make the JSON file invalid, it throws an error.

If I put a non-existent item in the JSON, nothing happens.

If everything's kosher, nothing happens.

 

Resource Location searched for is harderores:blocks/ore_hardiron. Loot table is data/harderores/loot_tables/blocks/ore_hardiron.json

 

The registeredLootTables map is fucking empty. There's nothing in it. No blocks of any kind drop anything.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

I had this "No blocks of any kind drop anything" happen to me a few times -- turned out to be a bad tag file that just caused the entire datapack loading (including loottables) init to abort...no warning that this had occured until i noticed that error in log file. Perhaps check for similar occurance

Edited by The_Wabbit
typo
Link to post
Share on other sites
4 minutes ago, The_Wabbit said:

I had this "No blocks of any kind drop anything" happen to me a few times -- turned out to be a bad tag file that just caused the entire datapack loading (including loottables) init to abort...no warning that this had occured until i noticed that error in log file. Perhaps check for similar occurance

Hmm.

Yeah, looks like I had a bad recipe or two. That did the trick. Seems really unhelpful that one bad data file causes all data files to be bad.

 

I'd been ignoring it because "I'm not worried about that right now, I want to test my enchantments."

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.