Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

How does the installer determine the Java installation it will use?


rushiku
 Share

Recommended Posts

Hi, I've downloaded the 1.14.4 Forge installer and can't get past an error.

 

Steps taken:

Install attempts:

- Download and run installer.

- Deal with installer, get to install bit, small window opens that states: "This application requires Java Runtime Environment 1.8.0".

- Close that, get sent to Oracle site to download Java 1.8

 

I do have more than one Java installation, including one that is 1.9, however

I have edited my Path to have only one Java install on it (the one in the Minecraft directory) and I have defined JAVA_HOME as that same directory.

 

java -version returns:

java version "1.8.0_51"
Java(TM) SE Runtime Environment (build 1.8.0_51-b16)
Java HotSpot(TM) 64-Bit Server VM (build 25.51-b03, mixed mode)

 

where java returns:

C:\Program Files (x86)\Minecraft\runtime\jre-x64\bin\java.exe

(it's actually defined, by me, as PROGRA~2, but Windows expanded it here)

 

So, getting back to the title, what do I need to do to help the Forge installer find the correct Java version?

Link to comment
Share on other sites

1.13+ installers are just jar files. So they will use whatever you have associated with the .jar extension.

You can try running https://johann.loefflmann.net/en/software/jarfix/index.html

If your path isnt setup right.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

This is starting to get frustrating...

I used the jarfix tool, which let me know that it updated the jar association to the Java 1.9 installation. 

The write up on the tool mentions using to the tool to avoid manually updating the registry, so I did exactly that.

(you're looking for the 'jarfile' entry, for anyone that's curious)

But still no joy.

Meanwhile, I tried entering javaw -jar forge.x.x.x.exe (and also copied it and renamed to .jar) in the command prompt, both complain about it being a corrupted jar, which it's not, because it will work if I double click on it.

 

Having run out of seemingly reasonable options, I finally gave in, uninstalled my 1.9 JDK, installed the 1.8 JRE, ran jarfix just in case, and Forge is now installing.

 

Thanks for the help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.