Jump to content

[workaround found] eclipse forge 1.14.4 unresolved dependency snapshot


frakier

Recommended Posts

From what I have gathered this is the process...(the process was different last time I played with any mods)
Now I know I have to make changes to make a mod this is just a straight up test to see if I can narrow down what was going on and was [sort of] surprised to get the same error on the forge example mod.
1. Create WORKSPACE "test.forge.mod".
2. Create the PROJECT_FOLDER"test" in the WORKSPACE "test.forge.mod".
3. Copy in the contents of forge-1.14.4-28.1.87-mdk.zip into the "test" PROJECT_FOLDER.
4. Start eclipse and select the PROJECT_FOLDER then "import projects"->"Gradle"->"import existing gradle project" [NEXT] select the "test" PROJECT_FOLDER and [finish]. let eclipse do its thing.
5. Run the Gradle task  "idle" -> "eclipse" then "fg_runs"->"genEclipseRuns".
6. Be sure and refresh select the PROJECT_FOLDER "test" and refresh [f5] (some 40 errors or so will come down to two errors).
6. When all is said and done the project has two problems...
..."Project 'test' is missing required library: 'C:\Windows\System32\unresolved dependency - net.minecraftforge forge 1.14.4-28.1.87_mapped_snapshot_20190719-1.14.3''
and
..."The project cannot be built until build path errors are resolved".

I have searched all over and even tried looking around in here, actually found a similar topic but it seemed to just die and there is another topic from today that was for intellij that could be similar but did not want to hijack their post by even explaining I was getting something similar in eclipse.
Any help would be appreciated.

EDIT: if there are any logs tell me where to find them and I will attach them.

ALSO...

ECLIPSE:

Eclipse IDE for Java Developers

Version: 2019-06 (4.12.0)
Build id: 20190614-1200

JAVA:
(due to the recent changes by oracle using the recommended openJDK, tried "Eclipse OpenJ9" but it did not work with [drum-roll please] eclipse had to switch to Hotspot  version)
(would not be surprised if this is the whole problem)
openjdk version "1.8.0_232"
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_232-b09)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.232-b09, mixed mode)

Edited by frakier
changed title
Link to comment
Share on other sites

IntelliJ worked though and using the AdoptOpenJDK, got to be something on the eclipse gradle side having problems.
 

1. Create WORKSPACE "test.forge.mod.intellij".
2. Create the PROJECT_FOLDER "intellijtest" in the WORKSPACE folder.
3. Copy in the contents of forge-1.14.4-28.1.87-mdk.zip into the PROJECT_FOLDER.
4. Right click the PROJECT_FOLDER and in the contexzt menuslect "open folder as intellij idea community edition project". Let intellij do its thing.
5. On the bottom left hand side of the window next to "build" and "TODO" find the Terminal and click it. Execute gradlew genIntellijRuns
...{had a problem had to set classpath} still a problem intellij using internal jdk {had to point to the AdoptOpenJDK folder}...
6. "Run"->"Edit Configurations"->"Run Client"...
...set the "Use classpath of module:" to intellijtest.main .. [Apply]
...set the "JRE:"->"Browse"[using the folder icon] to your java jdk folder [for me it was "C:\Program Files\AdoptOpenJDK\jdk-8.0.232.09-hotspot"] .. [Apply]
...[OK].."Run"->"runClient"


WORKED!!
 

INTELLIJ:

IntelliJ IDEA 2019.2.4 (Community Edition)
Build #IC-192.7142.36, built on October 29, 2019
Runtime version: 11.0.4+10-b304.77 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 725M
Cores: 4
Registry:
Non-Bundled Plugins:
 

JAVA:
(due to the recent changes by oracle using the recommended openJDK, tried "Eclipse OpenJ9" but it did not work with [drum-roll please] eclipse had to switch to Hotspot  version)
(would not be surprised if this is the whole problem)
openjdk version "1.8.0_232"
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_232-b09)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.232-b09, mixed mode)

 

Link to comment
Share on other sites

Well went back and tried the eclipse again and it worked, seems intellij is downloading/unpacking the needed dependencies [the snapshot stuff] into ".gradle\caches\forge_gradle" that eclipse is not doing correctly or at all.

Before there was this error...
...missing required library: 'C:\Windows\System32\unresolved dependency - net.minecraftforge forge 1.14.4-28.1.87_mapped_snapshot_20190719-1.14.3''

now completes with
C:\Users\{username}\.gradle\caches\forge_gradle\minecraft_user_repo\net\minecraftforge\forge\1.14.4-28.1.87_mapped_snapshot_20190719-1.14.3

Hope this helps someone else and if anyone knows where I should report this let me know.

Edited by frakier
said forge instead of eclipse
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • The mobs are moving normally for a second, then freeze, then go back to normal, and this repeats. I describe this as mob lag, bc they stutter as if they were lagging. I don't have the best wifi, but that shouldn't matter since its 10mbps which is enough for a server. I have 8 gigs of ram for it, no optimizations have worked, if there is anything more you may need to help lmk, ill describe. The modlist is pretty hefty: VS_ClockworkSurvivalSupportV1.4 aether-1.20.1-1.2.0-neoforge.jar alexsdelight-1.5.jar alexsmobs-1.22.7.jar appleskin-forge-mc1.20.1-2.5.1.jar backpacked-forge-1.20.1-2.2.5.jar balm-forge-1.20.1-7.2.1.jar bettervillage-forge-1.20.1-3.2.0.jar BiomesOPlenty-1.20.1-18.0.0.598.jar botarium-forge-1.20.1-2.3.2.jar CGM-Unofficial-1.4.11+Forge+1.20.1.jar citadel-2.5.2-1.20.1.jar clockwork-1.20.1-0.1.2-forge-05f5d5fbbb.jar configured-forge-1.20.1-2.2.2.jar connectivity-1.20.1-4.9.jar create-1.20.1-0.5.1.f.jar create-new-age-forge-1.20.1-1.1.2.jar createarmoryv0.6.1n.jar createbigcannons-forge-1.20.1-0.5.3.b.jar createchunkloading-1.6.0-forge.jar createdeco-2.0.1-1.20.1-forge.jar createdieselgenerators-1.20.1-1.2h.jar createendertransmission-2.0.7-1.20.1.jar create_misc_and_things_ 1.20.1_4.0A.jar cristellib-1.1.5-forge.jar cupboard-1.20.1-2.3.jar curios-forge-5.7.0+1.20.1.jar destroy-1.20.1-0.8.jar Dungeon Crawl-1.20.1-2.3.14.jar FallingTree-1.20.1-4.3.4.jar FarmersDelight-1.20.1-1.2.4.jar framework-forge-1.20.1-0.6.26.jar geckolib-forge-1.20.1-4.4.2.jar InsaneLib-1.12.1-mc1.20.1.jar Jade-1.20.1-forge-11.8.0.jar jei-1.20.1-forge-15.3.0.4.jar journeymap-1.20.1-5.9.18-forge.jar JustEnoughResources-1.20.1-1.4.0.247.jar kotlinforforge-4.10.0-all.jar l2library-2.4.23.jar libraryferret-forge-1.20.1-4.0.0.jar macawsbridgesbop-1.20-1.1.jar mcw-bridges-2.1.0-mc1.20.4forge.jar moonlight-1.20-2.9.17-forge.jar morevillagers-forge-1.20.1-5.0.0.jar Mo_ZombiesWave-1.20.1-0.1.0-forge.jar NaturesCompass-1.20.1-1.11.2-forge.jar Placebo-1.20.1-8.6.1.jar refinedstorage-1.12.4.jar soundphysics-forge-1.20.1-1.1.2.jar spark-1.10.53-forge.jar stealing_villagers-forge-1.20.1-1.0.0.jar s_a_b-1.3.0_1.20.1.jar takesapillage-1.0.3-1.20.1.jar TerraBlender-forge-1.20.1-3.0.1.4.jar tombstone-1.20.1-8.6.2.jar Towns-and-Towers-1.12-Fabric+Forge.jar twilightforest-1.20.1-4.3.2145-universal.jar valkyrienskies-120-2.1.3-beta.1.jar veinmining-forge-1.3.0+1.20.1.jar waystones-forge-1.20-14.1.3.jar YungsApi-1.20-Forge-4.0.3.jar YungsBetterDesertTemples-1.20-Forge-3.0.3.jar YungsBetterDungeons-1.20-Forge-4.0.3.jar YungsBetterEndIsland-1.20-Forge-2.0.5.jar YungsBetterJungleTemples-1.20-Forge-2.0.4.jar YungsBetterMineshafts-1.20-Forge-4.0.4.jar YungsBetterNetherFortresses-1.20-Forge-2.0.5.jar YungsBetterOceanMonuments-1.20-Forge-3.0.4.jar YungsBetterStrongholds-1.20-Forge-4.0.3.jar YungsBetterWitchHuts-1.20-Forge-3.0.3.jar YungsBridges-1.20-Forge-4.0.3.jar zaynens_leather_from_rotten_flesh_mod_1.20.1.jar
    • Thank you so much! Unfortunately before reading this I reinstalled my java installer. Now when I try to open the forge installer I receive an error message stating 'Unable to install Java' even though I have definitely downloaded and installed the latest version. Any idea what this could be or how I could fix it?  
    • IT WORKED! THANK YOU!
    • sorry for the stuborn ness ss   test code logs and planks return nothing on minable but i can use the other tags  name minecraft:oak_log BlockTags.LOGS name minecraft:oak_planks BlockTags.PLANKS   it kinda works but its not like like perfect             
    • I'm making a custom modpack for 1.20.1 and everything else seems to work except this Passive skilltree mod. The world loads fine but when I press the keybind to open the mod's GUI, the world immediately saves and crashes with this report: https://pastebin.com/svEPsRty Any help or insight towards the right direction is greatly appreciated!
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.