Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

custom block model rendered correctly in hand but not when placed [1.12.2]


Recommended Posts

so i have a custom model made for me and somehow the texture is glitched when placed but not when the player holds the item block and i dont know what it could be cause this is my first time using custom block models.

 

2019-11-20_20_14_04.thumb.png.ae30b737ef1f91c0e80b59771af91544.png

2019-11-20_20_15_47.thumb.png.59363e59ad8352b0f6f760aa2931b9f4.png

 

blockstate json file:

Spoiler

{
    "variants": {
        "normal": [
            { "model": "hxhmod:joystation" }
        ]
    }
}

 

model json file:

Spoiler

{
	"parent": "block/cube_all",
	"textures": {
		"0": "hxhmod:block/joystation"
	},
	"elements": [
		{
			"from": [3.1, 0, 3.6],
			"to": [12.9, 0.35, 12.4],
			"faces": {
				"north": {"uv": [11.622, 2.161, 13.082, 3.576], "texture": "#0"},
				"east": {"uv": [11.674, 2.08, 12.973, 3.488], "texture": "#0"},
				"south": {"uv": [11.703, 2.108, 12.944, 3.467], "texture": "#0"},
				"west": {"uv": [11.974, 2.161, 12.973, 3.512], "texture": "#0"},
				"up": {"uv": [11.864, 2.27, 12.972, 3.469], "texture": "#0"},
				"down": {"uv": [11.731, 2.056, 13.001, 3.359], "texture": "#0"}
			}
		},
		.
		.
		.

 

any ideas?

Link to post
Share on other sites
3 hours ago, eatthenight said:

any ideas?

Maybe change the uv's to not have decimals?

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to post
Share on other sites
18 hours ago, Animefan8888 said:

Maybe change the uv's to not have decimals?

I didnt made the model one of my modelers made it so i didnt know, anyway i overlooked this:

Texture hxhmod:textures/block/joystation.png with size 676x676 will have visual artifacts at mip level 4, it can only support level 2.
Please report to the mod author that the texture should be some multiple of 16x16.

so it has to do with the size of the texture

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.